aboutsummaryrefslogtreecommitdiff
path: root/graphics/goocanvas2
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-04 12:04:49 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-04 12:04:49 +0000
commit71a25c8cd8a7c6b47c98d06c7b6f9574a92e2968 (patch)
tree726336080d09c129a975efd7c0a998ea78293b73 /graphics/goocanvas2
parent135a87779b81fd1b47ec38bc9a88f8cfeb5ecd34 (diff)
downloadports-71a25c8cd8a7c6b47c98d06c7b6f9574a92e2968.tar.gz
ports-71a25c8cd8a7c6b47c98d06c7b6f9574a92e2968.zip
Remove obsolete patch, Forgotten in 2.0.2 update.
Notes
Notes: svn path=/head/; revision=335617
Diffstat (limited to 'graphics/goocanvas2')
-rw-r--r--graphics/goocanvas2/files/patch-introspection846
1 files changed, 0 insertions, 846 deletions
diff --git a/graphics/goocanvas2/files/patch-introspection b/graphics/goocanvas2/files/patch-introspection
deleted file mode 100644
index 56922cb94876..000000000000
--- a/graphics/goocanvas2/files/patch-introspection
+++ /dev/null
@@ -1,846 +0,0 @@
-From 2088843efb50f05b8965340eddbf7c0103c6eef1 Mon Sep 17 00:00:00 2001
-From: Jasper Lievisse Adriaanse <jasper@humppa.nl>
-Date: Thu, 28 Mar 2013 10:22:08 +0000
-Subject: Use GObject.Object instead of GLib.Object in introspection annotations
-
----
-diff --git a/src/goocanvasitem.c b/src/goocanvasitem.c
-index 42e2493..bbbfcaf 100644
---- src/goocanvasitem.c
-+++ src/goocanvasitem.c
-@@ -397,7 +397,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- /**
- * GooCanvasItem::child-notify
- * @item: the item that received the signal.
-- * @pspec: (type GLib.ParamSpec): the #GParamSpec of the changed child property.
-+ * @pspec: (type GObject.ParamSpec): the #GParamSpec of the changed child property.
- *
- * Emitted for each child property that has changed.
- * The signal's detail holds the property name.
-diff --git a/src/goocanvasitemmodel.c b/src/goocanvasitemmodel.c
-index ac9b330..d8e90cf 100644
---- src/goocanvasitemmodel.c
-+++ src/goocanvasitemmodel.c
-@@ -186,7 +186,7 @@ goo_canvas_item_model_base_init (gpointer g_iface)
- /**
- * GooCanvasItemModel::child-notify
- * @item: the item model that received the signal.
-- * @pspec: (type GLib.ParamSpec): the #GParamSpec of the changed child property.
-+ * @pspec: (type GObject.ParamSpec): the #GParamSpec of the changed child property.
- *
- * Emitted for each child property that has changed.
- * The signal's detail holds the property name.
-@@ -1126,7 +1126,7 @@ goo_canvas_item_model_class_install_child_property (GObjectClass *mclass,
- *
- * It finds a child property of a canvas item class by name.
- *
-- * Returns: (type GLib.ParamSpec) (transfer none): The #GParamSpec of the child
-+ * Returns: (type GObject.ParamSpec) (transfer none): The #GParamSpec of the child
- * property or %NULL if @class has no child property with that name.
- */
- GParamSpec*
-@@ -1152,7 +1152,7 @@ goo_canvas_item_model_class_find_child_property (GObjectClass *mclass,
- *
- * It returns all child properties of a canvas item class.
- *
-- * Returns: (array length=n_properties) (element-type GLib.ParamSpec) (transfer container):
-+ * Returns: (array length=n_properties) (element-type GObject.ParamSpec) (transfer container):
- * a newly allocated array of #GParamSpec*. The array must be freed with g_free().
- */
- GParamSpec**
---
-cgit v0.9.1
-From bfc08d9a34c5d3d598aa025dd514a11226dfe1be Mon Sep 17 00:00:00 2001
-From: Murray Cumming <murrayc@murrayc.com>
-Date: Thu, 28 Mar 2013 12:27:41 +0000
-Subject: Fix some introspection generation warnings.
-
- Avoid gobject-introspection warnings about missing : in
- documentation comments.
- Part of bug #696736
----
-diff --git a/ChangeLog b/ChangeLog
-index 8b8605a..a26f355 100644
---- ChangeLog
-+++ ChangeLog
-@@ -1,3 +1,11 @@
-+2013-03-28 Murray Cumming <murrayc@murrayc.com>
-+
-+ Fix some introspection generation warnings.
-+
-+ Avoid gobject-introspection warnings about missing : in
-+ documentation comments.
-+ Part of bug #696736
-+
- 2011-10-19 Jasper Lievisse Adriaanse <jasperla@gnome.org>
-
- * configure.in: Bump pygobject dependency to 2.90.4. Bug #661487.
-diff --git a/src/goocanvas.c b/src/goocanvas.c
-index 3933b31..d636fc5 100644
---- src/goocanvas.c
-+++ src/goocanvas.c
-@@ -420,7 +420,7 @@ goo_canvas_class_init (GooCanvasClass *klass)
- G_PARAM_WRITABLE));
-
- /**
-- * GooCanvas:background-color-gdk-rgba
-+ * GooCanvas:background-color-gdk-rgba:
- *
- * The color to use for the canvas background, specified as a GdkRGBA.
- *
-@@ -463,7 +463,7 @@ goo_canvas_class_init (GooCanvasClass *klass)
- /* Signals. */
-
- /**
-- * GooCanvas::item-created
-+ * GooCanvas::item-created:
- * @canvas: the canvas.
- * @item: the new item.
- * @model: the item's model.
-diff --git a/src/goocanvas.h b/src/goocanvas.h
-index a7f41dd..9e342b0 100644
---- src/goocanvas.h
-+++ src/goocanvas.h
-@@ -34,7 +34,7 @@ G_BEGIN_DECLS
- typedef struct _GooCanvasClass GooCanvasClass;
-
- /**
-- * GooCanvas
-+ * GooCanvas:
- *
- * The #GooCanvas-struct struct contains private data only.
- */
-@@ -162,7 +162,8 @@ struct _GooCanvas
- };
-
- /**
-- * GooCanvasClass
-+ * GooCanvasClass:
-+ *
- * @create_item: a virtual method that subclasses may override to create custom
- * canvas items for item models.
- * @item_created: signal emitted when a new canvas item has been created.
-diff --git a/src/goocanvasellipse.h b/src/goocanvasellipse.h
-index 0b15263..0e62acd 100644
---- src/goocanvasellipse.h
-+++ src/goocanvasellipse.h
-@@ -33,7 +33,7 @@ typedef struct _GooCanvasEllipse GooCanvasEllipse;
- typedef struct _GooCanvasEllipseClass GooCanvasEllipseClass;
-
- /**
-- * GooCanvasEllipse
-+ * GooCanvasEllipse:
- *
- * The #GooCanvasEllipse-struct struct contains private data only.
- */
-@@ -81,7 +81,7 @@ typedef struct _GooCanvasEllipseModel GooCanvasEllipseModel;
- typedef struct _GooCanvasEllipseModelClass GooCanvasEllipseModelClass;
-
- /**
-- * GooCanvasEllipseModel
-+ * GooCanvasEllipseModel:
- *
- * The #GooCanvasEllipseModel-struct struct contains private data only.
- */
-diff --git a/src/goocanvasgrid.c b/src/goocanvasgrid.c
-index d9f635d..fa585d2 100644
---- src/goocanvasgrid.c
-+++ src/goocanvasgrid.c
-@@ -247,7 +247,7 @@ goo_canvas_grid_install_common_properties (GObjectClass *gobject_class)
- G_PARAM_READWRITE));
-
- /**
-- * GooCanvasGrid:horz-grid-line-color-gdk-rgba
-+ * GooCanvasGrid:horz-grid-line-color-gdk-rgba:
- *
- * The color to use for the horizontal grid lines, specified as a GdkRGBA.
- *
-@@ -282,7 +282,7 @@ goo_canvas_grid_install_common_properties (GObjectClass *gobject_class)
- G_PARAM_READWRITE));
-
- /**
-- * GooCanvasGrid:vert-grid-line-color-gdk-rgba
-+ * GooCanvasGrid:vert-grid-line-color-gdk-rgba:
- *
- * The color to use for the vertical grid lines, specified as a GdkRGBA.
- *
-@@ -317,7 +317,7 @@ goo_canvas_grid_install_common_properties (GObjectClass *gobject_class)
- G_PARAM_READWRITE));
-
- /**
-- * GooCanvasGrid:border-color-gdk-rgba
-+ * GooCanvasGrid:border-color-gdk-rgba:
- *
- * The color to use for the border, specified as a GdkRGBA.
- *
-diff --git a/src/goocanvasgrid.h b/src/goocanvasgrid.h
-index fa70e2e..7d233bc 100644
---- src/goocanvasgrid.h
-+++ src/goocanvasgrid.h
-@@ -59,7 +59,7 @@ typedef struct _GooCanvasGrid GooCanvasGrid;
- typedef struct _GooCanvasGridClass GooCanvasGridClass;
-
- /**
-- * GooCanvasGrid
-+ * GooCanvasGrid:
- *
- * The #GooCanvasGrid-struct struct contains private data only.
- */
-@@ -110,7 +110,7 @@ typedef struct _GooCanvasGridModel GooCanvasGridModel;
- typedef struct _GooCanvasGridModelClass GooCanvasGridModelClass;
-
- /**
-- * GooCanvasGridModel
-+ * GooCanvasGridModel:
- *
- * The #GooCanvasGridModel-struct struct contains private data only.
- */
-diff --git a/src/goocanvasgroup.h b/src/goocanvasgroup.h
-index 75e28cd..9c5b50c 100644
---- src/goocanvasgroup.h
-+++ src/goocanvasgroup.h
-@@ -29,7 +29,7 @@ typedef struct _GooCanvasGroupModel GooCanvasGroupModel;
- typedef struct _GooCanvasGroupModelClass GooCanvasGroupModelClass;
-
- /**
-- * GooCanvasGroup
-+ * GooCanvasGroup:
- *
- * The #GooCanvasGroup-struct struct contains private data only.
- */
-@@ -72,7 +72,7 @@ GooCanvasItem* goo_canvas_group_new (GooCanvasItem *parent,
-
-
- /**
-- * GooCanvasGroupModel
-+ * GooCanvasGroupModel:
- *
- * The #GooCanvasGroupModel-struct struct contains private data only.
- */
-diff --git a/src/goocanvasimage.h b/src/goocanvasimage.h
-index a97364f..aa588c5 100644
---- src/goocanvasimage.h
-+++ src/goocanvasimage.h
-@@ -35,7 +35,7 @@ typedef struct _GooCanvasImage GooCanvasImage;
- typedef struct _GooCanvasImageClass GooCanvasImageClass;
-
- /**
-- * GooCanvasImage
-+ * GooCanvasImage:
- *
- * The #GooCanvasImage-struct struct contains private data only.
- */
-@@ -82,7 +82,7 @@ typedef struct _GooCanvasImageModel GooCanvasImageModel;
- typedef struct _GooCanvasImageModelClass GooCanvasImageModelClass;
-
- /**
-- * GooCanvasImageModel
-+ * GooCanvasImageModel:
- *
- * The #GooCanvasImageModel-struct struct contains private data only.
- */
-diff --git a/src/goocanvasitem.c b/src/goocanvasitem.c
-index bbbfcaf..fc03146 100644
---- src/goocanvasitem.c
-+++ src/goocanvasitem.c
-@@ -117,7 +117,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- /* Mouse events. */
-
- /**
-- * GooCanvasItem::enter-notify-event
-+ * GooCanvasItem::enter-notify-event:
- * @item: the item that received the signal.
- * @target_item: the target of the event.
- * @event: the event data. The x & y fields contain the mouse position
-@@ -142,7 +142,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- GDK_TYPE_EVENT | G_SIGNAL_TYPE_STATIC_SCOPE);
-
- /**
-- * GooCanvasItem::leave-notify-event
-+ * GooCanvasItem::leave-notify-event:
- * @item: the item that received the signal.
- * @target_item: the target of the event.
- * @event: the event data. The x & y fields contain the mouse position
-@@ -167,7 +167,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- GDK_TYPE_EVENT | G_SIGNAL_TYPE_STATIC_SCOPE);
-
- /**
-- * GooCanvasItem::motion-notify-event
-+ * GooCanvasItem::motion-notify-event:
- * @item: the item that received the signal.
- * @target_item: the target of the event.
- * @event: the event data. The x & y fields contain the mouse position
-@@ -192,7 +192,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- GDK_TYPE_EVENT | G_SIGNAL_TYPE_STATIC_SCOPE);
-
- /**
-- * GooCanvasItem::button-press-event
-+ * GooCanvasItem::button-press-event:
- * @item: the item that received the signal.
- * @target_item: the target of the event.
- * @event: the event data. The x & y fields contain the mouse position
-@@ -217,7 +217,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- GDK_TYPE_EVENT | G_SIGNAL_TYPE_STATIC_SCOPE);
-
- /**
-- * GooCanvasItem::button-release-event
-+ * GooCanvasItem::button-release-event:
- * @item: the item that received the signal.
- * @target_item: the target of the event.
- * @event: the event data. The x & y fields contain the mouse position
-@@ -245,7 +245,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- /* Keyboard events. */
-
- /**
-- * GooCanvasItem::focus-in-event
-+ * GooCanvasItem::focus-in-event:
- * @item: the item that received the signal.
- * @target_item: the target of the event.
- * @event: the event data.
-@@ -268,7 +268,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- GDK_TYPE_EVENT | G_SIGNAL_TYPE_STATIC_SCOPE);
-
- /**
-- * GooCanvasItem::focus-out-event
-+ * GooCanvasItem::focus-out-event:
- * @item: the item that received the signal.
- * @target_item: the target of the event.
- * @event: the event data.
-@@ -291,7 +291,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- GDK_TYPE_EVENT | G_SIGNAL_TYPE_STATIC_SCOPE);
-
- /**
-- * GooCanvasItem::key-press-event
-+ * GooCanvasItem::key-press-event:
- * @item: the item that received the signal.
- * @target_item: the target of the event.
- * @event: the event data.
-@@ -315,7 +315,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- GDK_TYPE_EVENT | G_SIGNAL_TYPE_STATIC_SCOPE);
-
- /**
-- * GooCanvasItem::key-release-event
-+ * GooCanvasItem::key-release-event:
- * @item: the item that received the signal.
- * @target_item: the target of the event.
- * @event: the event data.
-@@ -371,7 +371,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- GTK_TYPE_TOOLTIP);
-
- /**
-- * GooCanvasItem::grab-broken-event
-+ * GooCanvasItem::grab-broken-event:
- * @item: the item that received the signal.
- * @target_item: the target of the event.
- * @event: the event data.
-@@ -395,7 +395,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- GDK_TYPE_EVENT | G_SIGNAL_TYPE_STATIC_SCOPE);
-
- /**
-- * GooCanvasItem::child-notify
-+ * GooCanvasItem::child-notify:
- * @item: the item that received the signal.
- * @pspec: (type GObject.ParamSpec): the #GParamSpec of the changed child property.
- *
-@@ -413,7 +413,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- G_TYPE_PARAM);
-
- /**
-- * GooCanvasItem::animation-finished
-+ * GooCanvasItem::animation-finished:
- * @item: the item that received the signal.
- * @stopped: if the animation was explicitly stopped.
- *
-@@ -430,7 +430,7 @@ goo_canvas_item_base_init (gpointer g_iface)
- G_TYPE_BOOLEAN);
-
- /**
-- * GooCanvasItem::scroll-event
-+ * GooCanvasItem::scroll-event:
- * @item: the item that received the signal.
- * @target_item: the target of the event.
- * @event: the event data. The x & y fields contain the mouse position
-diff --git a/src/goocanvasitem.h b/src/goocanvasitem.h
-index d86c3bc..2f435c1 100644
---- src/goocanvasitem.h
-+++ src/goocanvasitem.h
-@@ -65,7 +65,7 @@ typedef struct _GooCanvasItemModel GooCanvasItemModel;
-
-
- /**
-- * GooCanvasItem
-+ * GooCanvasItem:
- *
- * #GooCanvasItem is a typedef used for objects that implement the
- * #GooCanvasItem interface.
-@@ -77,7 +77,8 @@ typedef struct _GooCanvasItem GooCanvasItem;
-
-
- /**
-- * GooCanvasItemIface
-+ * GooCanvasItemIface:
-+ *
- * @get_canvas: returns the canvas the item is in.
- * @set_canvas: sets the canvas the item is in.
- * @get_n_children: returns the number of children of the item.
-diff --git a/src/goocanvasitemmodel.c b/src/goocanvasitemmodel.c
-index d8e90cf..83e964d 100644
---- src/goocanvasitemmodel.c
-+++ src/goocanvasitemmodel.c
-@@ -115,7 +115,7 @@ goo_canvas_item_model_base_init (gpointer g_iface)
- _goo_canvas_item_model_child_property_notify_context = &cpn_context;
-
- /**
-- * GooCanvasItemModel::child-added
-+ * GooCanvasItemModel::child-added:
- * @model: the item model that received the signal.
- * @child_num: the index of the new child.
- *
-@@ -132,7 +132,7 @@ goo_canvas_item_model_base_init (gpointer g_iface)
- G_TYPE_INT);
-
- /**
-- * GooCanvasItemModel::child-moved
-+ * GooCanvasItemModel::child-moved:
- * @model: the item model that received the signal.
- * @old_child_num: the old index of the child.
- * @new_child_num: the new index of the child.
-@@ -150,7 +150,7 @@ goo_canvas_item_model_base_init (gpointer g_iface)
- G_TYPE_INT, G_TYPE_INT);
-
- /**
-- * GooCanvasItemModel::child-removed
-+ * GooCanvasItemModel::child-removed:
- * @model: the item model that received the signal.
- * @child_num: the index of the child that was removed.
- *
-@@ -167,7 +167,7 @@ goo_canvas_item_model_base_init (gpointer g_iface)
- G_TYPE_INT);
-
- /**
-- * GooCanvasItemModel::changed
-+ * GooCanvasItemModel::changed:
- * @model: the item model that received the signal.
- * @recompute_bounds: if the bounds of the item need to be recomputed.
- *
-@@ -184,7 +184,7 @@ goo_canvas_item_model_base_init (gpointer g_iface)
- G_TYPE_BOOLEAN);
-
- /**
-- * GooCanvasItemModel::child-notify
-+ * GooCanvasItemModel::child-notify:
- * @item: the item model that received the signal.
- * @pspec: (type GObject.ParamSpec): the #GParamSpec of the changed child property.
- *
-@@ -202,7 +202,7 @@ goo_canvas_item_model_base_init (gpointer g_iface)
- G_TYPE_PARAM);
-
- /**
-- * GooCanvasItemModel::animation-finished
-+ * GooCanvasItemModel::animation-finished:
- * @item: the item model that received the signal.
- * @stopped: if the animation was explicitly stopped.
- *
-diff --git a/src/goocanvasitemmodel.h b/src/goocanvasitemmodel.h
-index c32f7ef..de374c9 100644
---- src/goocanvasitemmodel.h
-+++ src/goocanvasitemmodel.h
-@@ -20,7 +20,7 @@ G_BEGIN_DECLS
-
-
- /**
-- * GooCanvasItemModel
-+ * GooCanvasItemModel:
- *
- * #GooCanvasItemModel is a typedef used for objects that implement the
- * #GooCanvasItemModel interface.
-@@ -33,7 +33,8 @@ G_BEGIN_DECLS
-
-
- /**
-- * GooCanvasItemModelIface
-+ * GooCanvasItemModelIface:
-+ *
- * @get_n_children: returns the number of children of the model.
- * @get_child: returns the child at the given index.
- * @add_child: adds a child.
-diff --git a/src/goocanvasitemsimple.c b/src/goocanvasitemsimple.c
-index 3603ea1..db312e3 100644
---- src/goocanvasitemsimple.c
-+++ src/goocanvasitemsimple.c
-@@ -273,7 +273,7 @@ goo_canvas_item_simple_install_common_properties (GObjectClass *gobject_class)
- G_PARAM_READWRITE));
-
- /**
-- * GooCanvasItemSimple:fill-color-gdk-rgba
-+ * GooCanvasItemSimple:fill-color-gdk-rgba:
- *
- * The color to use to paint the interior of the item, specified as a GdkRGBA. To disable painting set the 'fill-pattern' property to NULL.
- *
-@@ -322,7 +322,7 @@ goo_canvas_item_simple_install_common_properties (GObjectClass *gobject_class)
- "tooltip");
-
- /**
-- * GooCanvasItemSimple:clip-path
-+ * GooCanvasItemSimple:clip-path:
- *
- * The sequence of commands describing the clip path of the item, specified
- * as a string using the same syntax
-@@ -330,7 +330,7 @@ goo_canvas_item_simple_install_common_properties (GObjectClass *gobject_class)
- * Graphics (SVG)</ulink> path element.
- */
- /**
-- * GooCanvasItemModelSimple:clip-path
-+ * GooCanvasItemModelSimple:clip-path:
- *
- * The sequence of commands describing the clip path of the item, specified
- * as a string using the same syntax
-diff --git a/src/goocanvasitemsimple.h b/src/goocanvasitemsimple.h
-index 39ad00f..534d71b 100644
---- src/goocanvasitemsimple.h
-+++ src/goocanvasitemsimple.h
-@@ -17,7 +17,8 @@ G_BEGIN_DECLS
-
-
- /**
-- * GooCanvasItemSimpleData
-+ * GooCanvasItemSimpleData:
-+ *
- * @style: the style to draw with.
- * @transform: the transformation matrix of the item, or %NULL.
- * @clip_path_commands: an array of #GooCanvasPathCommand specifying the clip
-@@ -76,7 +77,8 @@ typedef struct _GooCanvasItemSimpleClass GooCanvasItemSimpleClass;
- typedef struct _GooCanvasItemModelSimple GooCanvasItemModelSimple;
-
- /**
-- * GooCanvasItemSimple
-+ * GooCanvasItemSimple:
-+ *
- * @canvas: the canvas.
- * @parent: the parent item.
- * @model: the item's model, if it has one.
-@@ -111,7 +113,8 @@ struct _GooCanvasItemSimple
- };
-
- /**
-- * GooCanvasItemSimpleClass
-+ * GooCanvasItemSimpleClass:
-+ *
- * @simple_create_path: simple subclasses that draw basic shapes and paths only
- * need to override this one method. It creates the path for the item.
- * All updating, painting and hit-testing is provided automatically by the
-@@ -202,7 +205,8 @@ void goo_canvas_item_simple_set_model (GooCanvasItemSimple *item,
- typedef struct _GooCanvasItemModelSimpleClass GooCanvasItemModelSimpleClass;
-
- /**
-- * GooCanvasItemModelSimple
-+ * GooCanvasItemModelSimple:
-+ *
- * @parent: the parent model.
- * @simple_data: data used by the canvas item for viewing the model.
- *
-diff --git a/src/goocanvaspath.c b/src/goocanvaspath.c
-index 53486dd..e9b0d03 100644
---- src/goocanvaspath.c
-+++ src/goocanvaspath.c
-@@ -59,7 +59,7 @@ static void
- goo_canvas_path_install_common_properties (GObjectClass *gobject_class)
- {
- /**
-- * GooCanvasPath:data
-+ * GooCanvasPath:data:
- *
- * The sequence of path commands, specified as a string using the same syntax
- * as in the <ulink url="http://www.w3.org/Graphics/SVG/">Scalable Vector
-diff --git a/src/goocanvaspath.h b/src/goocanvaspath.h
-index 5b11e61..3ccd8d4 100644
---- src/goocanvaspath.h
-+++ src/goocanvaspath.h
-@@ -34,7 +34,7 @@ typedef struct _GooCanvasPath GooCanvasPath;
- typedef struct _GooCanvasPathClass GooCanvasPathClass;
-
- /**
-- * GooCanvasPath
-+ * GooCanvasPath:
- *
- * The #GooCanvasPath-struct struct contains private data only.
- */
-@@ -79,7 +79,7 @@ typedef struct _GooCanvasPathModel GooCanvasPathModel;
- typedef struct _GooCanvasPathModelClass GooCanvasPathModelClass;
-
- /**
-- * GooCanvasPathModel
-+ * GooCanvasPathModel:
- *
- * The #GooCanvasPathModel-struct struct contains private data only.
- */
-diff --git a/src/goocanvaspolyline.h b/src/goocanvaspolyline.h
-index 2ce724e..a33d3a3 100644
---- src/goocanvaspolyline.h
-+++ src/goocanvaspolyline.h
-@@ -14,7 +14,8 @@ G_BEGIN_DECLS
-
-
- /**
-- * GooCanvasPoints
-+ * GooCanvasPoints:
-+ *
- * @coords: the coordinates of the points, in pairs.
- * @num_points: the number of points.
- * @ref_count: the reference count of the struct.
-@@ -81,7 +82,7 @@ typedef struct _GooCanvasPolyline GooCanvasPolyline;
- typedef struct _GooCanvasPolylineClass GooCanvasPolylineClass;
-
- /**
-- * GooCanvasPolyline
-+ * GooCanvasPolyline:
- *
- * The #GooCanvasPolyline-struct struct contains private data only.
- */
-@@ -134,7 +135,7 @@ typedef struct _GooCanvasPolylineModel GooCanvasPolylineModel;
- typedef struct _GooCanvasPolylineModelClass GooCanvasPolylineModelClass;
-
- /**
-- * GooCanvasPolylineModel
-+ * GooCanvasPolylineModel:
- *
- * The #GooCanvasPolylineModel-struct struct contains private data only.
- */
-diff --git a/src/goocanvasrect.h b/src/goocanvasrect.h
-index 4d92928..653a6bb 100644
---- src/goocanvasrect.h
-+++ src/goocanvasrect.h
-@@ -33,7 +33,7 @@ typedef struct _GooCanvasRect GooCanvasRect;
- typedef struct _GooCanvasRectClass GooCanvasRectClass;
-
- /**
-- * GooCanvasRect
-+ * GooCanvasRect:
- *
- * The #GooCanvasRect-struct struct contains private data only.
- */
-@@ -81,7 +81,7 @@ typedef struct _GooCanvasRectModel GooCanvasRectModel;
- typedef struct _GooCanvasRectModelClass GooCanvasRectModelClass;
-
- /**
-- * GooCanvasRectModel
-+ * GooCanvasRectModel:
- *
- * The #GooCanvasRectModel-struct struct contains private data only.
- */
-diff --git a/src/goocanvasstyle.h b/src/goocanvasstyle.h
-index ec76640..697f279 100644
---- src/goocanvasstyle.h
-+++ src/goocanvasstyle.h
-@@ -28,7 +28,7 @@ extern GQuark goo_canvas_style_hint_metrics_id;
-
-
- /**
-- * GooCanvasStyleProperty
-+ * GooCanvasStyleProperty:
- * @id: the unique property identifier.
- * @value: the value of the property.
- *
-@@ -54,7 +54,7 @@ typedef struct _GooCanvasStyle GooCanvasStyle;
- typedef struct _GooCanvasStyleClass GooCanvasStyleClass;
-
- /**
-- * GooCanvasStyle
-+ * GooCanvasStyle:
- * @parent: the parent style.
- * @properties: an array of #GooCanvasStyleProperty property settings.
- *
-diff --git a/src/goocanvastable.h b/src/goocanvastable.h
-index e204657..b584855 100644
---- src/goocanvastable.h
-+++ src/goocanvastable.h
-@@ -60,7 +60,7 @@ typedef struct _GooCanvasTable GooCanvasTable;
- typedef struct _GooCanvasTableClass GooCanvasTableClass;
-
- /**
-- * GooCanvasTable
-+ * GooCanvasTable:
- *
- * The #GooCanvasTable-struct struct contains private data only.
- */
-@@ -104,7 +104,7 @@ typedef struct _GooCanvasTableModel GooCanvasTableModel;
- typedef struct _GooCanvasTableModelClass GooCanvasTableModelClass;
-
- /**
-- * GooCanvasTableModel
-+ * GooCanvasTableModel:
- *
- * The #GooCanvasTableModel-struct struct contains private data only.
- */
-diff --git a/src/goocanvastext.h b/src/goocanvastext.h
-index 8569a48..183120b 100644
---- src/goocanvastext.h
-+++ src/goocanvastext.h
-@@ -39,7 +39,7 @@ typedef struct _GooCanvasText GooCanvasText;
- typedef struct _GooCanvasTextClass GooCanvasTextClass;
-
- /**
-- * GooCanvasText
-+ * GooCanvasText:
- *
- * The #GooCanvasText-struct struct contains private data only.
- */
-@@ -92,7 +92,7 @@ typedef struct _GooCanvasTextModel GooCanvasTextModel;
- typedef struct _GooCanvasTextModelClass GooCanvasTextModelClass;
-
- /**
-- * GooCanvasTextModel
-+ * GooCanvasTextModel:
- *
- * The #GooCanvasTextModel-struct struct contains private data only.
- */
-diff --git a/src/goocanvasutils.h b/src/goocanvasutils.h
-index ddc58bd..65700af 100644
---- src/goocanvasutils.h
-+++ src/goocanvasutils.h
-@@ -17,7 +17,8 @@ G_BEGIN_DECLS
- */
-
- /**
-- * GooCanvasPointerEvents
-+ * GooCanvasPointerEvents:
-+ *
- * @GOO_CANVAS_EVENTS_VISIBLE_MASK: a mask indicating that the item only
- * receives events when it is visible.
- * @GOO_CANVAS_EVENTS_PAINTED_MASK: a mask indicating that the item only
-@@ -66,7 +67,8 @@ typedef enum
-
-
- /**
-- * GooCanvasItemVisibility
-+ * GooCanvasItemVisibility:
-+ *
- * @GOO_CANVAS_ITEM_HIDDEN: the item is invisible, and is not allocated any
- * space in layout container items such as #GooCanvasTable.
- * @GOO_CANVAS_ITEM_INVISIBLE: the item is invisible, but it is still allocated
-@@ -91,7 +93,8 @@ typedef enum
-
-
- /**
-- * GooCanvasPathCommandType
-+ * GooCanvasPathCommandType:
-+ *
- * @GOO_CANVAS_PATH_MOVE_TO: move to the given point.
- * @GOO_CANVAS_PATH_CLOSE_PATH: close the current path, drawing a line from the
- * current position to the start of the path.
-@@ -140,7 +143,8 @@ typedef enum
-
-
- /**
-- * GooCanvasAnchorType
-+ * GooCanvasAnchorType:
-+ *
- * @GOO_CANVAS_ANCHOR_CENTER: the anchor is in the center of the object.
- * @GOO_CANVAS_ANCHOR_NORTH: the anchor is at the top of the object, centered horizontally.
- * @GOO_CANVAS_ANCHOR_NORTH_WEST: the anchor is at the top-left of the object.
-@@ -189,7 +193,7 @@ typedef union _GooCanvasPathCommand GooCanvasPathCommand;
- we can always use it whatever type of command it is. */
-
- /**
-- * GooCanvasPathCommand
-+ * GooCanvasPathCommand:
- *
- * GooCanvasPathCommand holds the data for each command in the path.
- *
-@@ -235,7 +239,8 @@ void goo_canvas_create_path (GArray *commands,
- typedef struct _GooCanvasLineDash GooCanvasLineDash;
-
- /**
-- * GooCanvasLineDash
-+ * GooCanvasLineDash:
-+ *
- * @ref_count: the reference count of the struct.
- * @num_dashes: the number of dashes and gaps between them.
- * @dashes: the sizes of each dash and gap.
-@@ -266,7 +271,7 @@ typedef cairo_pattern_t GooCairoPattern;
- #endif
-
- /**
-- * GooCairoAntialias
-+ * GooCairoAntialias:
- *
- * #GooCairoAntialias is simply a wrapper for the #cairo_antialias_t type,
- * allowing it to be used for #GObject properties.
-@@ -275,7 +280,7 @@ typedef cairo_pattern_t GooCairoPattern;
- */
-
- /**
-- * GooCairoFillRule
-+ * GooCairoFillRule:
- *
- * #GooCairoFillRule is simply a wrapper for the #cairo_fill_rule_t type,
- * allowing it to be used for #GObject properties.
-@@ -284,7 +289,7 @@ typedef cairo_pattern_t GooCairoPattern;
- */
-
- /**
-- * GooCairoHintMetrics
-+ * GooCairoHintMetrics:
- *
- * #GooCairoHintMetrics is simply a wrapper for the #cairo_hint_metrics_t type,
- * allowing it to be used for #GObject properties.
-@@ -293,7 +298,7 @@ typedef cairo_pattern_t GooCairoPattern;
- */
-
- /**
-- * GooCairoLineCap
-+ * GooCairoLineCap:
- *
- * #GooCairoLineCap is simply a wrapper for the #cairo_line_cap_t type,
- * allowing it to be used for #GObject properties.
-@@ -302,7 +307,7 @@ typedef cairo_pattern_t GooCairoPattern;
- */
-
- /**
-- * GooCairoLineJoin
-+ * GooCairoLineJoin:
- *
- * #GooCairoLineJoin is simply a wrapper for the #cairo_line_join_t type,
- * allowing it to be used for #GObject properties.
-@@ -311,7 +316,7 @@ typedef cairo_pattern_t GooCairoPattern;
- */
-
- /**
-- * GooCairoOperator
-+ * GooCairoOperator:
- *
- * #GooCairoOperator is simply a wrapper for the #cairo_operator_t type,
- * allowing it to be used for #GObject properties.
-@@ -320,7 +325,7 @@ typedef cairo_pattern_t GooCairoPattern;
- */
-
- /**
-- * GooCairoMatrix
-+ * GooCairoMatrix:
- *
- * #GooCairoMatrix is simply a wrapper for the #cairo_matrix_t type,
- * allowing it to be used for #GObject properties.
-@@ -329,7 +334,7 @@ typedef cairo_pattern_t GooCairoPattern;
- */
-
- /**
-- * GooCairoPattern
-+ * GooCairoPattern:
- *
- * #GooCairoPattern is simply a wrapper for the #cairo_pattern_t type,
- * allowing it to be used for #GObject properties.
-diff --git a/src/goocanvaswidget.h b/src/goocanvaswidget.h
-index 48b7998..9ef48bb 100644
---- src/goocanvaswidget.h
-+++ src/goocanvaswidget.h
-@@ -25,7 +25,7 @@ typedef struct _GooCanvasWidget GooCanvasWidget;
- typedef struct _GooCanvasWidgetClass GooCanvasWidgetClass;
-
- /**
-- * GooCanvasWidget
-+ * GooCanvasWidget:
- *
- * The #GooCanvasWidget-struct struct contains private data only.
- */
---
-cgit v0.9.1