aboutsummaryrefslogtreecommitdiff
path: root/graphics/gphoto2/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-09-07 09:03:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-09-07 09:03:55 +0000
commitb7daa8ecd72bcf5e55199856c69ae20d7e8e3111 (patch)
tree02d6fb76adaeade4b159b4415eae51357f6b223d /graphics/gphoto2/Makefile
parent003debeb01276bd20f93d5007c7f974aab551fa2 (diff)
downloadports-b7daa8ecd72bcf5e55199856c69ae20d7e8e3111.tar.gz
ports-b7daa8ecd72bcf5e55199856c69ae20d7e8e3111.zip
- Update to 2.4.7
- Make aalib/jpeg dependency optional
Notes
Notes: svn path=/head/; revision=240971
Diffstat (limited to 'graphics/gphoto2/Makefile')
-rw-r--r--graphics/gphoto2/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index 135d55a4ee78..468c67848a32 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gphoto2
-PORTVERSION= 2.4.5
-PORTREVISION= 1
+PORTVERSION= 2.4.7
CATEGORIES= graphics
MASTER_SITES= SF/gphoto/gphoto/${PORTVERSION}
@@ -15,8 +14,6 @@ MAINTAINER= pav@FreeBSD.org
COMMENT= A command-line frontend to libgphoto2
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
- aa.1:${PORTSDIR}/graphics/aalib \
- jpeg.10:${PORTSDIR}/graphics/jpeg \
gphoto2.2:${PORTSDIR}/graphics/libgphoto2
USE_GNOME= gnometarget
@@ -32,6 +29,17 @@ MAN1= gphoto2.1
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+OPTIONS= AALIB "Enable command line capture preview (aalib)" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_AALIB)
+LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib \
+ jpeg.10:${PORTSDIR}/graphics/jpeg
+.else
+CONFIGURE_ARGS+=--without-aalib --without-jpeg
+.endif
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
@@ -51,4 +59,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>