aboutsummaryrefslogtreecommitdiff
path: root/graphics/gphoto2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-09-01 00:40:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-09-01 00:40:21 +0000
commitab10fb893a2e341a75dd784ff49ddf05424598d6 (patch)
tree7bc818eb64b0b09a454b92bebba5529fe858368e /graphics/gphoto2
parent2fbfc9fa867068be478478de3d36980fe87eb0d7 (diff)
downloadports-ab10fb893a2e341a75dd784ff49ddf05424598d6.tar.gz
ports-ab10fb893a2e341a75dd784ff49ddf05424598d6.zip
* Chase so version for libexif
* Fix build with libexif-0.5.4 * Bump PORTREVISION PR: 42270 Obtained from: various diffs from gphoto2 CVS
Notes
Notes: svn path=/head/; revision=65396
Diffstat (limited to 'graphics/gphoto2')
-rw-r--r--graphics/gphoto2/Makefile3
-rw-r--r--graphics/gphoto2/files/patch-frontends_command-line_actions.c30
-rw-r--r--graphics/gphoto2/files/patch-libgphoto2_gphoto2-filesys.c18
3 files changed, 50 insertions, 1 deletions
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index 197059692bfd..2ca3ebdf2726 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gphoto2
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.gphoto.net/dist/
@@ -19,7 +20,7 @@ LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
usb-0.1.5:${PORTSDIR}/devel/libusb \
aa.1:${PORTSDIR}/graphics/aalib \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- exif.5:${PORTSDIR}/graphics/libexif
+ exif.7:${PORTSDIR}/graphics/libexif
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
USE_BZIP2= yes
diff --git a/graphics/gphoto2/files/patch-frontends_command-line_actions.c b/graphics/gphoto2/files/patch-frontends_command-line_actions.c
new file mode 100644
index 000000000000..369e3b94d3ac
--- /dev/null
+++ b/graphics/gphoto2/files/patch-frontends_command-line_actions.c
@@ -0,0 +1,30 @@
+--- frontends/command-line/actions.c.orig Sat Aug 31 20:34:21 2002
++++ frontends/command-line/actions.c Sat Aug 31 20:36:35 2002
+@@ -316,6 +316,7 @@
+ const char *data;
+ unsigned long size;
+ ExifData *ed;
++ unsigned int i;
+
+ CR (gp_file_new (&file));
+ CRU (gp_camera_file_get (p->camera, p->folder, filename,
+@@ -337,16 +338,9 @@
+ printf ("%-59.59s", _("Value"));
+ printf ("\n");
+ print_hline ();
+- if (ed->ifd0)
+- show_ifd (ed->ifd0);
+- if (ed->ifd1)
+- show_ifd (ed->ifd1);
+- if (ed->ifd_exif)
+- show_ifd (ed->ifd_exif);
+- if (ed->ifd_gps)
+- show_ifd (ed->ifd_gps);
+- if (ed->ifd_interoperability)
+- show_ifd (ed->ifd_interoperability);
++ for (i = 0; i < EXIF_IFD_COUNT; i++)
++ if (ed->ifd[i])
++ show_ifd (ed->ifd[i]);
+ print_hline ();
+ if (ed->size) {
+ printf (_("EXIF data contains a thumbnail (%i bytes)."),
diff --git a/graphics/gphoto2/files/patch-libgphoto2_gphoto2-filesys.c b/graphics/gphoto2/files/patch-libgphoto2_gphoto2-filesys.c
new file mode 100644
index 000000000000..0cf2e9054d9a
--- /dev/null
+++ b/graphics/gphoto2/files/patch-libgphoto2_gphoto2-filesys.c
@@ -0,0 +1,18 @@
+--- libgphoto2/gphoto2-filesys.c.orig Sat Aug 31 20:30:42 2002
++++ libgphoto2/gphoto2-filesys.c Sat Aug 31 20:32:23 2002
+@@ -98,12 +98,12 @@
+ /*
+ * HP PhotoSmart C30 has the date and time in ifd_exif.
+ */
+- e = exif_content_get_entry (ed->ifd0, EXIF_TAG_DATE_TIME);
++ e = exif_content_get_entry (ed->ifd[EXIF_IFD_0], EXIF_TAG_DATE_TIME);
+ if (!e)
+- e = exif_content_get_entry (ed->ifd_exif,
++ e = exif_content_get_entry (ed->ifd[EXIF_IFD_EXIF],
+ EXIF_TAG_DATE_TIME_ORIGINAL);
+ if (!e)
+- e = exif_content_get_entry (ed->ifd_exif,
++ e = exif_content_get_entry (ed->ifd[EXIF_IFD_EXIF],
+ EXIF_TAG_DATE_TIME_DIGITIZED);
+ if (!e) {
+ GP_DEBUG ("EXIF data has not date/time tag.");