aboutsummaryrefslogtreecommitdiff
path: root/graphics/graphviz/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-08-07 16:37:20 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2007-08-07 16:37:20 +0000
commit7a229652f7706a547d141153accaff1f667c081c (patch)
tree295c43efe1890546e1f647947b5bdb25bd8e350e /graphics/graphviz/Makefile
parent11247887a6b2b42badef2330f9c97ed965b5258a (diff)
downloadports-7a229652f7706a547d141153accaff1f667c081c.tar.gz
ports-7a229652f7706a547d141153accaff1f667c081c.zip
- update to 2.14
shared lib version bump internal include files ar no longer installed - fix build with WITH_LUA
Notes
Notes: svn path=/head/; revision=197296
Diffstat (limited to 'graphics/graphviz/Makefile')
-rw-r--r--graphics/graphviz/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index a7e7ca835e31..2ea711139617 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= graphviz
-PORTVERSION= 2.12
-PORTREVISION= 2
+PORTVERSION= 2.14
CATEGORIES= graphics tk84
MASTER_SITES= http://www.graphviz.org/pub/graphviz/ARCHIVE/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
@@ -35,6 +34,7 @@ MAN1= acyclic.1 bcomps.1 ccomps.1 dijkstra.1 dot.1 \
dotty.1 gc.1 gvcolor.1 gvpack.1 gvpr.1 gxl2dot.1 \
lneato.1 nop.1 prune.1 sccmap.1 tred.1 unflatten.1
MAN3= agraph.3 cdt.3 expr.3 graph.3 gvc.3 pathplan.3
+MAN7= graphviz.7
MLINKS= dot.1 circo.1 \
gxl2dot.1 dot2gxl.1 \
dot.1 fdp.1 \
@@ -185,8 +185,8 @@ CONFIGURE_ARGS+= --enable-lua
PLIST_SUB+= WITH_LUA=""
USE_LUA= yes
.include "${PORTSDIR}/Mk/bsd.lua.mk"
-CPPFLAGS+= -I${LUA_INCDIR}
-LDFLAGS+= -L${LUA_LIBDIR}
+CFLAGS+= -I${LUA_INCDIR}
+LDFLAGS+= -L${LUA_LIBDIR} -lm
CONFIGURE_ENV+= LUA="${LUA_BINDIR}/lua"
. endif