aboutsummaryrefslogtreecommitdiff
path: root/graphics/gthumb
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-04-12 08:24:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-04-12 08:24:32 +0000
commit8e289e1ecb347d5189abe5a320894fe47f5abb39 (patch)
tree1750713a7556f2542fb6fb8075f0a67251615f0f /graphics/gthumb
parente29d5654e9f416d889be863e8dd567a647259124 (diff)
downloadports-8e289e1ecb347d5189abe5a320894fe47f5abb39.tar.gz
ports-8e289e1ecb347d5189abe5a320894fe47f5abb39.zip
- chase exiv2 library bump
- while here remove some MD5 - fix some forgottern desktop-file-utils dependencies
Notes
Notes: svn path=/head/; revision=272597
Diffstat (limited to 'graphics/gthumb')
-rw-r--r--graphics/gthumb/Makefile3
-rw-r--r--graphics/gthumb/files/patch-extensions__exiv2_tools__exiv2-utils.cpp42
2 files changed, 44 insertions, 1 deletions
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index e3c1942e231c..fe6d622a4c55 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gthumb
PORTVERSION= 2.12.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -45,7 +46,7 @@ OPTIONS= EXIV2 "Exif support (image metadata)" On \
.include <bsd.port.pre.mk>
.if defined(WITH_EXIV2)
-LIB_DEPENDS+= exiv2.9:${PORTSDIR}/graphics/exiv2
+LIB_DEPENDS+= exiv2.10:${PORTSDIR}/graphics/exiv2
CONFIGURE_ARGS+=--enable-exiv2
PLIST_SUB+= EXIV2=""
.else
diff --git a/graphics/gthumb/files/patch-extensions__exiv2_tools__exiv2-utils.cpp b/graphics/gthumb/files/patch-extensions__exiv2_tools__exiv2-utils.cpp
new file mode 100644
index 000000000000..aaabc64ad811
--- /dev/null
+++ b/graphics/gthumb/files/patch-extensions__exiv2_tools__exiv2-utils.cpp
@@ -0,0 +1,42 @@
+--- ./extensions/exiv2_tools/exiv2-utils.cpp.orig 2010-09-15 21:07:15.000000000 +0200
++++ ./extensions/exiv2_tools/exiv2-utils.cpp 2011-04-11 15:39:59.491373470 +0200
+@@ -497,19 +497,19 @@
+ static const char *
+ get_exif_default_category (const Exiv2::Exifdatum &md)
+ {
++#if EXIV2_TEST_VERSION(0, 21, 0)
++ if (Exiv2::ExifTags::isMakerGroup(md.groupName()))
++#else
+ if (Exiv2::ExifTags::isMakerIfd(md.ifdId()))
++#endif
+ return "Exif::MakerNotes";
+
+- switch (md.ifdId()) {
+- case Exiv2::ifd1Id:
++ if (md.groupName().compare("Thumbnail") == 0)
+ return "Exif::Thumbnail";
+- case Exiv2::gpsIfdId:
++ else if (md.groupName().compare("GPSInfo") == 0)
+ return "Exif::GPS";
+- case Exiv2::iopIfdId:
++ else if (md.groupName().compare("Iop") == 0)
+ return "Exif::Versions";
+- default:
+- break;
+- }
+
+ return "Exif::Other";
+ }
+@@ -531,7 +531,11 @@
+ stringstream description;
+ if (! md->tagLabel().empty())
+ description << md->tagLabel();
+- else if (md->ifdId () > Exiv2::ifd1Id)
++#if EXIV2_TEST_VERSION(0, 21, 0)
++ else if (Exiv2::ExifTags::isMakerGroup(md->groupName()))
++#else
++ else if (Exiv2::ExifTags::isMakerIfd(md->ifdId()))
++#endif
+ // Must be a MakerNote - include group name
+ description << md->groupName() << "." << md->tagName();
+ else