aboutsummaryrefslogtreecommitdiff
path: root/graphics/gts/Makefile
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-08-31 17:19:24 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-08-31 17:19:24 +0000
commit9fbb944bdce74b5a7982e200cb3a333dcd82111f (patch)
tree0ea367784bce28e5bdb437dcd7be0eaf15149b99 /graphics/gts/Makefile
parentf94c60098d716ae464b9a85711abcadefb2d362d (diff)
downloadports-9fbb944bdce74b5a7982e200cb3a333dcd82111f.tar.gz
ports-9fbb944bdce74b5a7982e200cb3a333dcd82111f.zip
GNU_CONFIGURE -> USE_LIBTOOL
Add missing INSTALLS_SHLIB Fix LIB_DEPENDS Sort pkg-plist and add missing entry PR: 42242 Submitted by: tkato@prontomail.com
Notes
Notes: svn path=/head/; revision=65380
Diffstat (limited to 'graphics/gts/Makefile')
-rw-r--r--graphics/gts/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/graphics/gts/Makefile b/graphics/gts/Makefile
index 0024eb673ee8..dce432b546f9 100644
--- a/graphics/gts/Makefile
+++ b/graphics/gts/Makefile
@@ -8,25 +8,27 @@
PORTNAME= gts
PORTVERSION= 0.6.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-USE_LIBTOOL= yes
USE_GNOMENG= yes
USE_GNOME= glib12
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+USE_LIBTOOL= yes
+LIBTOOLFLAGS= --disable-ltlibs --release-ignore
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+INSTALLS_SHLIB= yes
-.if !defined(NOPORTDOCS)
post-install:
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/doc/html/* ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}
.endif
.include <bsd.port.mk>