aboutsummaryrefslogtreecommitdiff
path: root/graphics/hobbes-icons-xpm/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-10-29 12:28:37 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-10-29 12:28:37 +0000
commit4b6532e553fc02edec3aacf4d7f2aa54e1c7e1be (patch)
tree77ebdff0fb37b9518590a387995d36e5b23ae528 /graphics/hobbes-icons-xpm/Makefile
parente7a1876bfe8551e75a9a494507ca3bd22517c45b (diff)
downloadports-4b6532e553fc02edec3aacf4d7f2aa54e1c7e1be.tar.gz
ports-4b6532e553fc02edec3aacf4d7f2aa54e1c7e1be.zip
Use /usr/X11R6/include/pixmaps as installation path. This
is more standard than the old .../xpm3. PR: 4104 Submitted by: Pedro Giffuni S. <pgiffuni@fps.biblos.unal.edu.co>
Notes
Notes: svn path=/head/; revision=8393
Diffstat (limited to 'graphics/hobbes-icons-xpm/Makefile')
-rw-r--r--graphics/hobbes-icons-xpm/Makefile26
1 files changed, 16 insertions, 10 deletions
diff --git a/graphics/hobbes-icons-xpm/Makefile b/graphics/hobbes-icons-xpm/Makefile
index 6c1cf99c7da6..0a7d74703be7 100644
--- a/graphics/hobbes-icons-xpm/Makefile
+++ b/graphics/hobbes-icons-xpm/Makefile
@@ -1,9 +1,9 @@
-# New ports collection makefile for: hobbes-icons.3000
-# Version required: 3000
+# New ports collection makefile for: hobbes-icons-xpm3
+# Version required: 1.0
# Date created: 19 October 1996
# Whom: pgs
#
-# $Id: Makefile,v 1.2 1997/02/16 10:57:01 asami Exp $
+# $Id: Makefile,v 1.3 1997/05/30 16:50:46 fenner Exp $
#
DISTNAME= hobbes-icons-xpm3
@@ -19,15 +19,21 @@ MAINTAINER= pgiffuni@fps.biblos.unal.edu.co
USE_X11= yes
NO_BUILD= yes
-# Where it will be installed (will have to change PLIST if you change this
-LIBDIR= ${PREFIX}/lib/X11/xpm3
+# Where it will be installed (change pkg/PLIST if you change this)
+LIBDIR= ${PREFIX}/include/X11/pixmaps
do-install:
-# Very dirty, but it works...
- -${RM} ${WRKSRC}/README
- -${RM} ${WRKSRC}/readem.shar
- ${MKDIR} ${PREFIX}/lib/X11/xpm3
+ ${MKDIR} ${LIBDIR}
${CP} -R ${WRKSRC}/* ${LIBDIR}
- chown -R ${BINOWN}.${BINGRP} ${LIBDIR}
+ chown -R ${BINOWN}:${BINGRP} ${LIBDIR}
+ -${RM} ${LIBDIR}/README
+ -${RM} ${LIBDIR}/readem.shar
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/hobbes-icons-xpm3
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/hobbes-icons-xpm3
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.shar ${PREFIX}/share/doc/hobbes-icons-xpm3
+.endif
.include <bsd.port.mk>