aboutsummaryrefslogtreecommitdiff
path: root/graphics/hugin
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2009-09-29 16:36:45 +0000
committerVasil Dimov <vd@FreeBSD.org>2009-09-29 16:36:45 +0000
commit12823879a6717155808ca4c2c48ece58e804fa4d (patch)
tree4fa6922251c3c86fd88966f7e0101b84c61ff42b /graphics/hugin
parentc9ba1948cd64c350a3e766916ca7e7f8d31547b4 (diff)
downloadports-12823879a6717155808ca4c2c48ece58e804fa4d.tar.gz
ports-12823879a6717155808ca4c2c48ece58e804fa4d.zip
Upgrade graphics/hugin from 0.8.0 to 2009.2.0.
Notes
Notes: svn path=/head/; revision=242236
Diffstat (limited to 'graphics/hugin')
-rw-r--r--graphics/hugin/Makefile19
-rw-r--r--graphics/hugin/distinfo6
-rw-r--r--graphics/hugin/files/patch-CMakeLists.txt23
-rw-r--r--graphics/hugin/files/patch-doc_CMakeLists.txt10
-rw-r--r--graphics/hugin/files/patch-src_hugin1_base_wx_RunStitchPanel.cpp11
-rw-r--r--graphics/hugin/files/patch-src_hugin1_hugin_TextureManager.cpp11
-rw-r--r--graphics/hugin/files/patch-src_hugin1_hugin_config_defaults.h13
-rw-r--r--graphics/hugin/pkg-plist6
8 files changed, 38 insertions, 61 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index aba3e982cf63..291809b7c83b 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= hugin
-PORTVERSION= 0.8.0
+PORTVERSION= 2009.2.0
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}
MAINTAINER= vd@FreeBSD.org
COMMENT= A GUI for Panorama Tools, to stitch panoramic images
@@ -21,15 +21,14 @@ LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
pano13:${PORTSDIR}/graphics/libpano13 \
boost_date_time:${PORTSDIR}/devel/boost-libs \
GLEW:${PORTSDIR}/graphics/glew
+# gmake is really needed at _runtime_, do not remove it from below
RUN_DEPENDS= enblend>=3.1.r20080615:${PORTSDIR}/graphics/enblend \
exiftool:${PORTSDIR}/graphics/p5-Image-ExifTool \
gmake:${PORTSDIR}/devel/gmake
-# TODO add autopano-sift-C to the ports collection and hook it here as
-# an optional dependency
-
OPTIONS= PANOMATIC "Install graphics/panomatic" on \
- AUTOPANOSIFT "Install graphics/autopano-sift" on
+ AUTOPANOSIFT "Install graphics/autopano-sift" off \
+ AUTOPANOSIFTC "Install graphics/autopano-sift-c" on
USE_CMAKE= yes
@@ -84,7 +83,15 @@ RUN_DEPENDS+= panomatic:${PORTSDIR}/graphics/panomatic
.endif
.if defined(WITH_AUTOPANOSIFT)
+.if defined(WITH_AUTOPANOSIFTC)
+BROKEN= autopano-sift and autopano-sift-c are mutually exclusive,\
+ please run 'make config' again and select at most one of them
+.endif
RUN_DEPENDS+= autopanog:${PORTSDIR}/graphics/autopano-sift
.endif
+.if defined(WITH_AUTOPANOSIFTC)
+RUN_DEPENDS+= autopano:${PORTSDIR}/graphics/autopano-sift-c
+.endif
+
.include <bsd.port.post.mk>
diff --git a/graphics/hugin/distinfo b/graphics/hugin/distinfo
index e68543c2267e..0e704fa05525 100644
--- a/graphics/hugin/distinfo
+++ b/graphics/hugin/distinfo
@@ -1,3 +1,3 @@
-MD5 (hugin-0.8.0.tar.gz) = 0c88afbd7f8159aac29404ff40370400
-SHA256 (hugin-0.8.0.tar.gz) = cf0a138aa19f179c3d5a459dfc1217789e963e3f815fde3fdb46ea913310bf4a
-SIZE (hugin-0.8.0.tar.gz) = 12077874
+MD5 (hugin-2009.2.0.tar.gz) = 856fa8016bc990874a71a19cc162f6be
+SHA256 (hugin-2009.2.0.tar.gz) = 620e8ea2e3a65b0e51fad7a450b474d01d9d8ddf08e26f7b6866dee97458b0fc
+SIZE (hugin-2009.2.0.tar.gz) = 11159002
diff --git a/graphics/hugin/files/patch-CMakeLists.txt b/graphics/hugin/files/patch-CMakeLists.txt
index 5e10ca6fdc22..650cb2837bac 100644
--- a/graphics/hugin/files/patch-CMakeLists.txt
+++ b/graphics/hugin/files/patch-CMakeLists.txt
@@ -1,10 +1,21 @@
---- CMakeLists.txt.orig 2008-06-30 08:28:53.000000000 +0300
-+++ CMakeLists.txt 2008-06-30 08:29:57.000000000 +0300
-@@ -202,6 +202,7 @@
- SET(HUGINDATADIR share/hugin)
+--- CMakeLists.txt.orig 2009-09-21 04:04:06.000000000 +0300
++++ CMakeLists.txt 2009-09-29 19:05:34.000000000 +0300
+@@ -266,13 +266,13 @@
SET(DATADIR share)
SET(BINDIR bin)
-+SET(MANDIR man)
+
+-IF("$ENV{MANDIR}")
+- SET (MANDIR "$ENV{MANDIR}")
+-ELSEIF(CMAKE_SYSTEM_NAME=="FreeBSD")
++IF(NOT MANDIR AND NOT $ENV{MANDIR} STREQUAL "")
++ SET (MANDIR $ENV{MANDIR})
++ELSEIF(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+ SET (MANDIR "man")
+-ELSE("$ENV{MANDIR}")
++ELSE(NOT MANDIR AND NOT $ENV{MANDIR} STREQUAL "")
+ SET (MANDIR "share/man")
+-ENDIF("$ENV{MANDIR}")
++ENDIF(NOT MANDIR AND NOT $ENV{MANDIR} STREQUAL "")
+
SET(LOCALEDIR share/locale)
SET(ICONDIR share/icons)
- SET(LINKDIR share/applications)
diff --git a/graphics/hugin/files/patch-doc_CMakeLists.txt b/graphics/hugin/files/patch-doc_CMakeLists.txt
deleted file mode 100644
index 2e4108ff4547..000000000000
--- a/graphics/hugin/files/patch-doc_CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- doc/CMakeLists.txt.orig 2009-08-21 12:48:33.000000000 +0300
-+++ doc/CMakeLists.txt 2009-08-21 12:48:51.000000000 +0300
-@@ -3,6 +3,6 @@
- INSTALL(FILES fulla.html DESTINATION doc)
- INSTALL(FILES nona.txt DESTINATION doc)
- ELSE (WIN32)
--INSTALL(FILES align_image_stack.1 autooptimiser.1 celeste_standalone.1 fulla.1 hugin.1 hugin_hdrmerge.1 hugin_stitch_project.1 nona.1 nona_gui.1 PTBatcherGUI.1 pto2mk.1 tca_correct.1 vig_optimize.1 DESTINATION share/man/man1)
-+INSTALL(FILES align_image_stack.1 autooptimiser.1 celeste_standalone.1 fulla.1 hugin.1 hugin_hdrmerge.1 hugin_stitch_project.1 nona.1 nona_gui.1 PTBatcherGUI.1 pto2mk.1 tca_correct.1 vig_optimize.1 DESTINATION ${MANDIR}/man1)
- ENDIF(WIN32)
-
diff --git a/graphics/hugin/files/patch-src_hugin1_base_wx_RunStitchPanel.cpp b/graphics/hugin/files/patch-src_hugin1_base_wx_RunStitchPanel.cpp
deleted file mode 100644
index f39793709250..000000000000
--- a/graphics/hugin/files/patch-src_hugin1_base_wx_RunStitchPanel.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/hugin1/base_wx/RunStitchPanel.cpp.orig 2008-12-03 14:29:01.000000000 +0200
-+++ src/hugin1/base_wx/RunStitchPanel.cpp 2008-12-03 14:31:30.000000000 +0200
-@@ -240,6 +240,8 @@
- cmd = wxT("make");
- }
- cmd += wxT(" ") + args;
-+#elif defined __FreeBSD__
-+ wxString cmd = wxT("gmake ") + args;
- #else
- wxString cmd = wxT("make ") + args;
- #endif
diff --git a/graphics/hugin/files/patch-src_hugin1_hugin_TextureManager.cpp b/graphics/hugin/files/patch-src_hugin1_hugin_TextureManager.cpp
deleted file mode 100644
index 9eff70e85204..000000000000
--- a/graphics/hugin/files/patch-src_hugin1_hugin_TextureManager.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/hugin1/hugin/TextureManager.cpp.orig 2009-08-21 14:24:25.000000000 +0300
-+++ src/hugin1/hugin/TextureManager.cpp 2009-08-21 14:24:30.000000000 +0300
-@@ -52,6 +52,8 @@
- #include <GL/glu.h>
- #endif
-
-+#define log2(x) (log(x) / log(2))
-+
- TextureManager::TextureManager(PT::Panorama *pano, ViewState *view_state_in)
- {
- m_pano = pano;
diff --git a/graphics/hugin/files/patch-src_hugin1_hugin_config_defaults.h b/graphics/hugin/files/patch-src_hugin1_hugin_config_defaults.h
deleted file mode 100644
index 2487cd3d153a..000000000000
--- a/graphics/hugin/files/patch-src_hugin1_hugin_config_defaults.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/hugin1/hugin/config_defaults.h.orig 2008-06-20 17:21:28.000000000 +0300
-+++ src/hugin1/hugin/config_defaults.h 2008-06-20 17:22:40.000000000 +0300
-@@ -160,8 +160,8 @@
- #define HUGIN_APKOLOR_EXE ""
- #define HUGIN_APKOLOR_ARGS ""
-
--#define HUGIN_APSIFT_EXE "autopano-sift-c"
--#define HUGIN_APSIFT_ARGS "--maxmatches %p %o %i"
-+#define HUGIN_APSIFT_EXE "autopano-complete"
-+#define HUGIN_APSIFT_ARGS "-o %o -p %p %i"
- #define HUGIN_STITCHER_RUN_EDITOR 0l
- #define HUGIN_STITCHER_EDITOR "gimp-remote"
- #define HUGIN_STITCHER_EDITOR_ARGS "%f"
diff --git a/graphics/hugin/pkg-plist b/graphics/hugin/pkg-plist
index 22f61537c720..907736bfbe80 100644
--- a/graphics/hugin/pkg-plist
+++ b/graphics/hugin/pkg-plist
@@ -2,6 +2,7 @@ bin/PTBatcher
bin/PTBatcherGUI
bin/align_image_stack
bin/autooptimiser
+bin/autopano-noop.sh
bin/celeste_standalone
bin/fulla
bin/hugin
@@ -24,6 +25,7 @@ lib/libhuginvigraimpex.so.0.0
share/applications/hugin.desktop
share/applications/PTBatcherGUI.desktop
%%DATADIR%%/Makefile.equirect.mk
+%%DATADIR%%/data/celeste.model
%%DATADIR%%/xrc/about.xrc
%%DATADIR%%/xrc/assistant_panel.xrc
%%DATADIR%%/xrc/batch_frame.xrc
@@ -31,6 +33,7 @@ share/applications/PTBatcherGUI.desktop
%%DATADIR%%/xrc/batch_toolbar.xrc
%%DATADIR%%/xrc/cp_editor_panel.xrc
%%DATADIR%%/xrc/cp_list_frame.xrc
+%%DATADIR%%/xrc/cpdetector_dialog.xrc
%%DATADIR%%/xrc/crop_panel.xrc
%%DATADIR%%/xrc/data/1leftarrow.png
%%DATADIR%%/xrc/data/1rightarrow.png
@@ -44,7 +47,6 @@ share/applications/PTBatcherGUI.desktop
%%DATADIR%%/xrc/data/about.htm
%%DATADIR%%/xrc/data/add_project.png
%%DATADIR%%/xrc/data/add_projects.png
-%%DATADIR%%/xrc/data/celeste.model
%%DATADIR%%/xrc/data/center_pano.png
%%DATADIR%%/xrc/data/center_pano.xpm
%%DATADIR%%/xrc/data/close.xpm
@@ -537,6 +539,7 @@ share/applications/PTBatcherGUI.desktop
%%DATADIR%%/xrc/data/photometric.png
%%DATADIR%%/xrc/data/preview.png
%%DATADIR%%/xrc/data/preview_auto_update.png
+%%DATADIR%%/xrc/data/preview_control_point_tool.png
%%DATADIR%%/xrc/data/preview_num_transform.png
%%DATADIR%%/xrc/data/preview_show_all.png
%%DATADIR%%/xrc/data/preview_show_none.png
@@ -613,6 +616,7 @@ share/pixmaps/hugin.png
@dirrmtry share/locale/cs_CZ
@dirrmtry share/mime/packages
@dirrmtry share/mime
+@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%/xrc/data/help_en_EN
@dirrm %%DATADIR%%/xrc/data/help_it_IT
@dirrm %%DATADIR%%/xrc/data