aboutsummaryrefslogtreecommitdiff
path: root/graphics/hugin
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2005-08-14 13:43:22 +0000
committerMax Khon <fjoe@FreeBSD.org>2005-08-14 13:43:22 +0000
commit77414578dfcaf2b0b8b9035e58309f15925a4112 (patch)
treec56f95ce83e0b1741dd6ab50d9045cf5d1c791d1 /graphics/hugin
parentc53080de9c454c15042a8057860459b141e70673 (diff)
downloadports-77414578dfcaf2b0b8b9035e58309f15925a4112.tar.gz
ports-77414578dfcaf2b0b8b9035e58309f15925a4112.zip
- Fix build on RELENG_4.
- Fix dependencies on wxgtk (include lib versions, otherwise wxgtk2 2.6.x libarries could match) - Bump PORTREVISION. Approved by: portmgr
Notes
Notes: svn path=/head/; revision=140875
Diffstat (limited to 'graphics/hugin')
-rw-r--r--graphics/hugin/Makefile8
-rw-r--r--graphics/hugin/files/patch-configure11
-rw-r--r--graphics/hugin/files/patch-src-common-utils.cpp11
-rw-r--r--graphics/hugin/files/patch-src-hugin-ImagesPanel.cpp15
-rw-r--r--graphics/hugin/files/patch-src-include-common-utils.h12
-rw-r--r--graphics/hugin/files/patch-src-include-vigra_ext-PointMatching.h26
6 files changed, 75 insertions, 8 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 36aa92b4bdb7..2a0d21d22e4e 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hugin
PORTVERSION= 0.5.b2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,8 +22,8 @@ LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
png:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg \
fftw:${PORTSDIR}/math/fftw \
- wx_gtk2:${PORTSDIR}/x11-toolkits/wxgtk24 \
- wx_gtk2_xrc:${PORTSDIR}/x11-toolkits/wxgtk24-contrib \
+ wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24 \
+ wx_gtk2_xrc-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24-contrib \
boost_date_time:${PORTSDIR}/devel/boost
RUN_DEPENDS= PTOptimizer:${PORTSDIR}/graphics/libpano12 \
PTStitcher:${PORTSDIR}/graphics/linux-panorama-tools
@@ -31,7 +31,7 @@ RUN_DEPENDS= PTOptimizer:${PORTSDIR}/graphics/libpano12 \
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -ftemplate-depth-32" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
USE_BZIP2= yes
diff --git a/graphics/hugin/files/patch-configure b/graphics/hugin/files/patch-configure
new file mode 100644
index 000000000000..3357cf52c980
--- /dev/null
+++ b/graphics/hugin/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Thu Aug 11 20:04:18 2005
++++ configure Thu Aug 11 20:04:23 2005
+@@ -23388,7 +23388,7 @@
+ failed=0;
+ passed=0;
+ PANO_OLD_LDFLAGS=$LDFLAGS
+- PANO_OLD_CPPFLAGS=$LDFLAGS
++ PANO_OLD_CPPFLAGS=$CPPFLAGS
+ if test "x$HCPU" = 'xamd64' ; then
+ LDFLAGS="$LDFLAGS -L$PANO_HOME/lib64"
+ else
diff --git a/graphics/hugin/files/patch-src-common-utils.cpp b/graphics/hugin/files/patch-src-common-utils.cpp
index 6953dec1ef4d..9dddd7b41572 100644
--- a/graphics/hugin/files/patch-src-common-utils.cpp
+++ b/graphics/hugin/files/patch-src-common-utils.cpp
@@ -1,11 +1,14 @@
---- src/common/utils.cpp.orig Wed Mar 2 22:15:55 2005
-+++ src/common/utils.cpp Wed Mar 2 22:16:30 2005
-@@ -38,7 +38,7 @@
+--- src/common/utils.cpp.orig Mon Jan 17 07:29:39 2005
++++ src/common/utils.cpp Thu Aug 11 20:28:47 2005
+@@ -37,8 +37,10 @@
+ char tmp[100];
struct tm t;
struct timeval tv;
++ time_t _clock;
gettimeofday(&tv,NULL);
- localtime_r(&tv.tv_sec, &t);
-+ localtime_r((time_t *)&tv.tv_sec, &t);
++ _clock = tv.tv_sec;
++ localtime_r(&_clock, &t);
strftime(tmp,99,"%H:%M:%S",&t);
sprintf(tmp+8,".%06ld",tv.tv_usec);
return tmp;
diff --git a/graphics/hugin/files/patch-src-hugin-ImagesPanel.cpp b/graphics/hugin/files/patch-src-hugin-ImagesPanel.cpp
new file mode 100644
index 000000000000..be910b25f420
--- /dev/null
+++ b/graphics/hugin/files/patch-src-hugin-ImagesPanel.cpp
@@ -0,0 +1,15 @@
+--- src/hugin/ImagesPanel.cpp.orig Thu Aug 11 20:18:49 2005
++++ src/hugin/ImagesPanel.cpp Thu Aug 11 20:20:24 2005
+@@ -448,9 +448,9 @@
+ for (UIntSet::const_iterator it = selImg.begin();
+ it != selImg.end(); ++it )
+ {
+- vars[i].insert(make_pair("y", Variable("y",0.0)));
+- vars[i].insert(make_pair("p", Variable("p",0.0)));
+- vars[i].insert(make_pair("r", Variable("r",0.0)));
++ vars[i].insert(make_pair((char *) "y", Variable("y",0.0)));
++ vars[i].insert(make_pair((char *) "p", Variable("p",0.0)));
++ vars[i].insert(make_pair((char *) "r", Variable("r",0.0)));
+ i++;
+ }
+ GlobalCmdHist::getInstance().addCommand(
diff --git a/graphics/hugin/files/patch-src-include-common-utils.h b/graphics/hugin/files/patch-src-include-common-utils.h
new file mode 100644
index 000000000000..17d99366f2f7
--- /dev/null
+++ b/graphics/hugin/files/patch-src-include-common-utils.h
@@ -0,0 +1,12 @@
+--- src/include/common/utils.h.orig Mon Jan 17 07:29:40 2005
++++ src/include/common/utils.h Thu Aug 11 20:24:45 2005
+@@ -30,6 +30,9 @@
+ #include <sstream>
+ #include <cassert>
+
++#include <locale.h>
++#include <stdio.h>
++
+ #include "platform.h"
+
+ #ifdef __WXMSW__
diff --git a/graphics/hugin/files/patch-src-include-vigra_ext-PointMatching.h b/graphics/hugin/files/patch-src-include-vigra_ext-PointMatching.h
new file mode 100644
index 000000000000..5da2b1713215
--- /dev/null
+++ b/graphics/hugin/files/patch-src-include-vigra_ext-PointMatching.h
@@ -0,0 +1,26 @@
+--- src/include/vigra_ext/PointMatching.h.orig Thu Aug 11 19:34:40 2005
++++ src/include/vigra_ext/PointMatching.h Thu Aug 11 19:48:12 2005
+@@ -33,7 +33,9 @@
+
+ // BAD: sgi stl extension
+ #if defined(__GNUC__)
++#if __GNUC__ > 2
+ #include <ext/algorithm>
++#endif
+ #elif defined(HAVE_STLport)
+ #include <stlport4/algorithm>
+ #endif
+@@ -193,8 +195,13 @@
+ {
+ std::vector<SIFTFeature> randomfeat(feat1.size()*m_percent/100);
+ #if defined(__GNUC__)
++#if __GNUC__ > 2
+ __gnu_cxx::random_sample(feat1.begin(), feat1.end(),
+ randomfeat.begin(), randomfeat.end());
++#else
++ std::random_sample(feat1.begin(), feat1.end(),
++ randomfeat.begin(), randomfeat.end());
++#endif
+ #elif defined(HAVE_STLport)
+ _STL::random_sample(feat1.begin(), feat1.end(),
+ randomfeat.begin(), randomfeat.end());