aboutsummaryrefslogtreecommitdiff
path: root/graphics/icoutils
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-11-30 02:12:08 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-11-30 02:12:08 +0000
commit9a8302402840b48c8b599babce318d49e8219ea3 (patch)
tree2d1673c15bda05ee10e5feaa45239ecb687bacfb /graphics/icoutils
parent8820f44d68c932c953bf0be8faf7cc4d8acf1965 (diff)
downloadports-9a8302402840b48c8b599babce318d49e8219ea3.tar.gz
ports-9a8302402840b48c8b599babce318d49e8219ea3.zip
1) Fix build on ${OSVERSION} < 500000: replace stdint.h with
inttypes.h 2) Add missing USE_PERL5_RUN 3) Bump PORTREVISION due to (2)
Notes
Notes: svn path=/head/; revision=149991
Diffstat (limited to 'graphics/icoutils')
-rw-r--r--graphics/icoutils/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/graphics/icoutils/Makefile b/graphics/icoutils/Makefile
index aca9d64594ff..8309dc4340cb 100644
--- a/graphics/icoutils/Makefile
+++ b/graphics/icoutils/Makefile
@@ -7,7 +7,7 @@
PORTNAME= icoutils
PORTVERSION= 0.26.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,6 +18,8 @@ COMMENT= Convert/extract images in Microsoft Windows(R) icon/cursor files
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_GETTEXT= yes
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
@@ -31,6 +33,13 @@ PLIST_FILES= \
bin/icotool \
bin/wrestool
+post-patch:
+ @${FIND} ${WRKSRC} -type f -print0 | \
+ ${XARGS} -0 -x -n 10 \
+ ${REINPLACE_CMD} -E \
+ -e 's|<stdint.h>|<inttypes.h>|' \
+ -e 's|/usr/bin/perl|${PERL5}|'
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000