aboutsummaryrefslogtreecommitdiff
path: root/graphics/ilmbase
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-03-24 17:49:30 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-03-24 17:49:30 +0000
commit737e8c96095bcee260134043bb09df0f022c0d90 (patch)
treedfd422ebf8487b195f07f73936ee3138115740d7 /graphics/ilmbase
parentc4e3432e3193d9f67f68046466408f9402686c9a (diff)
downloadports-737e8c96095bcee260134043bb09df0f022c0d90.tar.gz
ports-737e8c96095bcee260134043bb09df0f022c0d90.zip
- Change license BSD to BSD3CLAUSE
- Add MAJORVER, VER - Strip libraries - Recreate patches with make makepatch
Notes
Notes: svn path=/head/; revision=349036
Diffstat (limited to 'graphics/ilmbase')
-rw-r--r--graphics/ilmbase/Makefile14
-rw-r--r--graphics/ilmbase/files/patch-IexMath__IexMathFpu.cpp (renamed from graphics/ilmbase/files/patch-IexMath-IexMathFpu.cpp)4
-rw-r--r--graphics/ilmbase/files/patch-ImathTest__testBoxAlgo.cpp (renamed from graphics/ilmbase/files/patch-ImathTest-testBoxAlgo.cpp)4
-rw-r--r--graphics/ilmbase/files/patch-ImathTest__testShear.cpp (renamed from graphics/ilmbase/files/patch-ImathTest-testShear.cpp)4
-rw-r--r--graphics/ilmbase/files/patch-Imath__ImathFun.cpp (renamed from graphics/ilmbase/files/patch-Imath-ImathFun.cpp)4
5 files changed, 19 insertions, 11 deletions
diff --git a/graphics/ilmbase/Makefile b/graphics/ilmbase/Makefile
index 76263b852e55..64a62d4c0a16 100644
--- a/graphics/ilmbase/Makefile
+++ b/graphics/ilmbase/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ilmbase-${PORTVERSION}
MAINTAINER= nemysis@FreeBSD.org
COMMENT= ILM Base libraries a.k.a. Half, IlmThread, Imath, and Iex
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USES= pathfix pkgconfig
GNU_CONFIGURE= yes
@@ -36,8 +36,11 @@ CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.endif
-PLIST_SUB= MAJORVER=2_1
-PLIST_SUB+= VER=11
+MAJORVER= 2_1
+VER= 11
+
+PLIST_SUB= MAJORVER=${MAJORVER}
+PLIST_SUB+= VER=${VER}
regression-test regression test check: build
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
@@ -48,6 +51,11 @@ post-patch:
@${REINPLACE_CMD} -e 's|== x|= x|g' ${WRKSRC}/configure
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libHalf.so.${VER}
+.for l in libIex libIexMath libImath libIlmThread
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${l}-${MAJORVER}.so.${VER}
+.endfor
+
.for e in ${BIN}
${INSTALL_PROGRAM} ${WRKSRC}/Half/${e} ${STAGEDIR}${PREFIX}/bin/${e}
.endfor
diff --git a/graphics/ilmbase/files/patch-IexMath-IexMathFpu.cpp b/graphics/ilmbase/files/patch-IexMath__IexMathFpu.cpp
index 78dad32533ef..dbe7a062b958 100644
--- a/graphics/ilmbase/files/patch-IexMath-IexMathFpu.cpp
+++ b/graphics/ilmbase/files/patch-IexMath__IexMathFpu.cpp
@@ -1,5 +1,5 @@
---- IexMath/IexMathFpu.cpp.orig 2013-06-18 21:51:38.000000000 +0200
-+++ IexMath/IexMathFpu.cpp 2013-10-04 19:25:00.000000000 +0200
+--- ./IexMath/IexMathFpu.cpp.orig 2013-06-18 21:51:38.000000000 +0200
++++ ./IexMath/IexMathFpu.cpp 2014-01-29 13:16:44.000000000 +0100
@@ -53,7 +53,7 @@
#endif
diff --git a/graphics/ilmbase/files/patch-ImathTest-testBoxAlgo.cpp b/graphics/ilmbase/files/patch-ImathTest__testBoxAlgo.cpp
index 7ee388ad6ebb..d330c92818d2 100644
--- a/graphics/ilmbase/files/patch-ImathTest-testBoxAlgo.cpp
+++ b/graphics/ilmbase/files/patch-ImathTest__testBoxAlgo.cpp
@@ -1,5 +1,5 @@
---- ImathTest/testBoxAlgo.cpp.orig 2013-06-18 21:51:38.000000000 +0200
-+++ ImathTest/testBoxAlgo.cpp 2013-10-04 20:10:10.000000000 +0200
+--- ./ImathTest/testBoxAlgo.cpp.orig 2013-06-18 21:51:38.000000000 +0200
++++ ./ImathTest/testBoxAlgo.cpp 2014-01-29 13:16:44.000000000 +0100
@@ -356,7 +356,7 @@
Box3f ()
};
diff --git a/graphics/ilmbase/files/patch-ImathTest-testShear.cpp b/graphics/ilmbase/files/patch-ImathTest__testShear.cpp
index ac73372d7362..22593e0acc3f 100644
--- a/graphics/ilmbase/files/patch-ImathTest-testShear.cpp
+++ b/graphics/ilmbase/files/patch-ImathTest__testShear.cpp
@@ -1,5 +1,5 @@
---- ImathTest/testShear.cpp.orig 2013-06-18 21:51:38.000000000 +0200
-+++ ImathTest/testShear.cpp 2013-10-04 20:16:08.000000000 +0200
+--- ./ImathTest/testShear.cpp.orig 2013-06-18 21:51:38.000000000 +0200
++++ ./ImathTest/testShear.cpp 2014-01-29 13:16:44.000000000 +0100
@@ -54,7 +54,6 @@
const float epsilon = IMATH_INTERNAL_NAMESPACE::limits< float >::epsilon();
diff --git a/graphics/ilmbase/files/patch-Imath-ImathFun.cpp b/graphics/ilmbase/files/patch-Imath__ImathFun.cpp
index 0c5a8df907cc..e42cd2a143c2 100644
--- a/graphics/ilmbase/files/patch-Imath-ImathFun.cpp
+++ b/graphics/ilmbase/files/patch-Imath__ImathFun.cpp
@@ -1,5 +1,5 @@
---- Imath/ImathFun.cpp.orig 2013-06-18 21:51:38.000000000 +0200
-+++ Imath/ImathFun.cpp 2013-10-04 20:06:42.000000000 +0200
+--- ./Imath/ImathFun.cpp.orig 2013-10-11 20:40:29.000000000 +0200
++++ ./Imath/ImathFun.cpp 2014-01-29 13:16:44.000000000 +0100
@@ -33,6 +33,7 @@
///////////////////////////////////////////////////////////////////////////