aboutsummaryrefslogtreecommitdiff
path: root/graphics/imlib2/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2006-09-05 13:20:09 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2006-09-05 13:20:09 +0000
commit16c237e988fc13969e57d6c1336395aace7f4f3c (patch)
tree197b5aee5579583bd2b00fd673ac760daf7dedb9 /graphics/imlib2/Makefile
parent5a4fcb752e6f47900c3f55a3f7f37e8d8fe7d040 (diff)
downloadports-16c237e988fc13969e57d6c1336395aace7f4f3c.tar.gz
ports-16c237e988fc13969e57d6c1336395aace7f4f3c.zip
1: use USE_LDCONFIG.
2: enable amd64 optimize when ARCH == amd64.
Notes
Notes: svn path=/head/; revision=172317
Diffstat (limited to 'graphics/imlib2/Makefile')
-rw-r--r--graphics/imlib2/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index 5b16e4c91521..2104e4e9a2cb 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= imlib2
PORTVERSION= 1.2.2.001
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://enlightenment.freedesktop.org/files/
@@ -25,7 +25,7 @@ USE_AUTOTOOLS= autoconf:259 libltdl:15 libtool:15
USE_GNOME= gnomehack pkgconfig gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
@@ -33,6 +33,10 @@ INSTALLS_SHLIB= yes
CONFIGURE_ARGS+= --enable-mmx
.endif
+.if (${ARCH} == "amd64")
+CONFIGURE_ARGS+= --enable-amd64
+.endif
+
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --without-x
PKGNAMESUFFIX+= -nox11