aboutsummaryrefslogtreecommitdiff
path: root/graphics/imlib
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-08-24 17:50:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-08-24 17:50:04 +0000
commitd22e1930e7e27cb51585833da026142c9b2d6935 (patch)
tree8fff0b91c1e180a99b76ad4fc11a04d943c60f0b /graphics/imlib
parent511b7bd219935d94d79faa583ad9598ba2fe068a (diff)
downloadports-d22e1930e7e27cb51585833da026142c9b2d6935.tar.gz
ports-d22e1930e7e27cb51585833da026142c9b2d6935.zip
imlib can't handle 32-bit visuals, so only use 24 as maximum.
PR: ports/149843 Submitted by: Yuri <yuri@tsoft.com> Obtained from: Ubuntu
Notes
Notes: svn path=/head/; revision=259923
Diffstat (limited to 'graphics/imlib')
-rw-r--r--graphics/imlib/Makefile2
-rw-r--r--graphics/imlib/files/patch-max-24bpp44
2 files changed, 45 insertions, 1 deletions
diff --git a/graphics/imlib/Makefile b/graphics/imlib/Makefile
index 720e110618d1..7160e310f59e 100644
--- a/graphics/imlib/Makefile
+++ b/graphics/imlib/Makefile
@@ -8,7 +8,7 @@
PORTNAME= imlib
PORTVERSION= 1.9.15
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics
MASTER_SITES= GNOME
DIST_SUBDIR= gnome
diff --git a/graphics/imlib/files/patch-max-24bpp b/graphics/imlib/files/patch-max-24bpp
new file mode 100644
index 000000000000..7635bb36c9ca
--- /dev/null
+++ b/graphics/imlib/files/patch-max-24bpp
@@ -0,0 +1,44 @@
+Fix a bug in imlib so that kuickshow works.
+https://bugs.kde.org/show_bug.cgi?id=248431
+
+
+--- Imlib/misc.c
++++ Imlib/misc.c
+@@ -423,6 +423,8 @@
+ if (xvir[i].depth > max)
+ max = xvir[i].depth;
+ }
++ if (max > 24)
++ max = 24;
+ if (max > 8)
+ {
+ id->x.depth = max;
+@@ -1026,6 +1028,8 @@
+ if (xvir[i].depth > max)
+ max = xvir[i].depth;
+ }
++ if (max > 24)
++ max = 24;
+ if (max > 8)
+ {
+ id->x.depth = max;
+--- gdk_imlib/misc.c
++++ gdk_imlib/misc.c
+@@ -455,6 +455,8 @@
+ if (xvir[i].depth > max)
+ max = xvir[i].depth;
+ }
++ if (max > 24)
++ max = 24;
+ if (max > 8)
+ {
+ id->x.depth = max;
+@@ -1004,6 +1006,8 @@
+ if (xvir[i].depth > max)
+ max = xvir[i].depth;
+ }
++ if (max > 24)
++ max = 24;
+ if (max > 8)
+ {
+ id->x.depth = max;