aboutsummaryrefslogtreecommitdiff
path: root/graphics/jasper
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-11-15 10:07:32 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-11-15 10:07:32 +0000
commit0ae00ef6857e473693b09e8d1fb8866c91d235ff (patch)
treeb91d5e332c07336586b46f1fce6fac534664a462 /graphics/jasper
parent32ed97a0a64b81051010ca934cc1ea3612ca173c (diff)
downloadports-0ae00ef6857e473693b09e8d1fb8866c91d235ff.tar.gz
ports-0ae00ef6857e473693b09e8d1fb8866c91d235ff.zip
Add Jasper - a reference implementation of the image codec specified in the
JPEG-2000 standard.
Notes
Notes: svn path=/head/; revision=50047
Diffstat (limited to 'graphics/jasper')
-rw-r--r--graphics/jasper/Makefile31
-rw-r--r--graphics/jasper/distinfo1
-rw-r--r--graphics/jasper/pkg-comment1
-rw-r--r--graphics/jasper/pkg-descr5
-rw-r--r--graphics/jasper/pkg-plist25
5 files changed, 63 insertions, 0 deletions
diff --git a/graphics/jasper/Makefile b/graphics/jasper/Makefile
new file mode 100644
index 000000000000..e6f2b68ea942
--- /dev/null
+++ b/graphics/jasper/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: jasper
+# Date created: 6 November 1994
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jasper
+PORTVERSION= 1.500.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.ece.ubc.ca/~mdadams/jasper/software/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_ZIP= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+LIBTOOLFLAGS= --disable-ltlibs --release-ignore
+CONFIGURE_ARGS= --enable-shared --enable-static
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/jasper/distinfo b/graphics/jasper/distinfo
new file mode 100644
index 000000000000..67055d19583f
--- /dev/null
+++ b/graphics/jasper/distinfo
@@ -0,0 +1 @@
+MD5 (jasper-1.500.3.zip) = a33a65b3f609ae7b7f7a17fb559a2507
diff --git a/graphics/jasper/pkg-comment b/graphics/jasper/pkg-comment
new file mode 100644
index 000000000000..bd74f2b6ffd0
--- /dev/null
+++ b/graphics/jasper/pkg-comment
@@ -0,0 +1 @@
+An implementation of the codec specified in the JPEG-2000 standard
diff --git a/graphics/jasper/pkg-descr b/graphics/jasper/pkg-descr
new file mode 100644
index 000000000000..1fe5aa482c31
--- /dev/null
+++ b/graphics/jasper/pkg-descr
@@ -0,0 +1,5 @@
+JasPer is a software-based implementation of the codec specified in the
+emerging JPEG-2000 Part-1 standard (i.e., ISO/IEC 15444-1). The JasPer software
+is written in the C programming language.
+
+WWW: http://www.ece.ubc.ca/~mdadams/jasper/
diff --git a/graphics/jasper/pkg-plist b/graphics/jasper/pkg-plist
new file mode 100644
index 000000000000..e9583f640cd6
--- /dev/null
+++ b/graphics/jasper/pkg-plist
@@ -0,0 +1,25 @@
+bin/imgcmp
+bin/imginfo
+bin/jasper
+include/jasper/jas_debug.h
+include/jasper/jas_fix.h
+include/jasper/jas_getopt.h
+include/jasper/jas_image.h
+include/jasper/jas_init.h
+include/jasper/jas_malloc.h
+include/jasper/jas_math.h
+include/jasper/jas_seq.h
+include/jasper/jas_stream.h
+include/jasper/jas_string.h
+include/jasper/jas_tvp.h
+include/jasper/jas_types.h
+include/jasper/jas_version.h
+include/jasper/jasper.h
+lib/libjasper.a
+lib/libjasper.so
+lib/libjasper.so.3
+share/doc/jasper/README
+share/doc/jasper/jasper.html
+share/doc/jasper/jasper_small.gif
+@dirrm share/doc/jasper
+@dirrm include/jasper