aboutsummaryrefslogtreecommitdiff
path: root/graphics/jhead
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-05-14 21:45:46 +0000
committerPatrick Li <pat@FreeBSD.org>2002-05-14 21:45:46 +0000
commit18011ed32efa6995f29c04b72ce6d91a81c9a5b7 (patch)
tree4f5b70b9553cba8c26fcb199464ef859f87fbbad /graphics/jhead
parent12d112ab51f9d19e79dbd62a159acce31f9568a0 (diff)
downloadports-18011ed32efa6995f29c04b72ce6d91a81c9a5b7.tar.gz
ports-18011ed32efa6995f29c04b72ce6d91a81c9a5b7.zip
Update to 1.7
PR: 37975 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=59110
Diffstat (limited to 'graphics/jhead')
-rw-r--r--graphics/jhead/Makefile6
-rw-r--r--graphics/jhead/distinfo2
-rw-r--r--graphics/jhead/files/Makefile6
3 files changed, 8 insertions, 6 deletions
diff --git a/graphics/jhead/Makefile b/graphics/jhead/Makefile
index b9099e039d8e..5ccd53521581 100644
--- a/graphics/jhead/Makefile
+++ b/graphics/jhead/Makefile
@@ -6,16 +6,18 @@
#
PORTNAME= jhead
-PORTVERSION= 1.6
+PORTVERSION= 1.7
CATEGORIES= graphics
MASTER_SITES= http://www.sentex.net/~mwandel/jhead/
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= jamie@hermans.ca
MAKEFILE= ${FILESDIR}/Makefile
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/jhead ${PREFIX}/bin
.if !defined(NOPORTDOCS)
diff --git a/graphics/jhead/distinfo b/graphics/jhead/distinfo
index 859e53c985b2..58c66ddaefa9 100644
--- a/graphics/jhead/distinfo
+++ b/graphics/jhead/distinfo
@@ -1 +1 @@
-MD5 (jhead1.6.tar.gz) = 71f5d57df15add35f5a60bb372f0cf1a
+MD5 (jhead-1.7.tar.gz) = 99cc43ff2a2fa22845dd686ecd497313
diff --git a/graphics/jhead/files/Makefile b/graphics/jhead/files/Makefile
index cc9f11785303..be4d98535863 100644
--- a/graphics/jhead/files/Makefile
+++ b/graphics/jhead/files/Makefile
@@ -8,10 +8,10 @@ SRC=.
all: jhead
-objs = $(OBJ)/jhead.o $(OBJ)/exif.o
+objs = $(OBJ)/jhead.o $(OBJ)/jpgfile.o $(OBJ)/exif.o
$(OBJ)/%.o:$(SRC)/%.c
- cc ${CFLAGS} -Wall -c $< -o $@
+ ${CC} ${CFLAGS} -Wall -c $< -o $@
jhead: $(objs) jhead.h
- cc -o jhead $(objs) -lm
+ ${CC} -o jhead $(objs) -lm