aboutsummaryrefslogtreecommitdiff
path: root/graphics/jhead
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-12-19 10:00:41 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-12-19 10:00:41 +0000
commit556fa284449a34da4f68222f561efccf2160907e (patch)
tree384323c69f2287f6dddd0fcb33e03914a5048790 /graphics/jhead
parent91e2db011f1023828a2a64980beeadfc05157815 (diff)
downloadports-556fa284449a34da4f68222f561efccf2160907e.tar.gz
ports-556fa284449a34da4f68222f561efccf2160907e.zip
Add jhead 1.5, exif Jpeg camera setting parser and thumbnail remover.
PR: 32916 Submitted by: Jamie Hermans <jamie@hermans.ca>
Notes
Notes: svn path=/head/; revision=51811
Diffstat (limited to 'graphics/jhead')
-rw-r--r--graphics/jhead/Makefile29
-rw-r--r--graphics/jhead/distinfo1
-rw-r--r--graphics/jhead/files/Makefile17
-rw-r--r--graphics/jhead/pkg-comment1
-rw-r--r--graphics/jhead/pkg-descr21
-rw-r--r--graphics/jhead/pkg-plist3
6 files changed, 72 insertions, 0 deletions
diff --git a/graphics/jhead/Makefile b/graphics/jhead/Makefile
new file mode 100644
index 000000000000..5fdc4f4b9dd6
--- /dev/null
+++ b/graphics/jhead/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: jhead
+# Date created: 01 Dec 2001
+# Whom: Jamie Hermans <jamie@hermans.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jhead
+PORTVERSION= 1.5
+CATEGORIES= graphics
+MASTER_SITES= http://www.sentex.net/~mwandel/jhead/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= jhead
+
+MAINTAINER= jamie@hermans.ca
+
+USE_ZIP= yes
+
+NO_WRKSUBDIR= yes
+MAKEFILE= ${FILESDIR}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/jhead ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/usage.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/jhead/distinfo b/graphics/jhead/distinfo
new file mode 100644
index 000000000000..53d6d9d0245a
--- /dev/null
+++ b/graphics/jhead/distinfo
@@ -0,0 +1 @@
+MD5 (jhead.zip) = 4baed69ea14629f49ff4935915be6b12
diff --git a/graphics/jhead/files/Makefile b/graphics/jhead/files/Makefile
new file mode 100644
index 000000000000..cc9f11785303
--- /dev/null
+++ b/graphics/jhead/files/Makefile
@@ -0,0 +1,17 @@
+#--------------------------------
+# jhead makefile for FreeBSD
+# $FreeBSD$
+#--------------------------------
+
+OBJ=.
+SRC=.
+
+all: jhead
+
+objs = $(OBJ)/jhead.o $(OBJ)/exif.o
+
+$(OBJ)/%.o:$(SRC)/%.c
+ cc ${CFLAGS} -Wall -c $< -o $@
+
+jhead: $(objs) jhead.h
+ cc -o jhead $(objs) -lm
diff --git a/graphics/jhead/pkg-comment b/graphics/jhead/pkg-comment
new file mode 100644
index 000000000000..b31c0295659e
--- /dev/null
+++ b/graphics/jhead/pkg-comment
@@ -0,0 +1 @@
+Exif Jpeg camera setting parser and thumbnail remover
diff --git a/graphics/jhead/pkg-descr b/graphics/jhead/pkg-descr
new file mode 100644
index 000000000000..dad5f318c465
--- /dev/null
+++ b/graphics/jhead/pkg-descr
@@ -0,0 +1,21 @@
+'jhead' is a program to parse through the little file system in the Exif
+headers and extract digital camera settings.
+
+Information that the 'jhead' program can extract from an Exif file:
+
+ Integral low-res Exif thumbnail
+ Shutter speed
+ Camera F-stop number
+ Flash used (yes/no)
+ Focus distance (some digital cameras store this element)
+ Focal length (most zoom cameras store their zoomed-to focal length)
+ Equivalent 35mm focal length (Calculated from focal length, CCD
+ size, and CCD resolution)
+ Image resolution
+ Time and date picture was taken
+ Camera make and model
+
+WWW: http://www.sentex.net/~mwandel/jhead/
+
+- Jamie
+jamie@hermans.ca
diff --git a/graphics/jhead/pkg-plist b/graphics/jhead/pkg-plist
new file mode 100644
index 000000000000..70677f6dee8d
--- /dev/null
+++ b/graphics/jhead/pkg-plist
@@ -0,0 +1,3 @@
+bin/jhead
+%%PORTDOCS%%share/doc/jhead/usage.html
+%%PORTDOCS%%@dirrm share/doc/jhead