aboutsummaryrefslogtreecommitdiff
path: root/graphics/kdc2tiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-04 10:24:04 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-04 10:24:04 +0000
commit353684a9682f788b42f7c83f0bcb434c986e548f (patch)
tree505d007e9371edda5994864102c8fdd99667b8a3 /graphics/kdc2tiff
parent4057dd908a5142e0f6f89e47e67c624f3a313c68 (diff)
downloadports-353684a9682f788b42f7c83f0bcb434c986e548f.tar.gz
ports-353684a9682f788b42f7c83f0bcb434c986e548f.zip
- Update to version 0.34
PR: 59754 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=94932
Diffstat (limited to 'graphics/kdc2tiff')
-rw-r--r--graphics/kdc2tiff/Makefile4
-rw-r--r--graphics/kdc2tiff/distinfo2
-rw-r--r--graphics/kdc2tiff/files/patch-GFilter.cpp11
-rw-r--r--graphics/kdc2tiff/files/patch-GICBayer.cpp29
-rw-r--r--graphics/kdc2tiff/files/patch-GImageComponent.cpp11
5 files changed, 3 insertions, 54 deletions
diff --git a/graphics/kdc2tiff/Makefile b/graphics/kdc2tiff/Makefile
index 13c6c3610528..1698fd0044e5 100644
--- a/graphics/kdc2tiff/Makefile
+++ b/graphics/kdc2tiff/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdc2tiff
-PORTVERSION= 0.32
+PORTVERSION= 0.34
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,6 +20,6 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
diff --git a/graphics/kdc2tiff/distinfo b/graphics/kdc2tiff/distinfo
index e9ab7d2416b0..8f1029dd4da8 100644
--- a/graphics/kdc2tiff/distinfo
+++ b/graphics/kdc2tiff/distinfo
@@ -1 +1 @@
-MD5 (kdc2tiff-0.32.tar.gz) = b24af53e97a047eaf1a92cbe1da44a17
+MD5 (kdc2tiff-0.34.tar.gz) = 16208a5e07926d1f7aa21779014d1a53
diff --git a/graphics/kdc2tiff/files/patch-GFilter.cpp b/graphics/kdc2tiff/files/patch-GFilter.cpp
deleted file mode 100644
index 5db75652c75d..000000000000
--- a/graphics/kdc2tiff/files/patch-GFilter.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- GFilter.cpp.orig Mon Dec 23 04:20:42 2002
-+++ GFilter.cpp Mon Dec 23 04:21:00 2002
-@@ -26,7 +26,7 @@
- green = *(short*)(((char*)table)+(green&0xFFFE));
- blue = *(short*)(((char*)table)+(blue&0xFFFE));
- }
--void GFilter_GammaCorrection::setGammaCorrection(float gamma=1) {
-+void GFilter_GammaCorrection::setGammaCorrection(float gamma) {
- // create table
- if (table)
- delete[] table;
diff --git a/graphics/kdc2tiff/files/patch-GICBayer.cpp b/graphics/kdc2tiff/files/patch-GICBayer.cpp
deleted file mode 100644
index ba9fce0accee..000000000000
--- a/graphics/kdc2tiff/files/patch-GICBayer.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
---- GICBayer.cpp.orig Mon Dec 23 04:19:54 2002
-+++ GICBayer.cpp Mon Dec 23 04:20:21 2002
-@@ -236,7 +236,7 @@
-
- GICBayer_Green::GICBayer_Green(const unsigned char* imagedata,
- int width, int height,
-- float maxerr=0)
-+ float maxerr)
- : GImageComponent(width,height,maxerr) {
-
- /* initialize arrays
-@@ -428,7 +428,7 @@
- GICBayer_Red::GICBayer_Red(const unsigned char* imagedata,
- int width, int height,
- GImageComponent& green,
-- float maxerr=0)
-+ float maxerr)
- : GImageComponent(width,height,maxerr) {
-
- if ((green.getWidth()!=w)||(green.getHeight()!=h)) {
-@@ -617,7 +617,7 @@
- GICBayer_Blue::GICBayer_Blue(const unsigned char* imagedata,
- int width, int height,
- GImageComponent& green,
-- float maxerr=0)
-+ float maxerr)
- : GImageComponent(width,height,maxerr) {
-
- if ((green.getWidth()!=w)||(green.getHeight()!=h)) {
diff --git a/graphics/kdc2tiff/files/patch-GImageComponent.cpp b/graphics/kdc2tiff/files/patch-GImageComponent.cpp
deleted file mode 100644
index 4f53a2dd8631..000000000000
--- a/graphics/kdc2tiff/files/patch-GImageComponent.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- GImageComponent.cpp.orig Mon Dec 23 04:19:27 2002
-+++ GImageComponent.cpp Mon Dec 23 04:19:39 2002
-@@ -283,7 +283,7 @@
-
- GImageComponent0::GImageComponent0(const unsigned char* imagedata,
- int width, int height,
-- float maxerr=0)
-+ float maxerr)
- : GImageComponent(width,height,maxerr) {
-
- int itter;