aboutsummaryrefslogtreecommitdiff
path: root/graphics/kix-kmod/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-11-09 19:13:27 +0000
committerRene Ladan <rene@FreeBSD.org>2013-11-09 19:13:27 +0000
commitbfc52e710421bd92466b329f6fbb9be930eb4755 (patch)
tree7436338612f22a81def9ee6c2d2e3826c1504ea4 /graphics/kix-kmod/Makefile
parent16a624cb31062d141fd07c5dc3f7794ed7fe74cd (diff)
downloadports-bfc52e710421bd92466b329f6fbb9be930eb4755.tar.gz
ports-bfc52e710421bd92466b329f6fbb9be930eb4755.zip
Convert to USES=kmod, which removes duplicated code and ensures that all
required steps are followed. There are no user-visible changes. The exception is multimedia/ptx-kmod, which now installs the kernel module into /boot/modules instead of ${PREFIX}/libexec/${PORTNAME}, this was something USES=kmod cannot handle. PR: ports/183625 Submitted by: myself Approved by: portmgr (bdrewery) Exp-run by: bdrewery
Notes
Notes: svn path=/head/; revision=333329
Diffstat (limited to 'graphics/kix-kmod/Makefile')
-rw-r--r--graphics/kix-kmod/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/graphics/kix-kmod/Makefile b/graphics/kix-kmod/Makefile
index d23dda5bdbb9..48568a235c67 100644
--- a/graphics/kix-kmod/Makefile
+++ b/graphics/kix-kmod/Makefile
@@ -4,7 +4,7 @@
PORTNAME= kix
PORTVERSION= 1.0
PORTREVISION= 1
-CATEGORIES= graphics kld
+CATEGORIES= graphics
MASTER_SITES= http://homepage.ntlworld.com/jon.belson/files/kix-1.0.tar.gz \
LOCAL/pgollucci
PKGNAMESUFFIX= -kmod
@@ -12,15 +12,11 @@ PKGNAMESUFFIX= -kmod
MAINTAINER= jon@witchspace.com
COMMENT= A graphical screensaver kernel module
-SSP_UNSAFE= kernel module does not support ssp
-
NO_STAGE= yes
+
+USES= kmod
.include <bsd.port.pre.mk>
-SYSDIR?= ${SRC_BASE}/sys
-.if !exists(${SYSDIR}/dev/syscons/syscons.h)
-IGNORE= requires kernel source (in ${SYSDIR}) to build
-.endif
MAKE_ENV+= WERROR=
PLIST_FILES= lib/kix_saver.ko
SUB_FILES= pkg-message