aboutsummaryrefslogtreecommitdiff
path: root/graphics/lcms
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2002-01-05 10:53:21 +0000
committerMikhail Teterin <mi@FreeBSD.org>2002-01-05 10:53:21 +0000
commit100babe355052f52b79ab76f28a3b0a42726ed83 (patch)
tree93f48cacaedd88833e4c2f5347b7f5365bacfa54 /graphics/lcms
parent3c235f227d9a373c6ab467bd8f0a6a19590ea821 (diff)
downloadports-100babe355052f52b79ab76f28a3b0a42726ed83.tar.gz
ports-100babe355052f52b79ab76f28a3b0a42726ed83.zip
Upgrade to 1.08. The tests report success on Alpha too (beast), even
though there are plenty of messages about unalligned access... (Notably, the author incorporated almost all of our 32-bit related patches). PR: ports/33528 Submitted by: Lev A. Serebryakov
Notes
Notes: svn path=/head/; revision=52608
Diffstat (limited to 'graphics/lcms')
-rw-r--r--graphics/lcms/Makefile9
-rw-r--r--graphics/lcms/distinfo2
-rw-r--r--graphics/lcms/files/Makefile.bsd6
-rw-r--r--graphics/lcms/files/patch-32bit118
-rw-r--r--graphics/lcms/files/patch-icc3411
-rw-r--r--graphics/lcms/files/patch-test10
-rw-r--r--graphics/lcms/pkg-plist2
7 files changed, 18 insertions, 140 deletions
diff --git a/graphics/lcms/Makefile b/graphics/lcms/Makefile
index ea1fb90d5868..cd1685ac6e32 100644
--- a/graphics/lcms/Makefile
+++ b/graphics/lcms/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lcms
-PORTVERSION= 1.07
-PORTREVISION= 1
+PORTVERSION= 1.08
CATEGORIES= graphics
MASTER_SITES= http://www.littlecms.com/
@@ -21,13 +20,13 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
.ifndef NOPORTDOCS
post-install:
${MKDIR} ${PREFIX}/share/doc/lcms
- ${CP} -rp ${WRKSRC}/../doc/* ${WRKSRC}/../samples/tifficc.c \
- ${WRKSRC}/../samples/wtpt.c ${WRKSRC}/../samples/neutral.c \
+ ${CP} -rp ${WRKSRC}/../doc/* ${WRKSRC}/../tifficc/tifficc.c \
+ ${WRKSRC}/../samples/wtpt.c ${WRKSRC}/../samples/icctrans.c \
${PREFIX}/share/doc/lcms/
.endif
post-build test:
cd ${WRKSRC}/../testbed && \
- ${SETENV} CFLAGS="${CFLAGS} -I../src" make -E CFLAGS test
+ ${SETENV} CFLAGS="${CFLAGS} -I../include" make -E CFLAGS test
.include <bsd.port.mk>
diff --git a/graphics/lcms/distinfo b/graphics/lcms/distinfo
index 2957cc2fd36e..7dea9544ba30 100644
--- a/graphics/lcms/distinfo
+++ b/graphics/lcms/distinfo
@@ -1 +1 @@
-MD5 (lcms-1.07.tar.gz) = bea30720a2a322b5b25e4f5b657f6994
+MD5 (lcms-1.08.tar.gz) = a1987f5043bc1a21f94c9dbc4adccbfe
diff --git a/graphics/lcms/files/Makefile.bsd b/graphics/lcms/files/Makefile.bsd
index c9816d499003..a4d9f29d4420 100644
--- a/graphics/lcms/files/Makefile.bsd
+++ b/graphics/lcms/files/Makefile.bsd
@@ -1,12 +1,14 @@
LIB=lcms
SHLIB_MAJOR= 1
-SHLIB_MINOR= 7
+SHLIB_MINOR= 8
SRCS!= make -f ${.CURDIR}/Makefile -V SRCS
NOPROFILE=YES
-INCS= lcms.h icc34.h
+INCS= ${.CURDIR}/../include/lcms.h ${.CURDIR}/../include/icc34.h
+
+CFLAGS+= -I${.CURDIR}/../include
INCDIR= ${LOCALBASE}/include
LIBDIR= ${LOCALBASE}/lib
diff --git a/graphics/lcms/files/patch-32bit b/graphics/lcms/files/patch-32bit
index 6a458fad6f06..1090667ce8e2 100644
--- a/graphics/lcms/files/patch-32bit
+++ b/graphics/lcms/files/patch-32bit
@@ -1,127 +1,15 @@
This patch fixes assumptions made in different parts of the code
regarding the sizeof long and int. The original code appears to use them
interchangeably, even though it expects them to be 32 bit wide.
---- cmsio1.c Tue Feb 13 12:08:06 2001
-+++ cmsio1.c Wed Sep 5 10:20:58 2001
-@@ -96,5 +96,5 @@
- /* Dictionary */
-
-- int TagCount;
-+ icInt32Number TagCount;
- icTagSignature TagNames[MAX_TABLE_TAG];
- size_t TagSizes[MAX_TABLE_TAG];
-@@ -194,5 +194,5 @@
- icTag Tag;
- icHeader Header;
-- long TagCount, i;
-+ icInt32Number TagCount, i;
-
- fread(&Header, sizeof(icHeader), 1, ICCfile);
-@@ -230,5 +230,5 @@
- Icc -> stream = ICCfile;
-
-- if (fread(&TagCount, sizeof(long), 1, ICCfile) != 1)
-+ if (fread(&TagCount, sizeof(TagCount), 1, ICCfile) != 1)
- goto ErrorCleanup;
-
-@@ -276,7 +276,7 @@
-
- static
--int SearchTag(LPICCPROFILE Profile, icTagSignature sig)
-+icInt32Number SearchTag(LPICCPROFILE Profile, icTagSignature sig)
- {
-- int i;
-+ icInt32Number i;
-
- for (i=0; i < Profile -> TagCount; i++)
-@@ -297,5 +297,5 @@
- {
- LPVOID Ptr;
-- int i;
-+ icInt32Number i;
-
- i = SearchTag(Icc, sig);
-@@ -525,5 +525,5 @@
- if (!file)
- {
-- int i;
-+ icInt32Number i;
-
- for (i=0; i < icco -> TagCount; i++)
-@@ -1383,7 +1383,7 @@
-
- static
--long TransportValue32(long Value)
-+icInt32Number TransportValue32(icInt32Number Value)
- {
-- long Temp = Value;
-+ icInt32Number Temp = Value;
-
- AdjustEndianess32((LPBYTE) &Temp);
-@@ -1520,5 +1520,5 @@
- BOOL SaveGamma(FILE *OutStream, LPGAMMATABLE Gamma)
- {
-- long Count;
-+ icInt32Number Count;
- int i;
-
-@@ -1528,5 +1528,5 @@
- Count = TransportValue32(Gamma->nEntries);
-
-- if (!DoWrite(OutStream, sizeof(long), &Count)) return FALSE;
-+ if (!DoWrite(OutStream, sizeof(Count), &Count)) return FALSE;
-
- for (i=0; i < Gamma->nEntries; i++)
-@@ -1549,5 +1549,5 @@
-
-
--/* Save an ASCII Tag (long) */
-+/* Save an ASCII Tag (icInt32Number) */
-
- static
-@@ -1644,9 +1644,9 @@
- BOOL SaveTagDirectory(FILE *OutStream, LPICCPROFILE Icc)
- {
-- int i;
-+ icInt32Number i;
- icTag Tag;
-- long TagCount = TransportValue32(Icc -> TagCount);
-+ icInt32Number TagCount = TransportValue32(Icc -> TagCount);
-
-- if (!DoWrite(OutStream, sizeof(long) , &TagCount)) return FALSE;
-+ if (!DoWrite(OutStream, sizeof(TagCount) , &TagCount)) return FALSE;
-
- for (i=0; i < Icc -> TagCount; i++) {
-@@ -1670,5 +1670,5 @@
-
- LPBYTE Data;
-- int i;
-+ icInt32Number i;
- size_t Begin;
-
--- cmsmtrx.c Tue Feb 13 12:08:06 2001
+++ cmsmtrx.c Wed Sep 5 10:28:02 2001
@@ -705,6 +705,6 @@
void VEC3scaleAndCut(LPWVEC3 r, LPVEC3 v, double d)
{
-- r -> n[VX] = (long) floor(v -> n[VX] * d + .5);
-- r -> n[VY] = (long) floor(v -> n[VY] * d + .5);
-- r -> n[VZ] = (long) floor(v -> n[VZ] * d + .5);
+- r -> n[VX] = (int) floor(v -> n[VX] * d + .5);
+- r -> n[VY] = (int) floor(v -> n[VY] * d + .5);
+- r -> n[VZ] = (int) floor(v -> n[VZ] * d + .5);
+ r -> n[VX] = (icInt32Number) floor(v -> n[VX] * d + .5);
+ r -> n[VY] = (icInt32Number) floor(v -> n[VY] * d + .5);
+ r -> n[VZ] = (icInt32Number) floor(v -> n[VZ] * d + .5);
}
---- lcms.h Mon Feb 19 04:55:06 2001
-+++ lcms.h Wed Sep 5 10:31:08 2001
-@@ -621,9 +621,9 @@
- /* Fixed point */
-
--typedef long Fixed32; /* Fixed 15.16 whith sign */
-+typedef icInt32Number Fixed32; /* Fixed 15.16 whith sign */
-
-
- #define INT_TO_FIXED(x) ((x)<<16)
--#define DOUBLE_TO_FIXED(x) ((long)((x)*65536.0+.5))
-+#define DOUBLE_TO_FIXED(x) ((icInt32Number)((x)*65536.0+.5))
- #define FIXED_TO_INT(x) ((x)>>16)
- #define FIXED_REST_TO_INT(x) ((x)&0xFFFFU)
diff --git a/graphics/lcms/files/patch-icc34 b/graphics/lcms/files/patch-icc34
index cbfc341be5c7..21b8d5b18cc0 100644
--- a/graphics/lcms/files/patch-icc34
+++ b/graphics/lcms/files/patch-icc34
@@ -1,14 +1,13 @@
Try to use the int32 and friends on all Unixes -- not just SGI's Irix.
---- icc34.h Tue Feb 13 12:08:06 2001
-+++ icc34.h Wed Sep 5 10:08:42 2001
-@@ -141,8 +141,10 @@
- * etc into icXXX form. The rest of the header uses the icXXX
- * typedefs. Signatures are 4 byte quantities.
+--- ../include/icc34.h Tue Feb 13 12:08:06 2001
++++ ../include/icc34.h Wed Sep 5 10:08:42 2001
+@@ -144,7 +144,9 @@
*/
+
+#ifdef __unix__
#ifdef __sgi
#include "sgidefs.h"
+#endif
- typedef __int32_t icSignature;
+ typedef __int32_t icSignature;
diff --git a/graphics/lcms/files/patch-test b/graphics/lcms/files/patch-test
deleted file mode 100644
index 0d224b296513..000000000000
--- a/graphics/lcms/files/patch-test
+++ /dev/null
@@ -1,10 +0,0 @@
-Inititialize/clear more variables. Now this test works on Alphas too.
---- ../testbed/testcms.c Tue Feb 13 12:08:32 2001
-+++ ../testbed/testcms.c Wed Sep 5 10:04:07 2001
-@@ -582,5 +582,5 @@
- static void ClearStats(LPSTATS p)
- {
-- p -> x = p -> y = p -> x2 = p -> y2 = p -> xy
-+ p -> n = p -> x = p -> y = p -> x2 = p -> y2 = p -> xy
- = p -> Peak = 0.0;
- }
diff --git a/graphics/lcms/pkg-plist b/graphics/lcms/pkg-plist
index 37bb98aeb721..bf2db41ae5ed 100644
--- a/graphics/lcms/pkg-plist
+++ b/graphics/lcms/pkg-plist
@@ -5,7 +5,7 @@ lib/liblcms.so
lib/liblcms.so.1.7
%%PORTDOCS%%share/doc/lcms/LCMSAPI.TXT
%%PORTDOCS%%share/doc/lcms/TUTORIAL.TXT
-%%PORTDOCS%%share/doc/lcms/neutral.c
+%%PORTDOCS%%share/doc/lcms/icctrans.c
%%PORTDOCS%%share/doc/lcms/tifficc.c
%%PORTDOCS%%share/doc/lcms/wtpt.c
%%PORTDOCS%%@dirrm share/doc/lcms