aboutsummaryrefslogtreecommitdiff
path: root/graphics/libEGL/Makefile
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-09-29 17:01:41 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-09-29 17:01:41 +0000
commit5a4c543c2b0f538631aea8379ce384d5defee89d (patch)
tree108a55d148b3bc801facab0fb03b8666659c1136 /graphics/libEGL/Makefile
parent7231ff2710fcc89472994d2e2d235e74e9c8704c (diff)
downloadports-5a4c543c2b0f538631aea8379ce384d5defee89d.tar.gz
ports-5a4c543c2b0f538631aea8379ce384d5defee89d.zip
The FreeBSD graphics/x11 team proudly presents
a kwm, zeising production: MESA 9.1.6 Starring: Mesa 9.1.6, including libGL, libGLU and dri (new xorg only) Addition of libEGL and libglesv2 KMS support for ATI graphics cards in 10-current (new xorg only) Improved sparc64 support for new xorg. [1] pixman 0.30.2, including shlib bump and portrevision bumps libX11 1.6.2 Make absolute pointing devices work with x11-drivers/xf86-input-mouse x11-drivers/xf86-video-ati 7.2.0 for 10-current (KMS aware ati driver) Also starring: Updates to drivers and other libraries and utilities Additional notes: When updating MESA related ports (libGL, dri) you need to remove old versions first. See UPDATING for details. PR: ports/181962 [2] Submitted by: marius [1] zeising [2] Exp-run by: bdrewery Approved by: portmgr (bdrewery) Thanks to all who helped testing!
Notes
Notes: svn path=/head/; revision=328711
Diffstat (limited to 'graphics/libEGL/Makefile')
-rw-r--r--graphics/libEGL/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/graphics/libEGL/Makefile b/graphics/libEGL/Makefile
new file mode 100644
index 000000000000..2e023af81038
--- /dev/null
+++ b/graphics/libEGL/Makefile
@@ -0,0 +1,30 @@
+# Created by: kwm@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= libEGL
+PORTVERSION= ${MESAVERSION}
+CATEGORIES= graphics
+
+COMMENT= OpenEGL library
+
+LIB_DEPENDS+= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs
+
+.if ! defined(WITH_NEW_XORG)
+IGNORE= Please enable WITH_NEW_XORG, libEGL needs libdrm higher then 2.4.24
+.endif
+
+USE_XORG= x11 xau xcb xdmcp
+
+# stuff not needed by libEGL but configure wants it
+USE_XORG+= glproto dri2proto xext xdamage xfixes
+LIB_DEPENDS+= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libdrm.so:${PORTSDIR}/graphics/libdrm
+
+BUILD_WKRSRC= ${WRKSRC}/src/egl
+INSTALL_WRKSRC= ${WRKSRC}/src/egl
+
+WITH_NEW_XORG= yes
+
+.include <bsd.port.options.mk>
+.include "${.CURDIR}/../../graphics/libGL/bsd.mesalib.mk"
+.include <bsd.port.mk>