aboutsummaryrefslogtreecommitdiff
path: root/graphics/libemf
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2013-10-29 02:54:44 +0000
committerMaho Nakata <maho@FreeBSD.org>2013-10-29 02:54:44 +0000
commit97ebc5ad222f3c37ee24e36325a8685ff52ca3c7 (patch)
treeb592b788a34b6ef38272b80d5d969f3e91adfb1c /graphics/libemf
parent6254f9f50c798e78a20ca7624982dc0d42cc9a92 (diff)
downloadports-97ebc5ad222f3c37ee24e36325a8685ff52ca3c7.tar.gz
ports-97ebc5ad222f3c37ee24e36325a8685ff52ca3c7.zip
Update to 1.0.7.
Notes
Notes: svn path=/head/; revision=331928
Diffstat (limited to 'graphics/libemf')
-rw-r--r--graphics/libemf/Makefile2
-rw-r--r--graphics/libemf/distinfo4
-rw-r--r--graphics/libemf/files/patch-include+wine+winbase.h18
-rw-r--r--graphics/libemf/files/patch-include+wine+winnt.h51
-rw-r--r--graphics/libemf/files/patch-libemf+libemf.cpp29
-rw-r--r--graphics/libemf/files/patch-libemf+libemf.h43
-rw-r--r--graphics/libemf/pkg-plist76
7 files changed, 79 insertions, 144 deletions
diff --git a/graphics/libemf/Makefile b/graphics/libemf/Makefile
index bd510f389cf7..2bc2cbb2c50e 100644
--- a/graphics/libemf/Makefile
+++ b/graphics/libemf/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libEMF
-PORTVERSION= 1.0
+PORTVERSION= 1.0.7
CATEGORIES= graphics
MASTER_SITES= SF
diff --git a/graphics/libemf/distinfo b/graphics/libemf/distinfo
index b157e20b24f1..cef52d32e4f6 100644
--- a/graphics/libemf/distinfo
+++ b/graphics/libemf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libEMF-1.0.tar.gz) = c45702f242b5a63dd64f1008a3f0b53b237e8fb7bb1c38db19f4b43abe04fc25
-SIZE (libEMF-1.0.tar.gz) = 641815
+SHA256 (libEMF-1.0.7.tar.gz) = 9f2fd8bb84e345978c7fc45a39e06fc6a44fee867a91ebe83433d3a34348fd21
+SIZE (libEMF-1.0.7.tar.gz) = 908973
diff --git a/graphics/libemf/files/patch-include+wine+winbase.h b/graphics/libemf/files/patch-include+wine+winbase.h
deleted file mode 100644
index 77f80c96200e..000000000000
--- a/graphics/libemf/files/patch-include+wine+winbase.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- include/wine/winbase.h.org 2009-02-17 09:53:26.000000000 +0900
-+++ include/wine/winbase.h 2009-02-17 09:54:24.000000000 +0900
-@@ -1802,6 +1802,7 @@
- VOID WINAPI SetLastError(DWORD);
- #endif /* __i386__ && __GNUC__ */
-
-+#if !defined(__alpha__) && !defined(__amd64__) && !defined(__ia64__) && !defined(__sparc64__)
- /* FIXME: should handle platforms where sizeof(void*) != sizeof(long) */
- static inline PVOID WINAPI InterlockedCompareExchangePointer( PVOID *dest, PVOID xchg, PVOID compare )
- {
-@@ -1813,6 +1814,7 @@
- return (PVOID)InterlockedExchange( (PLONG)dest, (LONG)val );
- }
-
-+#endif
- #ifdef __WINE__
- #define GetCurrentProcess() ((HANDLE)0xffffffff)
- #define GetCurrentThread() ((HANDLE)0xfffffffe)
diff --git a/graphics/libemf/files/patch-include+wine+winnt.h b/graphics/libemf/files/patch-include+wine+winnt.h
deleted file mode 100644
index 69dd801d5f6c..000000000000
--- a/graphics/libemf/files/patch-include+wine+winnt.h
+++ /dev/null
@@ -1,51 +0,0 @@
---- include/wine/winnt.h.orig Tue Jan 29 13:31:53 2002
-+++ include/wine/winnt.h Wed Mar 17 20:00:59 2004
-@@ -45,6 +45,18 @@
- # undef WORDS_BIGENDIAN
- # undef BITFIELDS_BIGENDIAN
- # undef ALLOW_UNALIGNED_ACCESS
-+#elif defined(__amd64__)
-+# undef WORDS_BIGENDIAN
-+# undef BITFIELDS_BIGENDIAN
-+# define ALLOW_UNALIGNED_ACCESS
-+#elif defined(__ia64__)
-+# undef WORDS_BIGENDIAN
-+# undef BITFIELDS_BIGENDIAN
-+# define ALLOW_UNALIGNED_ACCESS
-+#elif defined(__sparc64__)
-+# undef WORDS_BIGENDIAN
-+# undef BITFIELDS_BIGENDIAN
-+# define ALLOW_UNALIGNED_ACCESS
- #elif !defined(RC_INVOKED)
- # error Unknown CPU architecture!
- #endif
-@@ -211,7 +223,7 @@
- typedef unsigned short WORD, *PWORD, *LPWORD;
- typedef int INT, *PINT, *LPINT;
- typedef unsigned int UINT, *PUINT, *LPUINT;
--#if !defined(__alpha__)
-+#if !defined(__alpha__) && !defined(__amd64__) && !defined(__ia64__) && !defined(__sparc64__)
- typedef unsigned long DWORD, *PDWORD, *LPDWORD;
- typedef unsigned long ULONG, *PULONG, *LPULONG;
- #else /* defined( __alpha__ ) */
-@@ -257,7 +269,7 @@
- typedef BYTE BOOLEAN, *PBOOLEAN;
- typedef char CHAR, *PCHAR;
- typedef short SHORT, *PSHORT;
--#if !defined(__alpha__)
-+#if !defined(__alpha__) && !defined(__amd64__) && !defined(__ia64__) && !defined(__sparc64__)
- typedef long LONG, *PLONG, *LPLONG;
- #else /* defined( __alpha__ ) */
- typedef int LONG, *PLONG, *LPLONG;
-@@ -1044,6 +1056,11 @@
- } CONTEXT;
-
- #endif /* __sparc__ */
-+
-+#if defined(__amd64__) || defined(__ia64__)
-+#define CONTEXT_FULL 1
-+typedef struct _CONTEXT CONTEXT;
-+#endif
-
- #if !defined(CONTEXT_FULL) && !defined(RC_INVOKED)
- #error You need to define a CONTEXT for your CPU
diff --git a/graphics/libemf/files/patch-libemf+libemf.cpp b/graphics/libemf/files/patch-libemf+libemf.cpp
deleted file mode 100644
index 8b2dc132d193..000000000000
--- a/graphics/libemf/files/patch-libemf+libemf.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
---- libemf/libemf.cpp.org Sat Oct 4 09:50:55 2003
-+++ libemf/libemf.cpp Sat Oct 4 09:51:09 2003
-@@ -849,7 +849,7 @@
- if ( dc->fp ) {
-
- std::for_each( dc->records.begin(), dc->records.end(),
-- std::bind2nd( std::mem_fun1( &EMF::METARECORD::serialize ),
-+ std::bind2nd( mem_fun1( &EMF::METARECORD::serialize ),
- dc->ds ) );
- fclose( dc->fp );
-
-@@ -896,7 +896,7 @@
- if ( dc->fp ) {
-
- std::for_each( dc->records.begin(), dc->records.end(),
-- std::bind2nd( std::mem_fun1( &EMF::METARECORD::serialize ),
-+ std::bind2nd( mem_fun1( &EMF::METARECORD::serialize ),
- dc->ds ) );
- }
-
-@@ -1108,7 +1108,7 @@
- if ( dc == 0 ) return;
-
- std::for_each( dc->records.begin(), dc->records.end(),
-- std::mem_fun( &EMF::METARECORD::edit ) );
-+ mem_fun( &EMF::METARECORD::edit ) );
- #endif /* ENABLE_EDITING */
- }
-
diff --git a/graphics/libemf/files/patch-libemf+libemf.h b/graphics/libemf/files/patch-libemf+libemf.h
deleted file mode 100644
index 5455dfeb2459..000000000000
--- a/graphics/libemf/files/patch-libemf+libemf.h
+++ /dev/null
@@ -1,43 +0,0 @@
---- libemf/libemf.h.orig Wed Mar 17 20:00:10 2004
-+++ libemf/libemf.h Wed Mar 17 20:00:10 2004
-@@ -21,16 +21,22 @@
- #ifndef _LIBEMF_H
- #define _LIBEMF_H 1
-
-+#include <iostream>
- #include <cmath>
- #include <vector>
- #include <map>
- #include <functional>
-+#if __GNUC__ > 2
-+#include <backward/function.h>
-+#endif
- #include <algorithm>
-
- #include <config.h>
- #include <emf.h>
-
- #include <wine/w16.h>
-+
-+using namespace std;
-
- namespace EMF {
- /*!
-@@ -338,7 +338,7 @@
- fread( &dword, sizeof(DWORD), 1, fp_ );
- return *this;
- }
--#if !defined(__alpha__)
-+#if !defined(__alpha__) && !defined(__amd64__) && !defined(__ia64__) && !defined(__sparc64__)
- /*!
- * Output a long int to the stream (swabbed).
- * \param long long int to output.
-@@ -408,7 +408,7 @@
- fread( &int_, sizeof(INT), 1, fp_ );
- return *this;
- }
--#if !defined(__alpha__)
-+#if !defined(__alpha__) && !defined(__amd64__) && !defined(__ia64__) && !defined(__sparc64__)
- /*!
- * Output a (long) unsigned int to the stream (swabbed).
- * \param uint (long) unsigned int to output.
diff --git a/graphics/libemf/pkg-plist b/graphics/libemf/pkg-plist
index edf7f9db3aaa..aca9cb7f2f41 100644
--- a/graphics/libemf/pkg-plist
+++ b/graphics/libemf/pkg-plist
@@ -22,187 +22,254 @@ lib/libEMF.so.1
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1BRUSH-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1BRUSH.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1BRUSH.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1BRUSH.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1DATASTREAM-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1DATASTREAM.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRARC-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRARC.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRARC.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRARC.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRARCTO-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRARCTO.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRARCTO.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRARCTO.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRBEGINPATH-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRBEGINPATH.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRBEGINPATH.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRBEGINPATH.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCLOSEFIGURE-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCLOSEFIGURE.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCLOSEFIGURE.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCLOSEFIGURE.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCREATEBRUSHINDIRECT-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCREATEBRUSHINDIRECT.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCREATEBRUSHINDIRECT.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCREATEBRUSHINDIRECT.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCREATEPALETTE-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCREATEPALETTE.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCREATEPALETTE.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCREATEPALETTE.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCREATEPEN-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCREATEPEN.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCREATEPEN.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRCREATEPEN.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRDELETEOBJECT-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRDELETEOBJECT.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRDELETEOBJECT.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRDELETEOBJECT.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRELLIPSE-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRELLIPSE.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRELLIPSE.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRELLIPSE.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRENDPATH-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRENDPATH.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRENDPATH.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRENDPATH.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREOF-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREOF.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREOF.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREOF.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREXTCREATEFONTINDIRECTW-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREXTCREATEFONTINDIRECTW.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREXTCREATEFONTINDIRECTW.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREXTCREATEFONTINDIRECTW.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREXTCREATEPEN-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREXTCREATEPEN.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREXTCREATEPEN.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREXTCREATEPEN.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREXTTEXTOUTA-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREXTTEXTOUTA.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREXTTEXTOUTA.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMREXTTEXTOUTA.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRFILLPATH-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRFILLPATH.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRFILLPATH.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRFILLPATH.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRLINETO-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRLINETO.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRLINETO.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRLINETO.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRMODIFYWORLDTRANSFORM-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRMODIFYWORLDTRANSFORM.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRMODIFYWORLDTRANSFORM.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRMODIFYWORLDTRANSFORM.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRMOVETOEX-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRMOVETOEX.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRMOVETOEX.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRMOVETOEX.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIER-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIER.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIER.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIER.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIER16-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIER16.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIER16.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIER16.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIERTO-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIERTO.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIERTO.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIERTO.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIERTO16-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIERTO16.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIERTO16.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYBEZIERTO16.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYGON-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYGON.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYGON.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYGON.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYGON16-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYGON16.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYGON16.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYGON16.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINE-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINE.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINE.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINE.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINE16-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINE16.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINE16.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINE16.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINETO-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINETO.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINETO.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINETO.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINETO16-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINETO16.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINETO16.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYLINETO16.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYPOLYGON-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYPOLYGON.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYPOLYGON.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYPOLYGON.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYPOLYGON16-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYPOLYGON16.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYPOLYGON16.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRPOLYPOLYGON16.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRRECTANGLE-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRRECTANGLE.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRRECTANGLE.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRRECTANGLE.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRRESTOREDC-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRRESTOREDC.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRRESTOREDC.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRRESTOREDC.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSAVEDC-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSAVEDC.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSAVEDC.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSAVEDC.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSCALEVIEWPORTEXTEX-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSCALEVIEWPORTEXTEX.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSCALEVIEWPORTEXTEX.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSCALEVIEWPORTEXTEX.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSCALEWINDOWEXTEX-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSCALEWINDOWEXTEX.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSCALEWINDOWEXTEX.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSCALEWINDOWEXTEX.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSELECTOBJECT-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSELECTOBJECT.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSELECTOBJECT.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSELECTOBJECT.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETBKCOLOR-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETBKCOLOR.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETBKCOLOR.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETBKCOLOR.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETBKMODE-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETBKMODE.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETBKMODE.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETBKMODE.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETMAPMODE-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETMAPMODE.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETMAPMODE.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETMAPMODE.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETMETARGN-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETMETARGN.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETMETARGN.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETMETARGN.png
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETMITERLIMIT-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETMITERLIMIT.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETMITERLIMIT.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETPIXELV-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETPIXELV.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETPIXELV.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETPIXELV.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETPOLYFILLMODE-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETPOLYFILLMODE.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETPOLYFILLMODE.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETPOLYFILLMODE.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETTEXTALIGN-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETTEXTALIGN.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETTEXTALIGN.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETTEXTALIGN.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETTEXTCOLOR-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETTEXTCOLOR.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETTEXTCOLOR.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETTEXTCOLOR.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETVIEWPORTEXTEX-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETVIEWPORTEXTEX.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETVIEWPORTEXTEX.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETVIEWPORTEXTEX.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETVIEWPORTORGEX-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETVIEWPORTORGEX.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETVIEWPORTORGEX.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETVIEWPORTORGEX.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETWINDOWEXTEX-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETWINDOWEXTEX.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETWINDOWEXTEX.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETWINDOWEXTEX.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETWINDOWORGEX-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETWINDOWORGEX.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETWINDOWORGEX.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETWINDOWORGEX.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETWORLDTRANSFORM-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETWORLDTRANSFORM.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETWORLDTRANSFORM.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSETWORLDTRANSFORM.png
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSTROKEANDFILLPATH-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSTROKEANDFILLPATH.gif
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSTROKEANDFILLPATH.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSTROKEANDFILLPATH.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSTROKEPATH-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSTROKEPATH.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSTROKEPATH.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EMRSTROKEPATH.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1ENHMETAHEADER-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1ENHMETAHEADER.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1ENHMETAHEADER.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1ENHMETAHEADER.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EXTPEN-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EXTPEN.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EXTPEN.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1EXTPEN.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1FONT-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1FONT.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1FONT.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1FONT.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1GLOBALOBJECTS-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1GLOBALOBJECTS.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1GRAPHICSOBJECT-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1GRAPHICSOBJECT.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1GRAPHICSOBJECT.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1GRAPHICSOBJECT.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1METAFILEDEVICECONTEXT-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1METAFILEDEVICECONTEXT.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1METAFILEDEVICECONTEXT.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1METAFILEDEVICECONTEXT.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1METARECORD-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1METARECORD.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1METARECORD.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1METARECORD.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1OBJECT-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1OBJECT.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1OBJECT.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1OBJECT.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1PALETTE-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1PALETTE.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1PALETTE.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1PALETTE.png
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1PEN-members.html
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1PEN.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1PEN.html
+%%PORTDOCS%%%%DOCSDIR%%/classEMF_1_1PEN.png
%%PORTDOCS%%%%DOCSDIR%%/classEMRARC.gif
%%PORTDOCS%%%%DOCSDIR%%/classEMRARC.html
%%PORTDOCS%%%%DOCSDIR%%/classEMRARCTO.gif
@@ -309,20 +376,25 @@ lib/libEMF.so.1
%%PORTDOCS%%%%DOCSDIR%%/classLOGPALETTE.html
%%PORTDOCS%%%%DOCSDIR%%/classLOGPEN.gif
%%PORTDOCS%%%%DOCSDIR%%/classLOGPEN.html
+%%PORTDOCS%%%%DOCSDIR%%/classes.html
%%PORTDOCS%%%%DOCSDIR%%/documentation_8dox.html
%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/doxygen.gif
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
%%PORTDOCS%%%%DOCSDIR%%/emf_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/emf_8h.html
%%PORTDOCS%%%%DOCSDIR%%/example.png
%%PORTDOCS%%%%DOCSDIR%%/files.html
%%PORTDOCS%%%%DOCSDIR%%/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_func.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_vars.html
%%PORTDOCS%%%%DOCSDIR%%/globals.html
%%PORTDOCS%%%%DOCSDIR%%/hierarchy.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/libemf_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/libemf_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/libemf_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/libemf_8h_source.html
%%PORTDOCS%%%%DOCSDIR%%/namespace__EMF.html
%%PORTDOCS%%%%DOCSDIR%%/namespacemembers.html
%%PORTDOCS%%%%DOCSDIR%%/namespaces.html
@@ -342,4 +414,8 @@ lib/libEMF.so.1
%%PORTDOCS%%%%DOCSDIR%%/structEMF_1_1POINTLARRAY.html
%%PORTDOCS%%%%DOCSDIR%%/structEMF_1_1WCHARSTR-members.html
%%PORTDOCS%%%%DOCSDIR%%/structEMF_1_1WCHARSTR.html
+%%PORTDOCS%%%%DOCSDIR%%/tab_b.gif
+%%PORTDOCS%%%%DOCSDIR%%/tab_l.gif
+%%PORTDOCS%%%%DOCSDIR%%/tab_r.gif
+%%PORTDOCS%%%%DOCSDIR%%/tabs.css
%%PORTDOCS%%@dirrm %%DOCSDIR%%