aboutsummaryrefslogtreecommitdiff
path: root/graphics/libetonyek/Makefile
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2014-02-24 22:53:19 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2014-02-24 22:53:19 +0000
commit63a13804f82f5c6c8e63f84d2c7bda75d3de7d79 (patch)
tree0089232a9e5583994115c985a2e7b6c4a03c0164 /graphics/libetonyek/Makefile
parentfadcef222284c6904e7ccc6814c68fb36955ef92 (diff)
downloadports-63a13804f82f5c6c8e63f84d2c7bda75d3de7d79.tar.gz
ports-63a13804f82f5c6c8e63f84d2c7bda75d3de7d79.zip
Libetonyek is library providing ability to interpret and import
Apple Keynote presentations into various applications. WWW: http://www.freedesktop.org/wiki/Software/libetonyek
Notes
Notes: svn path=/head/; revision=345904
Diffstat (limited to 'graphics/libetonyek/Makefile')
-rw-r--r--graphics/libetonyek/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/graphics/libetonyek/Makefile b/graphics/libetonyek/Makefile
new file mode 100644
index 000000000000..e3a70ad21a35
--- /dev/null
+++ b/graphics/libetonyek/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= libetonyek
+PORTVERSION= 0.0.3
+CATEGORIES= graphics
+MASTER_SITES= http://dev-www.libreoffice.org/src/
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Library to interpret and import Apple Keynote presentations
+
+LICENSE= LGPL21 MPL
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= gperf:${PORTSDIR}/devel/gperf
+LIB_DEPENDS= libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
+ libwpd-0.9.so:${PORTSDIR}/textproc/libwpd \
+ libxml2.so:${PORTSDIR}/textproc/libxml2
+
+OPTIONS_DEFINE= DOCS TEST
+
+CONFIGURE_ARGS= --disable-werror
+CPPFLAGS+= -I${LOCALBASE}/include
+
+USE_AUTOTOOLS= libtool
+USE_LDCONFIG= yes
+USE_XZ= yes
+USES= gmake pkgconfig pathfix
+
+PORTDOCS= *
+DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
+DOCS_CONFIGURE_OFF= --without-docs
+TEST_BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/cppunit.pc:${PORTSDIR}/devel/cppunit
+TEST_CONFIGURE_OFF= --disable-tests
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTEST}
+post-build:
+ @cd ${WRKSRC}/src/test && ${GMAKE} check
+.endif
+
+.include <bsd.port.mk>