aboutsummaryrefslogtreecommitdiff
path: root/graphics/libfpx
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2002-01-12 08:52:37 +0000
committerMikhail Teterin <mi@FreeBSD.org>2002-01-12 08:52:37 +0000
commit8c1545f23596a8a9db30ef309520231470af85c6 (patch)
treeea635fb506245db4d329a71a556d94e739234904 /graphics/libfpx
parentfbb994450079849a7b00d43e12296797f32b521c (diff)
downloadports-8c1545f23596a8a9db30ef309520231470af85c6.tar.gz
ports-8c1545f23596a8a9db30ef309520231470af85c6.zip
Upgrade to 1.2.0-3. Minor improvements. One of our patches got
incorporated. Hey! Submitted by: alfred (very laconicly)
Notes
Notes: svn path=/head/; revision=52968
Diffstat (limited to 'graphics/libfpx')
-rw-r--r--graphics/libfpx/Makefile4
-rw-r--r--graphics/libfpx/distinfo2
-rw-r--r--graphics/libfpx/files/patch-basics::a_file.h70
3 files changed, 3 insertions, 73 deletions
diff --git a/graphics/libfpx/Makefile b/graphics/libfpx/Makefile
index 4ea1e2cc44c5..2e03dcbcbee9 100644
--- a/graphics/libfpx/Makefile
+++ b/graphics/libfpx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fpx
-PORTVERSION= 1.2.0
+PORTVERSION= 1.2.0-3
CATEGORIES= graphics
MASTER_SITES= http://imagemagick.sourceforge.net/http/delegates/ \
ftp://ftp.yggdrasil.com/mirrors/site/ftp.simplesystems.org/pub/%SUBDIR%/ \
@@ -31,7 +31,7 @@ MAINTAINER= mi@aldan.algebra.com
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
-WRKSRC= ${WRKDIR}/lib${DISTNAME}
+WRKSRC= ${WRKDIR}/lib${DISTNAME:C/-[^-]*$//}
post-patch:
# Replacing references to <malloc.h> with <stdlib.h>
diff --git a/graphics/libfpx/distinfo b/graphics/libfpx/distinfo
index d436efca84c2..41a706ace5da 100644
--- a/graphics/libfpx/distinfo
+++ b/graphics/libfpx/distinfo
@@ -1 +1 @@
-MD5 (fpx-1.2.0.tar.gz) = 9e431764692083f4b11e999b257bf42a
+MD5 (fpx-1.2.0-3.tar.gz) = 37dea1af585c8747c06c9845041afd51
diff --git a/graphics/libfpx/files/patch-basics::a_file.h b/graphics/libfpx/files/patch-basics::a_file.h
deleted file mode 100644
index a67744ae5061..000000000000
--- a/graphics/libfpx/files/patch-basics::a_file.h
+++ /dev/null
@@ -1,70 +0,0 @@
---- basics/a_file.h Sat Dec 23 17:10:00 2000
-+++ basics/a_file.h Thu Jan 18 11:41:58 2001
-@@ -46,12 +46,10 @@
- // Global Functions
- // ________________
-
--#ifdef _WINDOWS
- uint16 shortswap(uint16); // Swap for Big/Little Endian
- uint32 longswap(uint32); // Swap for Big/Little Endian
- # define int32swap longswap
- # define int16swap shortswap
--#endif
-
- // Classes Declarations
- // --------------------
-@@ -310,7 +308,6 @@
-
- #ifdef DEFINE_INT32_FUNCTIONS
-
--#ifdef _WINDOWS
- inline uint32 longswap( uint32 x )
- {
- uint32 a, b;
-@@ -318,7 +315,6 @@
- b = x & 0x0000ffff;
- return ( ((uint32)shortswap((uint16)b) << 16) | (uint32)shortswap((uint16)a) );
- }
--#endif
-
- inline Boolean Fichier::Ecriture(int32 ceLong)
- {
-@@ -376,7 +372,6 @@
-
-
- // Added by GDN
--#ifdef _WINDOWS
- inline uint16 shortswap( uint16 x )
- {
- uint16 a, b;
-@@ -384,7 +379,6 @@
- b = x & 0x00ff;
- return ( (b << 8) | a );
- }
--#endif
-
- inline Boolean Fichier::Ecriture(short ceShort)
- {
-@@ -487,9 +481,9 @@
- inline Boolean Fichier::EcritureTableau(short *array, int32 nshort)
- {
- Boolean ret;
--
-+ int32 i;
- #ifndef __bigEndian
-- for (int32 i = 0; i < nshort; i++)
-+ for (i = 0; i < nshort; i++)
- array[i] = shortswap (array[i]);
- #endif
-
-@@ -509,8 +503,9 @@
- inline Boolean Fichier::EcritureTableau( int32 *array, int32 t)
- {
- Boolean ret;
-+ int32 i;
- #ifndef __bigEndian
-- for (int32 i = 0; i < t; i++)
-+ for (i = 0; i < t; i++)
- array[i] = int32swap (array[i]);
- #endif
-