aboutsummaryrefslogtreecommitdiff
path: root/graphics/libimg/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-02-12 21:46:33 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-02-12 21:46:33 +0000
commit964fc8842bad81cfc5e312ff1a1033a076192b4f (patch)
treeb3bde429d7e8aae6c082a9b380fdcd3e8d58b977 /graphics/libimg/Makefile
parent236b4ce6395b8b15cc66bf78ce9d974020544377 (diff)
downloadports-964fc8842bad81cfc5e312ff1a1033a076192b4f.tar.gz
ports-964fc8842bad81cfc5e312ff1a1033a076192b4f.zip
Bring up to the latest 1.2.4. Install documentation (modulo NOPORTDOCS).
Some day the rest of the world will wise up and realize, that it is often easier and neater to create a Makefile from scratch, than to try to patch the configure/Makefile.in/Makefile.am/etc nonsense to do the right thing.
Notes
Notes: svn path=/head/; revision=38280
Diffstat (limited to 'graphics/libimg/Makefile')
-rw-r--r--graphics/libimg/Makefile31
1 files changed, 21 insertions, 10 deletions
diff --git a/graphics/libimg/Makefile b/graphics/libimg/Makefile
index 6453397dfd67..eb99e2767cb1 100644
--- a/graphics/libimg/Makefile
+++ b/graphics/libimg/Makefile
@@ -6,29 +6,40 @@
#
PORTNAME= libimg
-PORTVERSION= 1.2.2
-CATEGORIES= graphics tk82
+PORTVERSION= 1.2.4
+CATEGORIES= graphics tk83
MASTER_SITES= ftp://ftp.neosoft.com/pub/tcl/sorted/packages-8.0/graphics/Img/1.2/
DISTNAME= img${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82 \
+LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83 \
png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
-WRKSRC= ${WRKDIR}/img1.2.2
+WRKSRC= ${WRKDIR}/img${PORTVERSION}
-ALL_TARGET= default
+# We don't need the bundled libraries at all, except for a few headers
+# from libtiff, see comment in files/Makefile.bsd:
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude '*/libz/*' \
+ --exclude '*/compat/*' --exclude '*/libtiff/*.c' \
+ --exclude '*/libjpeg/*' --exclude '*/libpng/*'
+
+MAKEFILE= ${FILESDIR}/Makefile.bsd
+
+MAKE_ARGS= PORTVERSION="${PORTVERSION}" LOCALBASE="${LOCALBASE}" \
+ MKDIR="${MKDIR}" INSTALL_DATA="${INSTALL_DATA}"
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl=${PREFIX}/lib/tcl8.2 --with-tk=${PREFIX}/lib/tk8.2 \
- --disable-stubs
+.if !defined(NOPORTDOCS)
post-install:
- ${LN} -sf ${PREFIX}/lib/Img1.2/libimg82.so.1 ${PREFIX}/lib/libimg.so.1
- ${LN} -sf ${PREFIX}/lib/libimg.so.1 ${PREFIX}/lib/libimg.so
+ ${MKDIR} ${LOCALBASE}/share/doc/Img1.2
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${LOCALBASE}/share/doc/Img1.2
+.endif
.include <bsd.port.mk>
+
+PLIST_SUBP!= ${ENV} TCL_VER=${TCL_VER} ${MAKE} -f ${MAKEFILE} environ
+PLIST_SUB+= ${PLIST_SUBP}