aboutsummaryrefslogtreecommitdiff
path: root/graphics/libosmesa
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-04-09 08:40:35 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-04-09 08:40:35 +0000
commit40762860fcfcf98eb6029975ac8a47ea40d97aba (patch)
treeea3f85ef95ab08570db9f0a373db4d203b188693 /graphics/libosmesa
parent1dee0ff70d80c6b06f932d230909e9306a9dea21 (diff)
downloadports-40762860fcfcf98eb6029975ac8a47ea40d97aba.tar.gz
ports-40762860fcfcf98eb6029975ac8a47ea40d97aba.zip
- New port: graphics/libosmesa
Import version 7.8.1 of the Mesa3D library, built for off-screen rendering.
Notes
Notes: svn path=/head/; revision=252466
Diffstat (limited to 'graphics/libosmesa')
-rw-r--r--graphics/libosmesa/Makefile51
-rw-r--r--graphics/libosmesa/distinfo3
-rw-r--r--graphics/libosmesa/pkg-descr12
-rw-r--r--graphics/libosmesa/pkg-plist8
4 files changed, 74 insertions, 0 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
new file mode 100644
index 000000000000..83ecee593f67
--- /dev/null
+++ b/graphics/libosmesa/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: libosmesa
+# Date created: 9 April 2010
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= libosmesa
+PORTVERSION= 7.8.1
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/${PORTVERSION}/
+DISTNAME= MesaLib-${PORTVERSION}
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Off-Screen Mesa implementation of the OpenGL API
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+CONFLICTS= mesagl-mangled-*
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+USE_XORG= xxf86vm xext xfixes xdamage xt
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-driver=osmesa --with-osmesa-bits=32 \
+ --includedir=${PREFIX}/include/Mesa
+CFLAGS+= -I${LOCALBASE}/include
+
+WRKSRC= ${WRKDIR}/Mesa-${PORTVERSION}
+
+GLINC= gl.h glext.h osmesa.h
+GLLIB= OSMesa32
+SHLIB_VERS= ${PORTVERSION:R:R}
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/Mesa/GL
+ ${MKDIR} ${PREFIX}/lib
+ ${MKDIR} ${PREFIX}/libdata/pkgconfig
+# header files
+.for i in ${GLINC}
+ ${INSTALL_DATA} ${WRKSRC}/include/GL/${i} ${PREFIX}/include/Mesa/GL/
+.endfor
+# shlib
+ ${INSTALL_DATA} ${WRKSRC}/lib/libOSMesa32.so.${SHLIB_VERS} ${PREFIX}/lib
+ ${LN} -sf libOSMesa32.so.${SHLIB_VERS} ${PREFIX}/lib/libOSMesa32.so
+# pkg-config
+ cd ${WRKSRC}/src/mesa && ${GMAKE} osmesa.pc
+ ${INSTALL_DATA} ${WRKSRC}/src/mesa/osmesa.pc ${PREFIX}/libdata/pkgconfig
+
+.include <bsd.port.mk>
diff --git a/graphics/libosmesa/distinfo b/graphics/libosmesa/distinfo
new file mode 100644
index 000000000000..0c040c047dcb
--- /dev/null
+++ b/graphics/libosmesa/distinfo
@@ -0,0 +1,3 @@
+MD5 (MesaLib-7.8.1.tar.bz2) = 25ec15f8e41fde6d206118cc786dbac4
+SHA256 (MesaLib-7.8.1.tar.bz2) = b0b46e5abfd75db44501e308125fa92bcf1c91d91e97a043a3b1764cfa0907fa
+SIZE (MesaLib-7.8.1.tar.bz2) = 5137426
diff --git a/graphics/libosmesa/pkg-descr b/graphics/libosmesa/pkg-descr
new file mode 100644
index 000000000000..5989033f18d2
--- /dev/null
+++ b/graphics/libosmesa/pkg-descr
@@ -0,0 +1,12 @@
+Mesa is a 3-D graphics library with an API which is very similar to that
+of OpenGL*. To the extent that Mesa utilizes the OpenGL command syntax or
+state machine, it is being used with authorization from Silicon Graphics,
+Inc. However, the author makes no claim that Mesa is in any way a
+compatible replacement for OpenGL or associated with Silicon Graphics, Inc.
+
+This is a Off-Screen version of Mesa in order to do off-screen rendering in
+other packages like VTK. Offscreen rendering is useful for a
+number of things, such as batch processing, parallel processing, and
+remote processing.
+
+WWW: http://www.mesa3d.org/
diff --git a/graphics/libosmesa/pkg-plist b/graphics/libosmesa/pkg-plist
new file mode 100644
index 000000000000..e8bc98835a8b
--- /dev/null
+++ b/graphics/libosmesa/pkg-plist
@@ -0,0 +1,8 @@
+include/Mesa/GL/gl.h
+include/Mesa/GL/glext.h
+include/Mesa/GL/osmesa.h
+lib/libOSMesa32.so.7
+lib/libOSMesa32.so
+libdata/pkgconfig/osmesa.pc
+@dirrm include/Mesa/GL
+@dirrm include/Mesa