aboutsummaryrefslogtreecommitdiff
path: root/graphics/libosmesa
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-01-31 14:25:33 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-01-31 14:25:33 +0000
commitef0db57081cfb02e07886d5f30560fc8e7518e56 (patch)
treef6151a3e1fe83da9dc4780461f2044776358e165 /graphics/libosmesa
parent97de1995afdf92903731b6db5fde7e4f4f794f00 (diff)
downloadports-ef0db57081cfb02e07886d5f30560fc8e7518e56.tar.gz
ports-ef0db57081cfb02e07886d5f30560fc8e7518e56.zip
- Update to 7.9.1
Release notes: http://mesa3d.org/relnotes-7.9.1.html Feature safe: yes
Notes
Notes: svn path=/head/; revision=268487
Diffstat (limited to 'graphics/libosmesa')
-rw-r--r--graphics/libosmesa/Makefile8
-rw-r--r--graphics/libosmesa/distinfo5
-rw-r--r--graphics/libosmesa/files/patch-configure11
-rw-r--r--graphics/libosmesa/files/patch-src-glsl_Makefile15
-rw-r--r--graphics/libosmesa/files/patch-src-mesa-drivers-osmesa_osmesa.c10
-rw-r--r--graphics/libosmesa/files/patch-src-mesa-main_macros.h10
6 files changed, 43 insertions, 16 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index c1b7c3f03540..dd9f0353aaea 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libosmesa
-PORTVERSION= 7.8.2
-PORTREVISION= 1
+PORTVERSION= 7.9.1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/${PORTVERSION}/
DISTNAME= MesaLib-${PORTVERSION}
@@ -15,7 +14,10 @@ DISTNAME= MesaLib-${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Off-Screen Mesa implementation of the OpenGL API
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
+ talloc.2:${PORTSDIR}/devel/talloc
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:${PORTSDIR}/textproc/py-libxml2
+RUN_DEPENDS= ${BUILD_DEPENDS}
CONFLICTS= mesagl-mangled-*
diff --git a/graphics/libosmesa/distinfo b/graphics/libosmesa/distinfo
index 861b9a7746d7..1812dcb0a148 100644
--- a/graphics/libosmesa/distinfo
+++ b/graphics/libosmesa/distinfo
@@ -1,3 +1,2 @@
-MD5 (MesaLib-7.8.2.tar.bz2) = 6be2d343a0089bfd395ce02aaf8adb57
-SHA256 (MesaLib-7.8.2.tar.bz2) = 505bf418dceba05837f4ea1b1972b9620c35f8cb94bc4d1e6d573c15f562576d
-SIZE (MesaLib-7.8.2.tar.bz2) = 5138463
+SHA256 (MesaLib-7.9.1.tar.bz2) = 403986cd83d957db17957f11c320c9562cc8675273efbaa402e88bf4e6586721
+SIZE (MesaLib-7.9.1.tar.bz2) = 5640520
diff --git a/graphics/libosmesa/files/patch-configure b/graphics/libosmesa/files/patch-configure
new file mode 100644
index 000000000000..1b55fde6dafd
--- /dev/null
+++ b/graphics/libosmesa/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2011-01-20 07:30:27.000000000 +0000
++++ configure 2011-01-20 07:32:39.000000000 +0000
+@@ -5127,7 +5127,7 @@
+ ;;
+ esac
+ ;;
+- x86_64)
++ amd64)
+ case "$host_os" in
+ linux* | *freebsd* | dragonfly*)
+ test "x$enable_32bit" = xyes && asm_arch=x86 || asm_arch=x86_64
diff --git a/graphics/libosmesa/files/patch-src-glsl_Makefile b/graphics/libosmesa/files/patch-src-glsl_Makefile
new file mode 100644
index 000000000000..4a2689b4fce8
--- /dev/null
+++ b/graphics/libosmesa/files/patch-src-glsl_Makefile
@@ -0,0 +1,15 @@
+--- src/glsl/Makefile.orig 2011-01-31 12:12:57.000000000 +0100
++++ src/glsl/Makefile 2011-01-31 12:13:06.000000000 +0100
+@@ -114,11 +114,11 @@
+ $(CXX_SOURCES:.cpp=.o)
+
+ INCLUDES = \
+- $(TALLOC_CFLAGS) \
+ -I. \
+ -I../mesa \
+ -I../mapi \
+ -I../../include \
++ $(TALLOC_CFLAGS) \
+ $(LIBRARY_INCLUDES)
+
+ ALL_SOURCES = \
diff --git a/graphics/libosmesa/files/patch-src-mesa-drivers-osmesa_osmesa.c b/graphics/libosmesa/files/patch-src-mesa-drivers-osmesa_osmesa.c
deleted file mode 100644
index 65015740fd70..000000000000
--- a/graphics/libosmesa/files/patch-src-mesa-drivers-osmesa_osmesa.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/mesa/drivers/osmesa/osmesa.c.orig 2010-07-22 15:04:03.000000000 +0200
-+++ src/mesa/drivers/osmesa/osmesa.c 2010-07-22 15:04:02.000000000 +0200
-@@ -1329,6 +1329,7 @@
- * size.
- */
- osmesa->rb = new_osmesa_renderbuffer(&osmesa->mesa, osmesa->format, type);
-+ _mesa_remove_renderbuffer(osmesa->gl_buffer, BUFFER_FRONT_LEFT);
- _mesa_add_renderbuffer(osmesa->gl_buffer, BUFFER_FRONT_LEFT, osmesa->rb);
- assert(osmesa->rb->RefCount == 2);
-
diff --git a/graphics/libosmesa/files/patch-src-mesa-main_macros.h b/graphics/libosmesa/files/patch-src-mesa-main_macros.h
new file mode 100644
index 000000000000..4b51ae98ce55
--- /dev/null
+++ b/graphics/libosmesa/files/patch-src-mesa-main_macros.h
@@ -0,0 +1,10 @@
+--- src/mesa/main/macros.h.orig 2010-10-19 08:03:53.000000000 +0000
++++ src/mesa/main/macros.h 2010-10-19 08:05:32.000000000 +0000
+@@ -33,6 +33,7 @@
+
+ #include "imports.h"
+
++#define log2(x) (log(x) / log(2))
+
+ /**
+ * \name Integer / float conversion for colors, normals, etc.