aboutsummaryrefslogtreecommitdiff
path: root/graphics/libqglviewer
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-14 01:58:13 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-14 01:58:13 +0000
commit8483d37679390b0734496e82df9e7c419f4c402c (patch)
tree58634eb11942168520503e28fb7540655a5ce35a /graphics/libqglviewer
parent8938c02c1a1a2c62986ba2a5e37bdc32b7a71281 (diff)
downloadports-8483d37679390b0734496e82df9e7c419f4c402c.tar.gz
ports-8483d37679390b0734496e82df9e7c419f4c402c.zip
add missing dependent
mark broken on 4.x Noticed by: bento via kris
Notes
Notes: svn path=/head/; revision=111423
Diffstat (limited to 'graphics/libqglviewer')
-rw-r--r--graphics/libqglviewer/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/graphics/libqglviewer/Makefile b/graphics/libqglviewer/Makefile
index be9e2e939b9d..a087c9fc4a7e 100644
--- a/graphics/libqglviewer/Makefile
+++ b/graphics/libqglviewer/Makefile
@@ -15,6 +15,8 @@ DISTNAME= libQGLViewer-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ library helps development of 3D applications
+BUILD_DEPENDS= ${QMAKE}:${PORTSDIR}/devel/qmake
+
USE_BZIP2= yes
USE_QT_VER= 3
MAKE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
@@ -25,6 +27,12 @@ INSTALLS_SHLIB= yes
DOCSDIR= ${PREFIX}/share/doc/QGLViewer
PORTDOCS= *
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on 4.x"
+.endif
+
do-build:
@(cd ${WRKSRC}/QGLViewer && ${SETENV} ${MAKE_ENV} ${QMAKE} && \
${SETENV} ${MAKE_ENV} ${MAKE})
@@ -38,4 +46,4 @@ post-install:
@${FIND} ${PREFIX}/include/QGLViewer -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>