aboutsummaryrefslogtreecommitdiff
path: root/graphics/libvisual04-plugins
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-19 08:46:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-19 08:46:37 +0000
commitc6c4b6204f66fba9b68199460cfaf4b5ab6b9976 (patch)
tree855fbc9a2cfe046e57a4574628e20037f73cd0f1 /graphics/libvisual04-plugins
parentcfdf0f8339fa3b071a7d75464355da13871eeb4b (diff)
downloadports-c6c4b6204f66fba9b68199460cfaf4b5ab6b9976.tar.gz
ports-c6c4b6204f66fba9b68199460cfaf4b5ab6b9976.zip
Libvisual is an abstraction library that comes between applications and audio
visualisation plugins. Often when it comes to audio visualisation plugins or programs that create visuals, they depend on a player or something else; basically, there is no general framework that enabled application developers to easily access cool audio visualisation plugins. Libvisual wants to change this by providing an interface towards plugins and applications; through this easy to use interface applications can easily access plugins and, since the drawing is done by the application, it also enables the developer to draw the visual anywhere he wants. The framework also allows you to morph to different plugins and mix two at once; all kinds of neat tricks are possible using this method. WWW: http://localhost.nl/~synap/libvisual/ PR: ports/120380 Submitted by: Björn König <bkoenig at alpha-tierchen.de>
Notes
Notes: svn path=/head/; revision=207575
Diffstat (limited to 'graphics/libvisual04-plugins')
-rw-r--r--graphics/libvisual04-plugins/Makefile60
-rw-r--r--graphics/libvisual04-plugins/distinfo3
-rw-r--r--graphics/libvisual04-plugins/pkg-descr16
-rw-r--r--graphics/libvisual04-plugins/pkg-plist38
4 files changed, 117 insertions, 0 deletions
diff --git a/graphics/libvisual04-plugins/Makefile b/graphics/libvisual04-plugins/Makefile
new file mode 100644
index 000000000000..8fd21bd6cec4
--- /dev/null
+++ b/graphics/libvisual04-plugins/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: libvisual04-plugins
+# Date created: 8 February 2007
+# Whom: Björn König <bkoenig@alpha-tierchen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libvisual
+PORTVERSION= 0.4.0
+CATEGORIES= graphics
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= libvisual
+PKGNAMESUFFIX= 04-plugins
+DISTNAME= ${PORTNAME}-${PKGNAMESUFFIX:C/.*-//}-${PORTVERSION}
+
+MAINTAINER= bkoenig@alpha-tierchen.de
+COMMENT= Set of plugins for the libvisual framework
+
+LIB_DEPENDS= visual-${MAJORMINOR}:${PORTSDIR}/graphics/libvisual04
+
+USE_GNOME= pkgconfig
+USE_GL= yes
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-alsa \
+ --disable-mplayer \
+ --disable-gstreamer-plugin \
+ --disable-gdkpixbuf-plugin \
+ --disable-gforce \
+ --disable-jess \
+ --prefix=${PREFIX}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+MAJORMINOR= ${PORTVERSION:C/.[0-9]+$//}
+
+DATADIR= ${PREFIX}/share/${PORTNAME}-${PKGNAMESUFFIX:C/.*-//}-${MAJORMINOR}
+PLIST_SUB= PLUGINS_BASE_DIR=${LOCALBASE}/lib/${PORTNAME}-${MAJORMINOR} \
+ DATADIR_REL=${DATADIR_REL}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+BROKEN= Does not compile on 5.x
+.endif
+
+pre-configure:
+# /usr/bin/objformat is obsolete, hardcode the object format
+ @${REINPLACE_CMD} -e 's,objformat=.*,objformat=elf,' \
+ ${WRKSRC}/configure
+# link some plugins with libGLU because they need it
+ @${REINPLACE_CMD} -e 's,^\(LDFLAGS = \),\1-lGLU ,' \
+ ${WRKSRC}/plugins/actor/lv_gltest/Makefile.in \
+ ${WRKSRC}/plugins/actor/nastyfft/Makefile.in \
+ ${WRKSRC}/plugins/actor/pseudotoad_flower/Makefile.in
+# don't install message catalogs
+ @${REINPLACE_CMD} -e 's,^\(SUBDIRS = plugins\) po,\1,' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/graphics/libvisual04-plugins/distinfo b/graphics/libvisual04-plugins/distinfo
new file mode 100644
index 000000000000..22ec08b163a3
--- /dev/null
+++ b/graphics/libvisual04-plugins/distinfo
@@ -0,0 +1,3 @@
+MD5 (libvisual-plugins-0.4.0.tar.gz) = 4330e9287f9d6fae02f482f428a1e77b
+SHA256 (libvisual-plugins-0.4.0.tar.gz) = 8b783a111d54b92502085199c351979d0452b950fcddddd1eae28a16d8508e9b
+SIZE (libvisual-plugins-0.4.0.tar.gz) = 828631
diff --git a/graphics/libvisual04-plugins/pkg-descr b/graphics/libvisual04-plugins/pkg-descr
new file mode 100644
index 000000000000..40c44f268a8e
--- /dev/null
+++ b/graphics/libvisual04-plugins/pkg-descr
@@ -0,0 +1,16 @@
+Libvisual is an abstraction library that comes between applications and audio
+visualisation plugins.
+
+Often when it comes to audio visualisation plugins or programs that create
+visuals, they depend on a player or something else; basically, there is no
+general framework that enabled application developers to easily access cool
+audio visualisation plugins. Libvisual wants to change this by providing an
+interface towards plugins and applications; through this easy to use interface
+applications can easily access plugins and, since the drawing is done by the
+application, it also enables the developer to draw the visual anywhere he
+wants.
+
+The framework also allows you to morph to different plugins and mix two at
+once; all kinds of neat tricks are possible using this method.
+
+WWW: http://localhost.nl/~synap/libvisual/
diff --git a/graphics/libvisual04-plugins/pkg-plist b/graphics/libvisual04-plugins/pkg-plist
new file mode 100644
index 000000000000..69b43c5eba35
--- /dev/null
+++ b/graphics/libvisual04-plugins/pkg-plist
@@ -0,0 +1,38 @@
+%%DATADIR_REL%%/actor/actor_madspin/star1.bmp
+%%DATADIR_REL%%/actor/actor_madspin/star2.bmp
+@dirrm %%DATADIR_REL%%/actor/actor_madspin
+@dirrm %%DATADIR_REL%%/actor
+@dirrm %%DATADIR_REL%%
+@cwd %%PLUGINS_BASE_DIR%%
+actor/actor_lv_gltest.so
+actor/actor_lv_gltest.la
+actor/actor_nastyfft.so
+actor/actor_nastyfft.la
+actor/actor_madspin.so
+actor/actor_madspin.la
+actor/actor_flower.so
+actor/actor_flower.la
+actor/actor_infinite.so
+actor/actor_infinite.la
+actor/actor_corona.so
+actor/actor_corona.la
+actor/actor_lv_scope.so
+actor/actor_lv_scope.la
+actor/actor_oinksie.so
+actor/actor_oinksie.la
+actor/actor_jakdaw.so
+actor/actor_jakdaw.la
+actor/actor_bumpscope.so
+actor/actor_bumpscope.la
+morph/morph_alphablend.so
+morph/morph_alphablend.la
+morph/morph_flash.so
+morph/morph_flash.la
+morph/morph_tentacle.so
+morph/morph_tentacle.la
+morph/morph_slide.so
+morph/morph_slide.la
+@dirrm actor
+@dirrm morph
+@cwd /
+@dirrm %%PLUGINS_BASE_DIR%%