aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-c6-tiff/Makefile
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
commit05317facbedf1ed4566b56f4e09e6e4a49fc3f38 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /graphics/linux-c6-tiff/Makefile
parentf287925fdbb7ff7ab55ee8aaa28cf756fe49a296 (diff)
downloadports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.tar.gz
ports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.zip
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Notes
Notes: svn path=/head/; revision=368845
Diffstat (limited to 'graphics/linux-c6-tiff/Makefile')
-rw-r--r--graphics/linux-c6-tiff/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/graphics/linux-c6-tiff/Makefile b/graphics/linux-c6-tiff/Makefile
new file mode 100644
index 000000000000..7587b73076b5
--- /dev/null
+++ b/graphics/linux-c6-tiff/Makefile
@@ -0,0 +1,25 @@
+# Created by: Artyom Mirgorodskiy <artyom.mirgorodsky@gmail.com>
+# $FreeBSD$
+
+PORTNAME= tiff
+PORTVERSION= 3.9.4
+CATEGORIES= graphics linux
+DISTNAME= lib${PORTNAME}-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= TIFF library (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-tiff-[0-9]* linux-f10-tiff-[0-9]*
+
+ONLY_FOR_ARCHS= amd64 i386
+USE_LINUX= c6
+USE_LINUX_APPS= jpeg
+USE_LINUX_RPM= yes
+RPMVERSION= 9.el6_3
+LINUX_NAME= lib${PORTNAME}
+BRANDELF_DIRS= usr/bin
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>