aboutsummaryrefslogtreecommitdiff
path: root/graphics/luminance
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-10 18:12:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-10 18:12:48 +0000
commite97720e0b3f54373ba35947cb728ca266e35c5c7 (patch)
treeaaac8fdce495d8ed09a65cccb338a7e845eb8d0a /graphics/luminance
parentb168507c6cb24016b2df56e28275b6c2dc24e4a6 (diff)
downloadports-e97720e0b3f54373ba35947cb728ca266e35c5c7.tar.gz
ports-e97720e0b3f54373ba35947cb728ca266e35c5c7.zip
- Update to 1.9.3
PR: 134287 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=233613
Diffstat (limited to 'graphics/luminance')
-rw-r--r--graphics/luminance/Makefile38
-rw-r--r--graphics/luminance/distinfo6
-rw-r--r--graphics/luminance/files/patch-project.pro28
-rw-r--r--graphics/luminance/files/patch-src__TM_operators__mantiuk06__contrast_domain.cpp13
-rw-r--r--graphics/luminance/pkg-plist45
5 files changed, 50 insertions, 80 deletions
diff --git a/graphics/luminance/Makefile b/graphics/luminance/Makefile
index 52b0d8493863..e9a9eef50acd 100644
--- a/graphics/luminance/Makefile
+++ b/graphics/luminance/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qtpfsgui
-PORTVERSION= 1.9.2
-PORTREVISION= 2
+PORTVERSION= 1.9.3
CATEGORIES= graphics
MASTER_SITES= SF
@@ -15,16 +14,16 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A graphical user interface that provides a workflow for HDR imaging
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
-LIB_DEPENDS= exiv2:${PORTSDIR}/graphics/exiv2 \
- jpeg:${PORTSDIR}/graphics/jpeg \
- IlmImf:${PORTSDIR}/graphics/OpenEXR \
- tiff:${PORTSDIR}/graphics/tiff \
- fftw3f:${PORTSDIR}/math/fftw3-float
+LIB_DEPENDS= exiv2.7:${PORTSDIR}/graphics/exiv2 \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ fftw3f.4:${PORTSDIR}/math/fftw3-float
USE_QT_VER= 4
QT_COMPONENTS= corelib gui imageformats \
linguist_build moc_build qmake_build rcc_build uic_build
-ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
+MAKE_JOBS_SAFE= yes
INSTALL_TARGET= install_target install_menu install_icon install_i18n
INSTALLS_ICONS= yes
@@ -40,24 +39,33 @@ post-patch:
.for file in src/MainWindow/mainWindow.cpp \
src/Preferences/preferencesDialog.cpp \
src/TransplantExif/transplant.cpp
- @${REINPLACE_CMD} -e 's|/usr/local/share/qtpfsgui/|${DOCSDIR}/|g' \
- ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -e 's|/usr/share/qtpfsgui|${DOCSDIR}|g ; \
+ s|/usr/local/share/qtpfsgui|${DATADIR}|g' ${WRKSRC}/${file}
.endfor
do-configure:
@${LRELEASE} ${WRKSRC}/project.pro
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${QMAKESPEC}
-post-install:
- @${STRIP_CMD} ${PREFIX}/bin/qtpfsgui
- ${INSTALL} -d ${PREFIX}/share/icons/hicolor/48x48/apps
- @${LN} -sf ${PREFIX}/share/pixmaps/qtpfsgui.png \
- ${PREFIX}/share/icons/hicolor/48x48/apps/qtpfsgui.png
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/qtpfsgui ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/qtpfsgui.desktop ${PREFIX}/share/applications
+ @${MKDIR} ${PREFIX}/share/icons/hicolor/32x32/apps
+ ${INSTALL_DATA} ${WRKSRC}/images/qtpfsgui.png \
+ ${PREFIX}/share/icons/hicolor/32x32/apps
+ @${LN} -sf ${PREFIX}/share/icons/hicolor/32x32/apps/qtpfsgui.png \
+ ${PREFIX}/share/pixmaps/qtpfsgui.png
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DATADIR}
+ @${MKDIR} ${DATADIR}/i18n
+ ${INSTALL_DATA} ${WRKSRC}/i18n/*.qm ${DATADIR}/i18n
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for doc_file in AUTHORS Changelog README TODO
${INSTALL_DATA} ${WRKSRC}/${doc_file} ${DOCSDIR}
.endfor
+ @(cd ${WRKSRC}; ${COPYTREE_SHARE} html ${DOCSDIR})
.endif
.include <bsd.port.mk>
diff --git a/graphics/luminance/distinfo b/graphics/luminance/distinfo
index 5dab1867c1ab..63a027cfaad8 100644
--- a/graphics/luminance/distinfo
+++ b/graphics/luminance/distinfo
@@ -1,3 +1,3 @@
-MD5 (qtpfsgui-1.9.2.tar.gz) = 8a037c1dc75f04752dc36a59e7237fc4
-SHA256 (qtpfsgui-1.9.2.tar.gz) = 4462ec3ea8cf17db7b1ebe624d378bf4e239b80e0de2b2c6bbdf8c00cce16c8e
-SIZE (qtpfsgui-1.9.2.tar.gz) = 1181880
+MD5 (qtpfsgui-1.9.3.tar.gz) = 5a6421391e373c912e4a793e131151c8
+SHA256 (qtpfsgui-1.9.3.tar.gz) = 016aaa339ede405bfa55d531069bd64f45fd6139836b6ea9b4d655e2734b8fd6
+SIZE (qtpfsgui-1.9.3.tar.gz) = 1356731
diff --git a/graphics/luminance/files/patch-project.pro b/graphics/luminance/files/patch-project.pro
deleted file mode 100644
index cb4d0d736df3..000000000000
--- a/graphics/luminance/files/patch-project.pro
+++ /dev/null
@@ -1,28 +0,0 @@
---- project.pro.orig 2008-02-16 11:43:24.000000000 +0100
-+++ project.pro 2008-03-17 17:18:14.000000000 +0100
-@@ -298,13 +298,13 @@
- menu.files = qtpfsgui.desktop
- menu.path = $${PREFIX}/share/applications
- icon.files = images/qtpfsgui.png
--icon.path = $${PREFIX}/share/icons/hicolor/48x48/apps
-+icon.path = $${PREFIX}/share/pixmaps
- htmls.files = html
--htmls.path = $${PREFIX}/share/qtpfsgui
-+htmls.path = $${PREFIX}/share/doc/qtpfsgui
- i18n.files = i18n/lang_de.qm i18n/lang_es.qm i18n/lang_it.qm i18n/lang_fr.qm i18n/lang_pl.qm i18n/lang_tr.qm i18n/lang_ru.qm i18n/lang_cs.qm
- i18n.path = $$I18NDIR
- docs.files = README LICENSE AUTHORS INSTALL Changelog
--docs.path = $${PREFIX}/share/qtpfsgui
-+docs.path = $${PREFIX}/share/doc/qtpfsgui
-
- INSTALLS += target menu icon htmls i18n docs
- message ( "" )
-@@ -320,7 +320,7 @@
- message ("qtpfsgui ==> $$target.path")
- message ("qtpfsgui.desktop ==> $$menu.path")
- message ("qtpfsgui.png ==> $$icon.path")
--message ("html and docs ==> $$htmls.path")
-+message ("html ==> $$docs.path")
- message ("i18n messages ==> $$i18n.path")
- message ("********************************************************************")
-
diff --git a/graphics/luminance/files/patch-src__TM_operators__mantiuk06__contrast_domain.cpp b/graphics/luminance/files/patch-src__TM_operators__mantiuk06__contrast_domain.cpp
deleted file mode 100644
index a15b211d9f5b..000000000000
--- a/graphics/luminance/files/patch-src__TM_operators__mantiuk06__contrast_domain.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/TM_operators/mantiuk06/contrast_domain.cpp.orig 2008-04-28 18:15:22.000000000 +0200
-+++ src/TM_operators/mantiuk06/contrast_domain.cpp 2008-07-04 12:49:16.000000000 +0200
-@@ -41,8 +41,8 @@
- #include <string.h>
- #include <math.h>
-
--#ifdef WIN32
--#define exp10f( x ) exp( x * log (10))
-+#if defined(WIN32) || defined(__FreeBSD__)
-+#define exp10f(x) exp( (x) * log (10))
- #endif
-
- #include "contrast_domain.h"
diff --git a/graphics/luminance/pkg-plist b/graphics/luminance/pkg-plist
index cd5a44385a09..8133f9c26ea5 100644
--- a/graphics/luminance/pkg-plist
+++ b/graphics/luminance/pkg-plist
@@ -1,41 +1,44 @@
bin/qtpfsgui
share/applications/qtpfsgui.desktop
share/pixmaps/qtpfsgui.png
-share/icons/hicolor/48x48/apps/qtpfsgui.png
+share/icons/hicolor/32x32/apps/qtpfsgui.png
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/Changelog
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%DOCSDIR%%/html/dcraw.html
-%%DOCSDIR%%/html/faq.html
-%%DOCSDIR%%/html/hints.html
-%%DOCSDIR%%/html/images/batch-1.jpg
-%%DOCSDIR%%/html/images/copy_exif.jpeg
-%%DOCSDIR%%/html/images/mainwin.jpeg
-%%DOCSDIR%%/html/images/projectiveTransformationDialog.jpeg
-%%DOCSDIR%%/html/images/raw_conversion.jpg
-%%DOCSDIR%%/html/images/resize.jpeg
-%%DOCSDIR%%/html/images/snap-qt4_4.jpeg
-%%DOCSDIR%%/html/images/snap-qt4_5.jpeg
-%%DOCSDIR%%/html/images/snap-qt4_6.jpeg
-%%DOCSDIR%%/html/images/tonemapdialog.jpeg
-%%DOCSDIR%%/html/index.html
-%%DOCSDIR%%/html/manual.html
+%%PORTDOCS%%%%DOCSDIR%%/html/dcraw.html
+%%PORTDOCS%%%%DOCSDIR%%/html/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/html/hints.html
+%%PORTDOCS%%%%DOCSDIR%%/html/images/batch-1.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/images/copy_exif.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/images/mainwin.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/images/projectiveTransformationDialog.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/images/raw_conversion.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/images/resize.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/images/snap-qt4_4.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/images/snap-qt4_5.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/images/snap-qt4_6.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/images/tonemapdialog.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/manual.html
+%%DATADIR%%/LICENSE
%%DATADIR%%/i18n/lang_cs.qm
%%DATADIR%%/i18n/lang_de.qm
%%DATADIR%%/i18n/lang_es.qm
%%DATADIR%%/i18n/lang_fr.qm
+%%DATADIR%%/i18n/lang_hu.qm
+%%DATADIR%%/i18n/lang_id.qm
%%DATADIR%%/i18n/lang_it.qm
%%DATADIR%%/i18n/lang_pl.qm
%%DATADIR%%/i18n/lang_ru.qm
%%DATADIR%%/i18n/lang_tr.qm
@dirrm %%DATADIR%%/i18n
@dirrm %%DATADIR%%
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
-@dirrm %%DOCSDIR%%/html/images
-@dirrm %%DOCSDIR%%/html
-@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications