aboutsummaryrefslogtreecommitdiff
path: root/graphics/luminance
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-09-21 15:19:13 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-09-21 15:19:13 +0000
commitee87efc7d36005e9be1d347fa09e6bafd9464b68 (patch)
treeeb9ea13aacb276b6aa5a46881b219b932e92d826 /graphics/luminance
parent497fcbda6b4a06de0f0f9c49f7cec7c749538f20 (diff)
downloadports-ee87efc7d36005e9be1d347fa09e6bafd9464b68.tar.gz
ports-ee87efc7d36005e9be1d347fa09e6bafd9464b68.zip
- Update to version 2.3.0, the latest to date
- Cleanup port description, improve on COMMENT - Drop explicit ABI shlib version numbers from LIB_DEPENDS - Give maintainership to submitter Approved by: old maintainer
Notes
Notes: svn path=/head/; revision=304636
Diffstat (limited to 'graphics/luminance')
-rw-r--r--graphics/luminance/Makefile76
-rw-r--r--graphics/luminance/distinfo4
-rw-r--r--graphics/luminance/files/patch-src-HdrCreation_mtb_alignment.cpp10
-rw-r--r--graphics/luminance/files/patch-src__Exif__ExifOperations.cpp10
-rw-r--r--graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp10
-rw-r--r--graphics/luminance/files/patch-src__HelpBrowser__LuminancePaths.cpp20
-rw-r--r--graphics/luminance/pkg-descr8
-rw-r--r--graphics/luminance/pkg-plist159
8 files changed, 140 insertions, 157 deletions
diff --git a/graphics/luminance/Makefile b/graphics/luminance/Makefile
index e521e30657ee..0c7ba05b35bd 100644
--- a/graphics/luminance/Makefile
+++ b/graphics/luminance/Makefile
@@ -6,57 +6,45 @@
#
PORTNAME= luminance
-DISTVERSION= 2.0.1-1
-PORTREVISION= 5
+DISTVERSION= 2.3.0
CATEGORIES= graphics
-MASTER_SITES= SF/qtpfsgui/luminance/${DISTVERSION:S/-1//}/
-DISTNAME= ${PORTNAME}-v${DISTVERSION}
+MASTER_SITES= SF/qtpfsgui/${PORTNAME}/${DISTVERSION}
+DISTNAME= ${PORTNAME}-hdr-${DISTVERSION}
-MAINTAINER= goffredo@gmail.com
-COMMENT= An open source workflow for HDR imaging
+MAINTAINER= h2+fbsdports@fsfe.org
+COMMENT= Complete open source solution for HDR photography
LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
-LIB_DEPENDS= exiv2.12:${PORTSDIR}/graphics/exiv2 \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
- tiff.4:${PORTSDIR}/graphics/tiff \
- fftw3f:${PORTSDIR}/math/fftw3-float \
- gsl.16:${PORTSDIR}/math/gsl
-
-USE_QT4= gui xml webkit imageformats_run linguist_build \
- moc_build qmake_build rcc_build uic_build
-QMAKE_ARGS= PREFIX=${PREFIX} DOCDIR=${DOCSDIR} I18NDIR=${DATADIR}/i18n
-MAKE_JOBS_SAFE= yes
+LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float \
+ exiv2:${PORTSDIR}/graphics/exiv2 \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ IlmImf:${PORTSDIR}/graphics/OpenEXR \
+ tiff:${PORTSDIR}/graphics/tiff \
+ gsl:${PORTSDIR}/math/gsl \
+ raw_r:${PORTSDIR}/graphics/libraw
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_QT4= gui sql webkit xml linguist_build moc_build qmake_build \
+ rcc_build uic_build imageformats_run
INSTALLS_ICONS= yes
+MAKE_JOBS_SAFE= yes
-LRELEASE= ${QT_PREFIX}/bin/lrelease-qt4
-
-.include <bsd.port.pre.mk>
+DATADIR= ${PREFIX}/share/${PORTNAME}-hdr
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-hdr
post-patch:
-# FreeBSD has log2() since recently, remove local #define's which conflict
-# with prototypes in /usr/include/math.h (when applicable)
-.if ${OSVERSION} > 802501
- @${REINPLACE_CMD} -e '/log2/d' ${WRKSRC}/src/arch/freebsd/math.h
-.endif
- @cd ${WRKSRC}/src && ${REINPLACE_CMD} \
- -e 's|/usr/share/luminance|${DOCSDIR}|g' \
- -e 's|/usr/local/share/luminance|${DATADIR}|g' \
- MainWindow/MainWindow.cpp \
- Preferences/PreferencesDialog.cpp \
- TonemappingWindow/TonemappingWindow.cpp \
- TransplantExif/TransplantExifDialog.cpp
- @${REINPLACE_CMD} -e 's|%%HELPDIR%%|${DOCSDIR}|g' \
- ${WRKSRC}/src/HelpBrowser/LuminancePaths.cpp
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -E '/INSTALLS/s,help|docs,,g' ${WRKSRC}/project.pro
-.endif
-
-do-configure:
- @${LRELEASE} ${WRKSRC}/project.pro
- @cd ${WRKSRC} && \
- ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKE_ARGS} ${QMAKEFLAGS}
-
-.include <bsd.port.post.mk>
+# Do not install yet another copy of GPL (we use license framework instead)
+# and fix installation path for docs (but not for internal help files)
+ @${REINPLACE_CMD} -e '/LICENSE/d ; \
+ /#info files/s,share/luminance-hdr,${DOCSDIR_REL},' \
+ ${WRKSRC}/CMakeLists.txt
+# Allow builds from release distfile to display correct git hash in "About"
+# dialog window
+ @${REINPLACE_CMD} -e \
+ 's,@GIT_SHA1@,be5409f2ed028b0a509d3f4cd44a970a09d2ef6c,' \
+ ${WRKSRC}/src/Common/GitSHA1.cpp.in
+
+.include <bsd.port.mk>
diff --git a/graphics/luminance/distinfo b/graphics/luminance/distinfo
index a16419cbfd7e..b0706ea9581a 100644
--- a/graphics/luminance/distinfo
+++ b/graphics/luminance/distinfo
@@ -1,2 +1,2 @@
-SHA256 (luminance-v2.0.1-1.tar.gz) = 16ddead236f7b8d81fc67cbd7d8f384e51ebe5263c3a11afa6046821fb02e922
-SIZE (luminance-v2.0.1-1.tar.gz) = 2435362
+SHA256 (luminance-hdr-2.3.0.tar.bz2) = dada0795b58843912bcb57ce61dcd615bcb9f9437b610a37ff813ad2c899c676
+SIZE (luminance-hdr-2.3.0.tar.bz2) = 5398576
diff --git a/graphics/luminance/files/patch-src-HdrCreation_mtb_alignment.cpp b/graphics/luminance/files/patch-src-HdrCreation_mtb_alignment.cpp
deleted file mode 100644
index 3e8dec9913bb..000000000000
--- a/graphics/luminance/files/patch-src-HdrCreation_mtb_alignment.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/HdrCreation/mtb_alignment.cpp.orig 2008-03-17 15:55:26.000000000 +0100
-+++ src/HdrCreation/mtb_alignment.cpp 2008-03-17 15:57:21.000000000 +0100
-@@ -27,6 +27,7 @@
- #include <cassert>
- #include <QVector>
- #include "mtb_alignment.h"
-+#include "../arch/freebsd/math.h"
-
- QImage* shiftQImage(const QImage *in, int dx, int dy)
- {
diff --git a/graphics/luminance/files/patch-src__Exif__ExifOperations.cpp b/graphics/luminance/files/patch-src__Exif__ExifOperations.cpp
deleted file mode 100644
index 5f8387ff4d14..000000000000
--- a/graphics/luminance/files/patch-src__Exif__ExifOperations.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/Exif/ExifOperations.cpp.orig 2010-04-12 20:58:25.000000000 +0400
-+++ ./src/Exif/ExifOperations.cpp 2010-11-12 14:20:53.446299319 +0300
-@@ -23,6 +23,7 @@
-
- #include <image.hpp>
- #include <cmath>
-+#include "../arch/freebsd/math.h"
-
- #include "ExifOperations.h"
-
diff --git a/graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp b/graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp
deleted file mode 100644
index 8be3507718a3..000000000000
--- a/graphics/luminance/files/patch-src__HdrCreation__HdrCreationManager.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/HdrCreation/HdrCreationManager.cpp.orig 2010-05-20 21:46:40.000000000 +0400
-+++ ./src/HdrCreation/HdrCreationManager.cpp 2010-11-12 14:20:53.448299319 +0300
-@@ -23,6 +23,7 @@
-
- #include <QApplication>
- #include <QFileInfo>
-+#include "../arch/freebsd/math.h"
-
- #include "Fileformat/pfstiff.h"
- #include "Exif/ExifOperations.h"
diff --git a/graphics/luminance/files/patch-src__HelpBrowser__LuminancePaths.cpp b/graphics/luminance/files/patch-src__HelpBrowser__LuminancePaths.cpp
index 92b49708b84d..7a57e9231987 100644
--- a/graphics/luminance/files/patch-src__HelpBrowser__LuminancePaths.cpp
+++ b/graphics/luminance/files/patch-src__HelpBrowser__LuminancePaths.cpp
@@ -1,11 +1,11 @@
---- ./src/HelpBrowser/LuminancePaths.cpp.orig 2009-12-05 19:28:52.000000000 +0300
-+++ ./src/HelpBrowser/LuminancePaths.cpp 2010-11-12 14:20:53.460402688 +0300
-@@ -35,7 +35,7 @@
- hf = LocalizedDirPath(QApplication::applicationDirPath() + dirsep + "help" + dirsep );
+--- ./src/HelpBrowser/LuminancePaths.cpp.orig
++++ ./src/HelpBrowser/LuminancePaths.cpp
+@@ -35,8 +35,6 @@ QString LuminancePaths::HelpDir()
+ hf = LocalizedDirPath(QApplication::applicationDirPath() + dirsep + "../Resources/help/en" + dirsep);
+ #elif _WIN32
+ hf = LocalizedDirPath(QApplication::applicationDirPath() + dirsep + "help" + dirsep);
+-#elif __FreeBSD__
+- hf = LocalizedDirPath("/usr/local/share/doc/luminance-hdr/");
#else
- // hf = LocalizedDirPath( PREFIX + dirsep + "share" + dirsep + "fontmatrix" + dirsep + "help" + dirsep );
-- hf = LocalizedDirPath( "/usr" + dirsep + "share" + dirsep + "luminance" + dirsep + "help" + dirsep );
-+ hf = LocalizedDirPath( "%%HELPDIR%%/" );
- #endif
- getThis()->LuminancePathsDB["HelpDir"] = hf;
-
+ // hf = LocalizedDirPath( PREFIX + dirsep + "share" + dirsep + "fontmatrix" + dirsep + "help" + dirsep );
+ //hf = LocalizedDirPath("usr" + dirsep + "share" + dirsep + "luminance-hdr" + dirsep + "help" + dirsep);
diff --git a/graphics/luminance/pkg-descr b/graphics/luminance/pkg-descr
index 04fb8de48add..dc1915d6d8e3 100644
--- a/graphics/luminance/pkg-descr
+++ b/graphics/luminance/pkg-descr
@@ -3,8 +3,8 @@ aims to provide a workflow for HDR imaging.
Supported features:
- * Create an HDR file from a set of images (formats: JPEG, TIFF 8bit and
- 16bit, RAW) of the same scene taken at different exposure settings
+ * Create an HDR file from a set of images (formats: JPEG, TIFF 8-bit and
+ 16-bit, RAW) of the same scene taken at different exposure settings
* Rotate, resize, and crop HDR images
* Tonemap HDR images
* Copy EXIF data between sets of images
@@ -13,8 +13,10 @@ Supported HDR formats (with file extensions):
* OpenEXR (.exr)
* Radiance RGBE (.hdr)
- * TIFF formats: 16bit, 32bit (float) and LogLuv (.tiff)
+ * TIFF formats: 16-bit, 32-bit (float) and LogLuv (.tiff)
* PFS native format (.pfs)
* Raw image formats (various)
+Supported LDR formats: JPEG, PNG, PPM, PBM, TIFF (8-bit).
+
WWW: http://qtpfsgui.sourceforge.net/
diff --git a/graphics/luminance/pkg-plist b/graphics/luminance/pkg-plist
index 63ee59f60676..6f7de1691408 100644
--- a/graphics/luminance/pkg-plist
+++ b/graphics/luminance/pkg-plist
@@ -1,78 +1,101 @@
-bin/luminance
-share/applications/luminance.desktop
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/BUGS
-%%PORTDOCS%%%%DOCSDIR%%/Changelog
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/help/en/README
-%%PORTDOCS%%%%DOCSDIR%%/help/en/additional.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/basics.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/contributing.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/contributing_donating.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/contributing_programming.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/contributing_testing.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/contributing_translating.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/copying_exif.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/creating_hdr.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/creating_hdr_cli.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/creating_hdr_interactive.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/dcraw.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/editing_hdr.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/external.png
-%%PORTDOCS%%%%DOCSDIR%%/help/en/faq.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/features.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/hints.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/images/batch-tmo.png
-%%PORTDOCS%%%%DOCSDIR%%/help/en/images/copy-exif.png
-%%PORTDOCS%%%%DOCSDIR%%/help/en/images/mainwin.jpeg
-%%PORTDOCS%%%%DOCSDIR%%/help/en/images/not-translated-menu-item.png
-%%PORTDOCS%%%%DOCSDIR%%/help/en/images/projectiveTransformationDialog.png
-%%PORTDOCS%%%%DOCSDIR%%/help/en/images/resize.png
-%%PORTDOCS%%%%DOCSDIR%%/help/en/images/tonemapdialog.jpg
-%%PORTDOCS%%%%DOCSDIR%%/help/en/images/translated-menu-item.png
-%%PORTDOCS%%%%DOCSDIR%%/help/en/index.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/manual.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/menu.xml
-%%PORTDOCS%%%%DOCSDIR%%/help/en/news.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/prefs.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/prefs_hdr.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/prefs_tonemapping.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/prefs_tools.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/prefs_ui.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/projective_transformation.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/style.css
-%%PORTDOCS%%%%DOCSDIR%%/help/en/tmap_ref.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/tmap_ref_drago.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/tmap_ref_durand.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/tmap_ref_mantiuk06.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/tonemapping.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/tonemapping_batch.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/tonemapping_cli.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/tonemapping_interactive.html
-%%PORTDOCS%%%%DOCSDIR%%/help/en/workflow.html
-%%PORTDOCS%%%%DOCSDIR%%/help/js/jquery.js
-%%PORTDOCS%%%%DOCSDIR%%/help/js/jquery.jtabs.pack.js
-share/icons/hicolor/32x32/apps/luminance.png
+bin/luminance-hdr
+bin/luminance-hdr-cli
+share/applications/luminance-hdr.desktop
+share/icons/hicolor/48x48/apps/luminance-hdr.png
+%%DATADIR%%/help/en/README
+%%DATADIR%%/help/en/additional.html
+%%DATADIR%%/help/en/basics.html
+%%DATADIR%%/help/en/color_management.html
+%%DATADIR%%/help/en/contributing.html
+%%DATADIR%%/help/en/contributing_donating.html
+%%DATADIR%%/help/en/contributing_programming.html
+%%DATADIR%%/help/en/contributing_testing.html
+%%DATADIR%%/help/en/contributing_translating.html
+%%DATADIR%%/help/en/copying_exif.html
+%%DATADIR%%/help/en/creating_hdr.html
+%%DATADIR%%/help/en/creating_hdr_batch.html
+%%DATADIR%%/help/en/creating_hdr_cli.html
+%%DATADIR%%/help/en/creating_hdr_interactive.html
+%%DATADIR%%/help/en/dcraw.html
+%%DATADIR%%/help/en/editing_hdr.html
+%%DATADIR%%/help/en/external.png
+%%DATADIR%%/help/en/faq.html
+%%DATADIR%%/help/en/features.html
+%%DATADIR%%/help/en/hints.html
+%%DATADIR%%/help/en/images/batch-hdr.png
+%%DATADIR%%/help/en/images/batch-tmo.png
+%%DATADIR%%/help/en/images/color_management.png
+%%DATADIR%%/help/en/images/copy-exif.png
+%%DATADIR%%/help/en/images/cropping_frame.png
+%%DATADIR%%/help/en/images/mainwin.png
+%%DATADIR%%/help/en/images/not-translated-menu-item.png
+%%DATADIR%%/help/en/images/preferences.png
+%%DATADIR%%/help/en/images/prefs-cms.png
+%%DATADIR%%/help/en/images/prefs-ext.png
+%%DATADIR%%/help/en/images/prefs-hdr.png
+%%DATADIR%%/help/en/images/prefs-raw.png
+%%DATADIR%%/help/en/images/prefs-tm.png
+%%DATADIR%%/help/en/images/projectiveTransformationDialog.png
+%%DATADIR%%/help/en/images/resize.png
+%%DATADIR%%/help/en/images/translated-menu-item.png
+%%DATADIR%%/help/en/index.html
+%%DATADIR%%/help/en/manual.html
+%%DATADIR%%/help/en/menu.xml
+%%DATADIR%%/help/en/news.html
+%%DATADIR%%/help/en/prefs.html
+%%DATADIR%%/help/en/prefs_cms.html
+%%DATADIR%%/help/en/prefs_hdr.html
+%%DATADIR%%/help/en/prefs_rawconversion.html
+%%DATADIR%%/help/en/prefs_tonemapping.html
+%%DATADIR%%/help/en/prefs_tools.html
+%%DATADIR%%/help/en/prefs_ui.html
+%%DATADIR%%/help/en/projective_transformation.html
+%%DATADIR%%/help/en/style.css
+%%DATADIR%%/help/en/tmap_ref.html
+%%DATADIR%%/help/en/tmap_ref_drago.html
+%%DATADIR%%/help/en/tmap_ref_durand.html
+%%DATADIR%%/help/en/tmap_ref_mantiuk06.html
+%%DATADIR%%/help/en/tonemapping.html
+%%DATADIR%%/help/en/tonemapping_batch.html
+%%DATADIR%%/help/en/tonemapping_cli.html
+%%DATADIR%%/help/en/tonemapping_interactive.html
+%%DATADIR%%/help/en/workflow.html
+%%DATADIR%%/help/js/jquery.js
+%%DATADIR%%/help/js/jquery.jtabs.pack.js
+@dirrm %%DATADIR%%/help/js
+@dirrm %%DATADIR%%/help/en/images
+@dirrm %%DATADIR%%/help/en
+@dirrm %%DATADIR%%/help
%%DATADIR%%/i18n/lang_cs.qm
%%DATADIR%%/i18n/lang_de.qm
%%DATADIR%%/i18n/lang_es.qm
+%%DATADIR%%/i18n/lang_fi.qm
%%DATADIR%%/i18n/lang_fr.qm
+%%DATADIR%%/i18n/lang_hi.qm
+%%DATADIR%%/i18n/lang_hu.qm
+%%DATADIR%%/i18n/lang_id.qm
%%DATADIR%%/i18n/lang_it.qm
%%DATADIR%%/i18n/lang_pl.qm
+%%DATADIR%%/i18n/lang_ro.qm
%%DATADIR%%/i18n/lang_ru.qm
+%%DATADIR%%/i18n/lang_sk.qm
%%DATADIR%%/i18n/lang_tr.qm
+%%DATADIR%%/i18n/lang_zh.qm
+%%DATADIR%%/i18n/qt_cs.qm
+%%DATADIR%%/i18n/qt_de.qm
+%%DATADIR%%/i18n/qt_es.qm
+%%DATADIR%%/i18n/qt_fi.qm
+%%DATADIR%%/i18n/qt_fr.qm
+%%DATADIR%%/i18n/qt_hu.qm
+%%DATADIR%%/i18n/qt_it.qm
+%%DATADIR%%/i18n/qt_pl.qm
+%%DATADIR%%/i18n/qt_ro.qm
+%%DATADIR%%/i18n/qt_ru.qm
+%%DATADIR%%/i18n/qt_tr.qm
+%%DATADIR%%/i18n/qt_zh.qm
@dirrm %%DATADIR%%/i18n
@dirrm %%DATADIR%%
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/js
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/img
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/en/images
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/en
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/help
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrmtry share/applications
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/Changelog
+%%DOCSDIR%%/README
+@dirrm %%DOCSDIR%%