aboutsummaryrefslogtreecommitdiff
path: root/graphics/ming
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-21 14:09:43 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-21 14:09:43 +0000
commitbdf8dcba58133d035bff874bfc84f5c3e2865497 (patch)
tree83edb620aae569e61757d0a374f858e6644c47ce /graphics/ming
parent8261c30458dfb0a85f6b7746fc8d4398a562016b (diff)
downloadports-bdf8dcba58133d035bff874bfc84f5c3e2865497.tar.gz
ports-bdf8dcba58133d035bff874bfc84f5c3e2865497.zip
- Change gif library from graphics/libungif to graphics/giflib
- Sort LIB_DEPENDS - Collect post-patch: of slave ports (graphics/p5-ming and graphics/py-ming) - Bump PORTREVISION for dependency change
Notes
Notes: svn path=/head/; revision=291999
Diffstat (limited to 'graphics/ming')
-rw-r--r--graphics/ming/Makefile23
1 files changed, 18 insertions, 5 deletions
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index 5fe2ed3d565c..fa03d9c03f23 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -7,20 +7,21 @@
PORTNAME= ming
PORTVERSION= 0.4.4
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Releases/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Flash 4/5 movie output library with many languages support
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
- ungif.5:${PORTSDIR}/graphics/libungif \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
+ gif.5:${PORTSDIR}/graphics/giflib \
+ png.6:${PORTSDIR}/graphics/png
CONFLICTS= ja-ming-[0-9]*
-CONFIGURE_ARGS+= --includedir=${PREFIX}/include/ming
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS+=--includedir=${PREFIX}/include/ming
CPPFLAGS+= -I. -I.. -I${LOCALBASE}/include
LDFLAGS+= -L. -L.. -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
@@ -37,6 +38,18 @@ DOCS_UTIL= README TIPS TODO swftoperl.html
LIB_DEPENDS+= ming.5:${PORTSDIR}/graphics/ming
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|ungif|gif|g' ${WRKSRC}/configure ${WRKSRC}/docs/man/Makefile \
+ ${WRKSRC}/perl_ext/Makefile.PL ${WRKSRC}/py_ext/setup.py.in
+# patch for graphics/p5-ming
+ @${REINPLACE_CMD} -e 's|\.3pm|.3|g' ${WRKSRC}/perl_ext/Makefile.PL ${WRKSRC}/perl_ext/mkdoc
+ @${REINPLACE_CMD} -e 's|GvCV(\(.*\)) = \(.*\);|GvCV_set(\1, \2);|' ${WRKSRC}/perl_ext/Exports.c
+ @${REINPLACE_CMD} -e '1 s|/usr/bin/perl|${PERL}|' ${WRKSRC}/perl_ext/examples/*.cgi
+# patch for graphics/py-ming
+ @${REINPLACE_CMD} -e 's| --root ".*"||' ${WRKSRC}/py_ext/Makefile.in
+ @${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g' ${WRKSRC}/py_ext/setup.py.in
+ @${LN} -sf ${LOCALBASE}/include/ming ${WRKSRC}/src
+
.if !target(post-install)
post-install:
${MKDIR} ${PREFIX}/include/ming/ ${PREFIX}/include/ming/blocks/ ${PREFIX}/include/ming/util/