aboutsummaryrefslogtreecommitdiff
path: root/graphics/ming
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-15 07:46:18 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-15 07:46:18 +0000
commitcc61336dab963bd883130808553972a7ab291f6e (patch)
tree1d02b11eeaa34e0c0355899b9c707b1c0d372276 /graphics/ming
parent9e38593ec2fc0c4fcbf9af92426e7e8cc8e01185 (diff)
downloadports-cc61336dab963bd883130808553972a7ab291f6e.tar.gz
ports-cc61336dab963bd883130808553972a7ab291f6e.zip
- Update to 0.4.4
Notes
Notes: svn path=/head/; revision=291422
Diffstat (limited to 'graphics/ming')
-rw-r--r--graphics/ming/Makefile73
-rw-r--r--graphics/ming/distinfo4
2 files changed, 23 insertions, 54 deletions
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index 3c13b74b0eec..5fe2ed3d565c 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= ming
-PORTVERSION= 0.4.3
-PORTREVISION?= 1
+PORTVERSION= 0.4.4
+PORTREVISION?= 0
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}/Releases/Ming%20${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/Releases/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Flash 4/5 movie output library with many languages support
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
@@ -20,67 +20,36 @@ LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
CONFLICTS= ja-ming-[0-9]*
-USE_GNOME= gnomehack
-USE_GMAKE= yes
-USE_BISON= build
-GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --includedir=${PREFIX}/include/ming
-USE_LDCONFIG= yes
-MAKE_JOBS_UNSAFE= yes
-
CPPFLAGS+= -I. -I.. -I${LOCALBASE}/include
LDFLAGS+= -L. -L.. -L${LOCALBASE}/lib
-CFLAGS+= ${CPPFLAGS}
+GNU_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
+USE_BISON= build
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
DOCS= HISTORY NEWS README TODO
DOCS_UTIL= README TIPS TODO swftoperl.html
-.if defined(SLAVE_PORT)
+.if defined(SLAVEPORT)
LIB_DEPENDS+= ming.5:${PORTSDIR}/graphics/ming
.endif
-.if defined(SLAVE_PORT) && ${SLAVE_PORT}=="p5"
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.endif
-
+.if !target(post-install)
post-install:
-.if !defined(SLAVE_PORT)
- ${INSTALL_SCRIPT} ${WRKSRC}/util/ming-config ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/util/cws2fws ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/include/ming
- ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/ming
- ${INSTALL_DATA} ${WRKSRC}/src/*.h ${PREFIX}/include/ming
- @${MKDIR} ${PREFIX}/include/ming/util
- ${INSTALL_DATA} ${WRKSRC}/util/*.h ${PREFIX}/include/ming/util
- ${INSTALL_DATA} ${WRKSRC}/util/png2dbl.c ${PREFIX}/include/ming/util
- @${MKDIR} ${PREFIX}/include/ming/blocks
- ${INSTALL_DATA} ${WRKSRC}/src/blocks/*.h ${PREFIX}/include/ming/blocks
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for docs in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
-.endfor
- @${MKDIR} ${DOCSDIR}/util
-.for docs_utils in ${DOCS_UTIL}
- @${INSTALL_DATA} ${WRKSRC}/util/${docs_utils} ${DOCSDIR}/util
-.endfor
-.endif
-.endif
-
-.if defined(SLAVE_PORT) && ${SLAVE_PORT}=="p5"
+ ${MKDIR} ${PREFIX}/include/ming/ ${PREFIX}/include/ming/blocks/ ${PREFIX}/include/ming/util/
+ cd ${WRKSRC}/ && \
+ ${INSTALL_SCRIPT} util/cws2fws util/ming-config ${PREFIX}/bin/ && \
+ ${INSTALL_DATA} *.h src/*.h ${PREFIX}/include/ming/ && \
+ ${INSTALL_DATA} src/blocks/*.h ${PREFIX}/include/ming/blocks/ && \
+ ${INSTALL_DATA} util/png2dbl.c util/*.h ${PREFIX}/include/ming/util/
.if !defined(NOPORTDOCS)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${INSTALL_WRKSRC}/examples/*.* ${EXAMPLESDIR}
+ ${MKDIR} ${DOCSDIR}/ ${DOCSDIR}/util/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}/
+ cd ${WRKSRC}/util/ && ${INSTALL_DATA} ${DOCS_UTIL} ${DOCSDIR}/util/
.endif
.endif
-pre-install:
-.if defined(SLAVE_PORT) && ${SLAVE_PORT}=="p5"
- @${REINPLACE_CMD} 's/3pm/3/g' ${INSTALL_WRKSRC}/Makefile
- @${REINPLACE_CMD} 's/3pm/3/g' ${INSTALL_WRKSRC}/Makefile.perl
-.for m in ${MAN3}
- ${MV} ${INSTALL_WRKSRC}/blib/man3/${m}pm ${INSTALL_WRKSRC}/blib/man3/${m}
-.endfor
-.endif
-
.include <bsd.port.mk>
diff --git a/graphics/ming/distinfo b/graphics/ming/distinfo
index 482c6ca74880..a3f8f4102e0d 100644
--- a/graphics/ming/distinfo
+++ b/graphics/ming/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ming-0.4.3.tar.gz) = 1fbe9f03c92130ebad0f68f61ed0d1e35c9b5b42adbb2ba1a340d2ac9523624b
-SIZE (ming-0.4.3.tar.gz) = 14920165
+SHA256 (ming-0.4.4.tar.gz) = 002ab467e861b3d4c4df716d3f6eb1a13ff55daa39f246c9f7d81ccf11f5b798
+SIZE (ming-0.4.4.tar.gz) = 14816668