aboutsummaryrefslogtreecommitdiff
path: root/graphics/mingplot
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-07 21:36:42 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-07 21:36:42 +0000
commite298440097f052fda9c6352e379a3515e6a36e2b (patch)
tree8ebf1b74e9897d23e61a476e0daecb8376a599d1 /graphics/mingplot
parentc10d567bdc3f0ec05e51b5cc023a2400bc3f0430 (diff)
downloadports-e298440097f052fda9c6352e379a3515e6a36e2b.tar.gz
ports-e298440097f052fda9c6352e379a3515e6a36e2b.zip
Add mingplot, a tool to generate flash-based charts.
PR: ports/59361 Submitted by: UMENO Takashi <umeno@rr.iij4u.or.jp>
Notes
Notes: svn path=/head/; revision=95289
Diffstat (limited to 'graphics/mingplot')
-rw-r--r--graphics/mingplot/Makefile21
-rw-r--r--graphics/mingplot/distinfo1
-rw-r--r--graphics/mingplot/files/patch-mingchart.rb69
-rw-r--r--graphics/mingplot/pkg-descr4
-rw-r--r--graphics/mingplot/pkg-plist9
5 files changed, 104 insertions, 0 deletions
diff --git a/graphics/mingplot/Makefile b/graphics/mingplot/Makefile
new file mode 100644
index 000000000000..ff7355b3ed17
--- /dev/null
+++ b/graphics/mingplot/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: mingplot
+# Date created: 14 Nov 2003
+# Whom: UMENO Takashi <umeno@rr.iij4u.or.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mingplot
+PORTVERSION= 0.2
+CATEGORIES= graphics www
+MASTER_SITES= http://namazu.org/~satoru/mingplot/
+
+MAINTAINER= umeno@rr.iij4u.or.jp
+COMMENT= A tool to generate a flash-based chart
+
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/ming/ming.so:${PORTSDIR}/graphics/ruby-ming \
+ ${RUBY_SITEARCHLIBDIR}/iconv.so:${PORTSDIR}/converters/ruby-iconv
+
+USE_RUBY= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/mingplot/distinfo b/graphics/mingplot/distinfo
new file mode 100644
index 000000000000..6b8f4543661c
--- /dev/null
+++ b/graphics/mingplot/distinfo
@@ -0,0 +1 @@
+MD5 (mingplot-0.2.tar.gz) = 7f54e5224f14f5e490617f540fafebe8
diff --git a/graphics/mingplot/files/patch-mingchart.rb b/graphics/mingplot/files/patch-mingchart.rb
new file mode 100644
index 000000000000..d06ca349995a
--- /dev/null
+++ b/graphics/mingplot/files/patch-mingchart.rb
@@ -0,0 +1,69 @@
+--- mingchart.rb.orig Fri Aug 15 10:06:17 2003
++++ mingchart.rb Fri Aug 15 10:06:20 2003
+@@ -188,7 +188,7 @@
+
+ def add_axises
+ shape = SWFShape.new
+- shape.set_line(@axis_line_width, *@axis_line_color)
++ shape.set_line(@axis_line_width, *@axis_line_color.to_a)
+ shape.move_pen(@canvas_x_margin, @canvas_y_margin)
+ shape.draw_line(0, @y_length)
+ shape.draw_line(@x_length, 0)
+@@ -325,7 +325,7 @@
+ item.move_to(xx + x_margin, yy + y_margin)
+
+ line = SWFShape.new
+- line.set_line(@scale_line_width, *@scale_line_color)
++ line.set_line(@scale_line_width, *@scale_line_color.to_a)
+ line.move_pen_to(xx, yy)
+ if at == :bottom
+ line.draw_line(0, -@s...)
+@@ -354,7 +354,7 @@
+ xx = convert_x(x)
+ yy = @canvas_height - @canvas_y_margin
+ line = SWFShape.new
+- line.set_line(@grid_line_width, *@grid_line_color)
++ line.set_line(@grid_line_width, *@grid_line_color.to_a)
+ line.move_pen_to(xx, yy)
+ line.draw_line(0, -@y...)
+ @movie.add(line)
+@@ -370,7 +370,7 @@
+ xx = @canvas_x_margin
+ yy = convert_y(y, side)
+ line = SWFShape.new
+- line.set_line(@grid_line_width, *@grid_line_color)
++ line.set_line(@grid_line_width, *@grid_line_color.to_a)
+ line.move_pen_to(xx, yy)
+ line.draw_line(@x_length, 0)
+ @movie.add(line)
+@@ -424,7 +424,7 @@
+
+ def draw_line (data, color, side, fill_p = false)
+ line = SWFShape.new
+- line.set_line(@line_width, *color)
++ line.set_line(@line_width, *color.to_a)
+ first_time = true
+
+ if fill_p
+@@ -549,8 +549,9 @@
+ texts.push([text, width, height, lineno])
+ }
+
+- total_height = texts.map {|x| x[2] }.inject(0) {|x, y|
+- x + y * @line_title_line_height_ratio
++ total_height = 0
++ texts.map {|x| x[2] }.each {|v|
++ total_height += v * @line_title_line_height_ratio
+ }
+ max_width = texts.map {|x| x[1] }.max
+
+@@ -571,7 +572,7 @@
+ base_y + height + height * i * @line_title_line_height_ratio)
+
+ line = SWFShape.new
+- line.set_line(@line_width, *@line_colors[lineno])
++ line.set_line(@line_width, *@line_colors[lineno].to_a)
+ line.draw_line(@line_title_line_length, 0)
+ item = @movie.add(line)
+ item.move_to(base_x + @line_title_line_margin,
+
diff --git a/graphics/mingplot/pkg-descr b/graphics/mingplot/pkg-descr
new file mode 100644
index 000000000000..09c94e49b245
--- /dev/null
+++ b/graphics/mingplot/pkg-descr
@@ -0,0 +1,4 @@
+Mingplot is a tool to generate a flash-based chart using ming.
+
+For more information, see
+WWW: http://namazu.org/~satoru/mingplot/
diff --git a/graphics/mingplot/pkg-plist b/graphics/mingplot/pkg-plist
new file mode 100644
index 000000000000..0ec0a6d816e1
--- /dev/null
+++ b/graphics/mingplot/pkg-plist
@@ -0,0 +1,9 @@
+bin/amazonplot
+bin/googleplot
+share/mingplot/mingplot.css
+share/mingplot/EfontSerifB.fdb
+%%RUBY_SITELIBDIR%%/mingchart.rb
+%%RUBY_SITELIBDIR%%/mingplot.rb
+%%RUBY_SITELIBDIR%%/googleplot.rb
+%%RUBY_SITELIBDIR%%/amazonplot.rb
+@dirrm share/mingplot