aboutsummaryrefslogtreecommitdiff
path: root/graphics/nip2/Makefile
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2003-12-22 14:33:10 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2003-12-22 14:33:10 +0000
commit0110b62347c7f70544dd0368019eb9fb9256015a (patch)
tree1b2ba7871291c1d69b3eda632f23327ac631c534 /graphics/nip2/Makefile
parent725dc7f1578c2418c52bd4ec8b3efe60bb5605db (diff)
downloadports-0110b62347c7f70544dd0368019eb9fb9256015a.tar.gz
ports-0110b62347c7f70544dd0368019eb9fb9256015a.zip
Add nip-7.8.12 - Graphical user interface for VIPS
Notes
Notes: svn path=/head/; revision=96436
Diffstat (limited to 'graphics/nip2/Makefile')
-rw-r--r--graphics/nip2/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/graphics/nip2/Makefile b/graphics/nip2/Makefile
new file mode 100644
index 000000000000..23fd5ccaf5eb
--- /dev/null
+++ b/graphics/nip2/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: vips
+# Date created: 19 December 2003
+# Whom: Lev Serebryakov <lev@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nip
+PORTVERSION= 7.8.12
+CATEGORIES= graphics
+MASTER_SITES= http://www.vips.ecs.soton.ac.uk/vips-7.8/
+
+MAINTAINER= lev@FreeBSD.org
+COMMENT= Graphical user interface for VIPS
+
+LIB_DEPENDS= vips.0:${PORTSDIR}/graphics/vips \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ gtkextra.17:${PORTSDIR}/x11-toolkits/gtkextra
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+USE_XLIB= yes
+USE_REINPLACE= yes
+
+MAN1= nip.1
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} 's/^EXTRA_DIST = scraps bootstrap doc/EXTRA_DIST = scraps bootstrap/' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} '535,538s/^/#/' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>