aboutsummaryrefslogtreecommitdiff
path: root/graphics/nip2
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2011-09-23 22:29:55 +0000
committerMikhail Teterin <mi@FreeBSD.org>2011-09-23 22:29:55 +0000
commit61f1dfd76896369f3443ee826a77e3ffb0e1256d (patch)
tree11b0e1205e24c54a5fa0b9d652904ff87a229773 /graphics/nip2
parent6f6fbe4bdf9851de1eb6ebef5287e3007846045e (diff)
downloadports-61f1dfd76896369f3443ee826a77e3ffb0e1256d.tar.gz
ports-61f1dfd76896369f3443ee826a77e3ffb0e1256d.zip
Upgrade from 7.14.5 to 7.26.3.
Requested by: Doug Fortune
Notes
Notes: svn path=/head/; revision=282283
Diffstat (limited to 'graphics/nip2')
-rw-r--r--graphics/nip2/Makefile7
-rw-r--r--graphics/nip2/distinfo4
-rw-r--r--graphics/nip2/files/patch-src_gtkitementry.c56
-rw-r--r--graphics/nip2/pkg-plist98
4 files changed, 84 insertions, 81 deletions
diff --git a/graphics/nip2/Makefile b/graphics/nip2/Makefile
index d8828576439c..429f2ad63592 100644
--- a/graphics/nip2/Makefile
+++ b/graphics/nip2/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= nip2
-PORTVERSION= 7.14.5
-PORTREVISION= 7
+PORTVERSION= 7.26.3
CATEGORIES= graphics
MASTER_SITES= http://www.vips.ecs.soton.ac.uk/supported/${PORTVERSION:R}/
MAINTAINER= mi@aldan.algebra.com
COMMENT= Graphical user interface for VIPS
-LIB_DEPENDS= vips:${PORTSDIR}/graphics/vips \
+LIB_DEPENDS= vips.3[0-9]:${PORTSDIR}/graphics/vips \
gsl:${PORTSDIR}/math/gsl \
xml2:${PORTSDIR}/textproc/libxml2
@@ -23,7 +22,7 @@ USE_GMAKE= yes
USE_GNOME= gnomemimedata glib20 pkgconfig gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --mandir=${PREFIX}/man
-ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
+MAKE_JOBS_SAFE= yes
# This port has no man-pages. It installs a number of HTML files,
# which are available through the GUI's Help. For this reason, they
# are always installed, regardless of the NOPORTDOCS setting.
diff --git a/graphics/nip2/distinfo b/graphics/nip2/distinfo
index cb2b20be142f..ffc79630175f 100644
--- a/graphics/nip2/distinfo
+++ b/graphics/nip2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nip2-7.14.5.tar.gz) = 27e1102682c6650b707d74327746f28f8f55badcc73ff46ec8d021a3444f5aa2
-SIZE (nip2-7.14.5.tar.gz) = 8385657
+SHA256 (nip2-7.26.3.tar.gz) = 94d842ffb6ba1d210ce7358c62f4f4cfa52c5663a2deb03f662aba29a0bee9d8
+SIZE (nip2-7.26.3.tar.gz) = 8681267
diff --git a/graphics/nip2/files/patch-src_gtkitementry.c b/graphics/nip2/files/patch-src_gtkitementry.c
deleted file mode 100644
index 43b809d653d5..000000000000
--- a/graphics/nip2/files/patch-src_gtkitementry.c
+++ /dev/null
@@ -1,56 +0,0 @@
---- src/gtkitementry.c.orig 2010-10-31 15:58:33.000000000 +0100
-+++ src/gtkitementry.c 2010-10-31 15:59:28.000000000 +0100
-@@ -131,7 +131,7 @@ static void gtk_entry_draw_curso
- static PangoLayout *gtk_entry_ensure_layout (GtkEntry *entry,
- gboolean include_preedit);
- static void gtk_entry_queue_draw (GtkEntry *entry);
--static void gtk_entry_reset_im_context (GtkEntry *entry);
-+static void nip_gtk_entry_reset_im_context (GtkEntry *entry);
- static void gtk_entry_recompute (GtkEntry *entry);
- static void gtk_entry_get_cursor_locations (GtkEntry *entry,
- CursorType type,
-@@ -657,7 +657,7 @@ gtk_entry_real_set_position (GtkEditable
- if (position != entry->current_pos ||
- position != entry->selection_bound)
- {
-- gtk_entry_reset_im_context (entry);
-+ nip_gtk_entry_reset_im_context (entry);
- gtk_entry_set_positions (entry, position, position);
- }
- }
-@@ -823,7 +823,7 @@ gtk_entry_move_cursor (GtkEntry *e
- {
- gint new_pos = entry->current_pos;
-
-- gtk_entry_reset_im_context (entry);
-+ nip_gtk_entry_reset_im_context (entry);
-
- if (entry->current_pos != entry->selection_bound && !extend_selection)
- {
-@@ -917,7 +917,7 @@ gtk_entry_insert_at_cursor (GtkEntry
-
- if (entry->editable)
- {
-- gtk_entry_reset_im_context (entry);
-+ nip_gtk_entry_reset_im_context (entry);
-
- gtk_editable_insert_text (editable, str, -1, &pos);
- gtk_editable_set_position (editable, pos);
-@@ -933,7 +933,7 @@ gtk_entry_delete_from_cursor (GtkEntry
- gint start_pos = entry->current_pos;
- gint end_pos = entry->current_pos;
-
-- gtk_entry_reset_im_context (entry);
-+ nip_gtk_entry_reset_im_context (entry);
-
- if (!entry->editable)
- return;
-@@ -1699,7 +1699,7 @@ gtk_entry_queue_draw (GtkEntry *entry)
- }
-
- static void
--gtk_entry_reset_im_context (GtkEntry *entry)
-+nip_gtk_entry_reset_im_context (GtkEntry *entry)
- {
- if (entry->need_im_reset)
- {
diff --git a/graphics/nip2/pkg-plist b/graphics/nip2/pkg-plist
index b7278851a29b..ce2cc87e80d7 100644
--- a/graphics/nip2/pkg-plist
+++ b/graphics/nip2/pkg-plist
@@ -2,15 +2,6 @@ bin/nip2
bin/run-nip2.sh
share/nip2/rc/ipgtkrc
share/nip2/data/examples/logo/logo2.ws
-share/nip2/data/examples/1_point_mosiac/cd1.2.jpg
-share/nip2/data/examples/1_point_mosiac/cd4.2.jpg
-share/nip2/data/examples/1_point_mosiac/cd2.1.jpg
-share/nip2/data/examples/1_point_mosiac/cd4.1.jpg
-share/nip2/data/examples/1_point_mosiac/cd1.1.jpg
-share/nip2/data/examples/1_point_mosiac/cd3.2.jpg
-share/nip2/data/examples/1_point_mosiac/cd2.2.jpg
-share/nip2/data/examples/1_point_mosiac/cd3.1.jpg
-share/nip2/data/examples/1_point_mosiac/1pt_mosaic.ws
share/nip2/data/examples/overlays_and_blending/overlay_blend.ws
share/nip2/data/examples/overlays_and_blending/blend_example_ir.jpg
share/nip2/data/examples/overlays_and_blending/blend_example_vis.jpg
@@ -21,14 +12,6 @@ share/nip2/data/examples/manual_balance/simp_base.png
share/nip2/data/examples/manual_balance/mask_03.png
share/nip2/data/examples/manual_balance/mask_control.png
share/nip2/data/examples/manual_balance/manual_balance.ws
-share/nip2/data/examples/2_point_mosiac/example_im_02.jpg
-share/nip2/data/examples/2_point_mosiac/example_im_04.jpg
-share/nip2/data/examples/2_point_mosiac/example_im_03.jpg
-share/nip2/data/examples/2_point_mosiac/full_image.jpg
-share/nip2/data/examples/2_point_mosiac/example_im_01.jpg
-share/nip2/data/examples/2_point_mosiac/example_im_05.jpg
-share/nip2/data/examples/2_point_mosiac/example_im_06.jpg
-share/nip2/data/examples/2_point_mosiac/2pts_mosaic.ws
share/nip2/data/examples/registering/example_im_2.jpg
share/nip2/data/examples/registering/registering.ws
share/nip2/data/examples/registering/example_im_1.jpg
@@ -166,13 +149,90 @@ share/nip2/compat/7.12/_list.def
share/nip2/compat/7.12/_predicate.def
share/nip2/compat/7.12/_stdenv.def
share/nip2/compat/7.12/_types.def
+share/nip2/compat/7.14/Colour.def
+share/nip2/compat/7.14/Filter.def
+share/nip2/compat/7.14/Histogram.def
+share/nip2/compat/7.14/Image.def
+share/nip2/compat/7.14/Math.def
+share/nip2/compat/7.14/Matrix.def
+share/nip2/compat/7.14/Object.def
+share/nip2/compat/7.14/Preferences.ws
+share/nip2/compat/7.14/Tasks.def
+share/nip2/compat/7.14/Widgets.def
+share/nip2/compat/7.14/_Object.def
+share/nip2/compat/7.14/_convert.def
+share/nip2/compat/7.14/_generate.def
+share/nip2/compat/7.14/_joe_extra.def
+share/nip2/compat/7.14/_joe_utilities.def
+share/nip2/compat/7.14/_list.def
+share/nip2/compat/7.14/_predicate.def
+share/nip2/compat/7.14/_stdenv.def
+share/nip2/compat/7.14/_types.def
+share/nip2/compat/7.16/Colour.def
+share/nip2/compat/7.16/Filter.def
+share/nip2/compat/7.16/Histogram.def
+share/nip2/compat/7.16/Image.def
+share/nip2/compat/7.16/Math.def
+share/nip2/compat/7.16/Matrix.def
+share/nip2/compat/7.16/Object.def
+share/nip2/compat/7.16/Preferences.ws
+share/nip2/compat/7.16/Tasks.def
+share/nip2/compat/7.16/Widgets.def
+share/nip2/compat/7.16/_Object.def
+share/nip2/compat/7.16/_convert.def
+share/nip2/compat/7.16/_generate.def
+share/nip2/compat/7.16/_joe_extra.def
+share/nip2/compat/7.16/_joe_utilities.def
+share/nip2/compat/7.16/_list.def
+share/nip2/compat/7.16/_predicate.def
+share/nip2/compat/7.16/_stdenv.def
+share/nip2/compat/7.16/_types.def
+share/nip2/compat/7.24/Colour.def
+share/nip2/compat/7.24/Filter.def
+share/nip2/compat/7.24/Histogram.def
+share/nip2/compat/7.24/Image.def
+share/nip2/compat/7.24/Math.def
+share/nip2/compat/7.24/Matrix.def
+share/nip2/compat/7.24/Object.def
+share/nip2/compat/7.24/Preferences.ws
+share/nip2/compat/7.24/Tasks.def
+share/nip2/compat/7.24/Widgets.def
+share/nip2/compat/7.24/_Object.def
+share/nip2/compat/7.24/_convert.def
+share/nip2/compat/7.24/_generate.def
+share/nip2/compat/7.24/_joe_extra.def
+share/nip2/compat/7.24/_joe_utilities.def
+share/nip2/compat/7.24/_list.def
+share/nip2/compat/7.24/_predicate.def
+share/nip2/compat/7.24/_stdenv.def
+share/nip2/compat/7.24/_types.def
+share/nip2/data/examples/1_point_mosaic/1pt_mosaic.ws
+share/nip2/data/examples/1_point_mosaic/cd1.1.jpg
+share/nip2/data/examples/1_point_mosaic/cd1.2.jpg
+share/nip2/data/examples/1_point_mosaic/cd2.1.jpg
+share/nip2/data/examples/1_point_mosaic/cd2.2.jpg
+share/nip2/data/examples/1_point_mosaic/cd3.1.jpg
+share/nip2/data/examples/1_point_mosaic/cd3.2.jpg
+share/nip2/data/examples/1_point_mosaic/cd4.1.jpg
+share/nip2/data/examples/1_point_mosaic/cd4.2.jpg
+@dirrm share/nip2/data/examples/1_point_mosaic
+share/nip2/data/examples/2_point_mosaic/2pts_mosaic.ws
+share/nip2/data/examples/2_point_mosaic/example_im_01.jpg
+share/nip2/data/examples/2_point_mosaic/example_im_02.jpg
+share/nip2/data/examples/2_point_mosaic/example_im_03.jpg
+share/nip2/data/examples/2_point_mosaic/example_im_04.jpg
+share/nip2/data/examples/2_point_mosaic/example_im_05.jpg
+share/nip2/data/examples/2_point_mosaic/example_im_06.jpg
+share/nip2/data/examples/2_point_mosaic/full_image.jpg
+@dirrm share/nip2/data/examples/2_point_mosaic
@dirrm share/nip2/compat/7.8
@dirrm share/nip2/compat/7.9
@dirrm share/nip2/compat/7.10
@dirrm share/nip2/compat/7.12
+@dirrm share/nip2/compat/7.14
+@dirrm share/nip2/compat/7.16
+@dirrm share/nip2/compat/7.24
@dirrm share/nip2/compat
-@dirrm share/nip2/data/examples/1_point_mosiac
-@dirrm share/nip2/data/examples/2_point_mosiac
@dirrm share/nip2/data/examples/businesscard
@dirrm share/nip2/data/examples/clone
@dirrm share/nip2/data/examples/framing