aboutsummaryrefslogtreecommitdiff
path: root/graphics/ogre3d
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-10-03 18:33:01 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-10-03 18:33:01 +0000
commit3fb5ed5e659d2f4902f91df4b74cde8e8e76914a (patch)
treeb63269bf120f94975a685a6374e6823aac565dee /graphics/ogre3d
parent57d3e544f480a10c5c9f7e3faa70fd8b62e61a36 (diff)
downloadports-3fb5ed5e659d2f4902f91df4b74cde8e8e76914a.tar.gz
ports-3fb5ed5e659d2f4902f91df4b74cde8e8e76914a.zip
OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented, flexible
3D engine written in C++ designed to make it easier and more intuitive for developers to produce games and demos utilising 3D hardware. WWW: http://www.cegui.org.uk/
Notes
Notes: svn path=/head/; revision=144095
Diffstat (limited to 'graphics/ogre3d')
-rw-r--r--graphics/ogre3d/Makefile66
-rw-r--r--graphics/ogre3d/distinfo2
-rw-r--r--graphics/ogre3d/pkg-descr8
-rw-r--r--graphics/ogre3d/pkg-plist227
4 files changed, 303 insertions, 0 deletions
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
new file mode 100644
index 000000000000..3415fd6b26dd
--- /dev/null
+++ b/graphics/ogre3d/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: ogre3d
+# Date created: 03 Oct 2005
+# Whom: Oliver Lehmann <oliver@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ogre3d
+PORTVERSION= 1.0.5
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=ogre
+DISTNAME= ogre-linux_osx-v1-0-5
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= A scene-oriented, flexible 3D engine written in C++
+
+LIB_DEPENDS= zzip.10:${PORTSDIR}/devel/zziplib \
+ CEGUIBase.0:${PORTSDIR}/graphics/cegui
+
+WRKSRC= ${WRKDIR}/ogrenew
+CONFIGURE_ARGS= --disable-cg --program-transform-name=
+USE_REINPLACE= YES
+USE_LIBTOOL_VER=13
+GNU_CONFIGURE= YES
+INSTALLS_SHLIB= YES
+USE_GCC= 3.4
+USE_BZIP2= YES
+USE_X_PREFIX= YES
+USE_GNOME= gnomehack
+USE_SDL= sdl
+USE_GMAKE= YES
+
+post-patch:
+ @${REINPLACE_CMD} -e '\
+ s|sdl-config|${SDL_CONFIG}|g ;\
+ s|-lpthread|${PTHREAD_LIBS}|g; \
+ s|"-lIL|"-L${LOCALBASE}/lib -lIL|g; \
+ s|-lGL -lGLU|-L${X11BASE}/lib &|g; \
+ s|GLSUPPORT_CFLAGS=\$$SDL_CFLAGS|GLSUPPORT_CFLAGS="-I${X11BASE}/include \$$SDL_CFLAGS"|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '\
+ s|\(-L$$(top_builddir)/OgreMain/src\)\([$$ ]*\)|\1/.libs\2|; \
+ s|\$$(INSTALL_PROGRAM) .libs/|\$$(INSTALL_PROGRAM) |' \
+ ${WRKSRC}/Samples/*/src/Makefile.in \
+ ${WRKSRC}/Tools/*/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|-L$$(top_builddir)/Samples/Common/CEGUIRenderer/src|&/.libs|' \
+ ${WRKSRC}/Samples/Gui/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|<CEGUI/|<|g' \
+ ${WRKSRC}/Samples/Gui/src/Gui.cpp \
+ ${WRKSRC}/Samples/Common/CEGUIRenderer/include/OgreCEGUIResourceProvider.h \
+ ${WRKSRC}/Samples/Common/CEGUIRenderer/include/OgreCEGUITexture.h \
+ ${WRKSRC}/Samples/Common/CEGUIRenderer/include/OgreCEGUIRenderer.h \
+ ${WRKSRC}/Samples/Common/CEGUIRenderer/src/OgreCEGUIRenderer.cpp \
+ ${WRKSRC}/Samples/Common/CEGUIRenderer/src/OgreCEGUIResourceProvider.cpp \
+ ${WRKSRC}/Samples/Common/CEGUIRenderer/src/OgreCEGUITexture.cpp
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docfile in README COPYING AUTHORS ChangeLog
+ @${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/ogre3d/distinfo b/graphics/ogre3d/distinfo
new file mode 100644
index 000000000000..5a3a66e23b21
--- /dev/null
+++ b/graphics/ogre3d/distinfo
@@ -0,0 +1,2 @@
+MD5 (ogre-linux_osx-v1-0-5.tar.bz2) = 8e7dcdd3c64fd921277c7161f914e607
+SIZE (ogre-linux_osx-v1-0-5.tar.bz2) = 19132245
diff --git a/graphics/ogre3d/pkg-descr b/graphics/ogre3d/pkg-descr
new file mode 100644
index 000000000000..34c8cbfc4a5a
--- /dev/null
+++ b/graphics/ogre3d/pkg-descr
@@ -0,0 +1,8 @@
+OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented, flexible
+3D engine written in C++ designed to make it easier and more intuitive for
+developers to produce games and demos utilising 3D hardware. The class library
+abstracts all the details of using the underlying system libraries like
+Direct3D and OpenGL and provides an interface based on world objects and other
+intuitive classes.
+
+WWW: http://www.ogre3d.org/
diff --git a/graphics/ogre3d/pkg-plist b/graphics/ogre3d/pkg-plist
new file mode 100644
index 000000000000..e197ca188eb4
--- /dev/null
+++ b/graphics/ogre3d/pkg-plist
@@ -0,0 +1,227 @@
+bin/OgreMaterialUpgrade
+bin/OgreMeshUpgrade
+bin/OgreXMLConverter
+include/OGRE/Ogre.h
+include/OGRE/OgreAnimation.h
+include/OGRE/OgreAnimationState.h
+include/OGRE/OgreAnimationTrack.h
+include/OGRE/OgreArchive.h
+include/OGRE/OgreArchiveFactory.h
+include/OGRE/OgreArchiveManager.h
+include/OGRE/OgreAutoParamDataSource.h
+include/OGRE/OgreAxisAlignedBox.h
+include/OGRE/OgreBillboard.h
+include/OGRE/OgreBillboardParticleRenderer.h
+include/OGRE/OgreBillboardSet.h
+include/OGRE/OgreBitwise.h
+include/OGRE/OgreBlendMode.h
+include/OGRE/OgreBone.h
+include/OGRE/OgreBorderPanelOverlayElement.h
+include/OGRE/OgreCEGUIRenderer.h
+include/OGRE/OgreCEGUIResourceProvider.h
+include/OGRE/OgreCEGUITexture.h
+include/OGRE/OgreCamera.h
+include/OGRE/OgreCodec.h
+include/OGRE/OgreColourValue.h
+include/OGRE/OgreCommon.h
+include/OGRE/OgreConfig.h
+include/OGRE/OgreConfigDialog.h
+include/OGRE/OgreConfigFile.h
+include/OGRE/OgreConfigOptionMap.h
+include/OGRE/OgreController.h
+include/OGRE/OgreControllerManager.h
+include/OGRE/OgreCursor.h
+include/OGRE/OgreDataStream.h
+include/OGRE/OgreDefaultHardwareBufferManager.h
+include/OGRE/OgreDynLib.h
+include/OGRE/OgreDynLibManager.h
+include/OGRE/OgreEdgeListBuilder.h
+include/OGRE/OgreEntity.h
+include/OGRE/OgreErrorDialog.h
+include/OGRE/OgreEventDispatcher.h
+include/OGRE/OgreEventListeners.h
+include/OGRE/OgreEventProcessor.h
+include/OGRE/OgreEventQueue.h
+include/OGRE/OgreEventTarget.h
+include/OGRE/OgreException.h
+include/OGRE/OgreExternalTextureSource.h
+include/OGRE/OgreExternalTextureSourceManager.h
+include/OGRE/OgreFactoryObj.h
+include/OGRE/OgreFileSystem.h
+include/OGRE/OgreFont.h
+include/OGRE/OgreFontManager.h
+include/OGRE/OgreFrameListener.h
+include/OGRE/OgreFrustum.h
+include/OGRE/OgreGpuProgram.h
+include/OGRE/OgreGpuProgramManager.h
+include/OGRE/OgreGpuProgramUsage.h
+include/OGRE/OgreHardwareBuffer.h
+include/OGRE/OgreHardwareBufferManager.h
+include/OGRE/OgreHardwareIndexBuffer.h
+include/OGRE/OgreHardwareOcclusionQuery.h
+include/OGRE/OgreHardwarePixelBuffer.h
+include/OGRE/OgreHardwareVertexBuffer.h
+include/OGRE/OgreHighLevelGpuProgram.h
+include/OGRE/OgreHighLevelGpuProgramManager.h
+include/OGRE/OgreILCodecs.h
+include/OGRE/OgreILImageCodec.h
+include/OGRE/OgreImage.h
+include/OGRE/OgreImageCodec.h
+include/OGRE/OgreInput.h
+include/OGRE/OgreInputEvent.h
+include/OGRE/OgreIteratorWrappers.h
+include/OGRE/OgreKeyEvent.h
+include/OGRE/OgreKeyFrame.h
+include/OGRE/OgreKeyTarget.h
+include/OGRE/OgreLight.h
+include/OGRE/OgreLog.h
+include/OGRE/OgreLogManager.h
+include/OGRE/OgreMaterial.h
+include/OGRE/OgreMaterialManager.h
+include/OGRE/OgreMaterialSerializer.h
+include/OGRE/OgreMath.h
+include/OGRE/OgreMatrix3.h
+include/OGRE/OgreMatrix4.h
+include/OGRE/OgreMemoryMacros.h
+include/OGRE/OgreMemoryManager.h
+include/OGRE/OgreMesh.h
+include/OGRE/OgreMeshFileFormat.h
+include/OGRE/OgreMeshManager.h
+include/OGRE/OgreMeshSerializer.h
+include/OGRE/OgreMeshSerializerImpl.h
+include/OGRE/OgreMouseEvent.h
+include/OGRE/OgreMouseMotionTarget.h
+include/OGRE/OgreMouseTarget.h
+include/OGRE/OgreMovableObject.h
+include/OGRE/OgreMovablePlane.h
+include/OGRE/OgreNoMemoryMacros.h
+include/OGRE/OgreNode.h
+include/OGRE/OgreOverlay.h
+include/OGRE/OgreOverlayContainer.h
+include/OGRE/OgreOverlayElement.h
+include/OGRE/OgreOverlayElementCommands.h
+include/OGRE/OgreOverlayElementFactory.h
+include/OGRE/OgreOverlayManager.h
+include/OGRE/OgrePanelOverlayElement.h
+include/OGRE/OgreParticle.h
+include/OGRE/OgreParticleAffector.h
+include/OGRE/OgreParticleAffectorFactory.h
+include/OGRE/OgreParticleEmitter.h
+include/OGRE/OgreParticleEmitterCommands.h
+include/OGRE/OgreParticleEmitterFactory.h
+include/OGRE/OgreParticleIterator.h
+include/OGRE/OgreParticleSystem.h
+include/OGRE/OgreParticleSystemManager.h
+include/OGRE/OgreParticleSystemRenderer.h
+include/OGRE/OgrePass.h
+include/OGRE/OgrePatchMesh.h
+include/OGRE/OgrePatchSurface.h
+include/OGRE/OgrePixelFormat.h
+include/OGRE/OgrePlane.h
+include/OGRE/OgrePlaneBoundedVolume.h
+include/OGRE/OgrePlatform.h
+include/OGRE/OgrePlatformManager.h
+include/OGRE/OgrePositionTarget.h
+include/OGRE/OgrePredefinedControllers.h
+include/OGRE/OgrePrerequisites.h
+include/OGRE/OgreProfiler.h
+include/OGRE/OgreProgressiveMesh.h
+include/OGRE/OgreQuaternion.h
+include/OGRE/OgreRay.h
+include/OGRE/OgreRectangle.h
+include/OGRE/OgreRectangle2D.h
+include/OGRE/OgreRenderOperation.h
+include/OGRE/OgreRenderQueue.h
+include/OGRE/OgreRenderQueueListener.h
+include/OGRE/OgreRenderQueueSortingGrouping.h
+include/OGRE/OgreRenderSystem.h
+include/OGRE/OgreRenderSystemCapabilities.h
+include/OGRE/OgreRenderTarget.h
+include/OGRE/OgreRenderTargetListener.h
+include/OGRE/OgreRenderTargetTexture.h
+include/OGRE/OgreRenderTexture.h
+include/OGRE/OgreRenderWindow.h
+include/OGRE/OgreRenderable.h
+include/OGRE/OgreResource.h
+include/OGRE/OgreResourceBackgroundQueue.h
+include/OGRE/OgreResourceGroupManager.h
+include/OGRE/OgreResourceManager.h
+include/OGRE/OgreRoot.h
+include/OGRE/OgreRotationalSpline.h
+include/OGRE/OgreSceneManager.h
+include/OGRE/OgreSceneManagerEnumerator.h
+include/OGRE/OgreSceneNode.h
+include/OGRE/OgreSceneQuery.h
+include/OGRE/OgreScriptLoader.h
+include/OGRE/OgreSearchOps.h
+include/OGRE/OgreSerializer.h
+include/OGRE/OgreShadowCaster.h
+include/OGRE/OgreShadowVolumeExtrudeProgram.h
+include/OGRE/OgreSharedPtr.h
+include/OGRE/OgreSimpleRenderable.h
+include/OGRE/OgreSimpleSpline.h
+include/OGRE/OgreSingleton.h
+include/OGRE/OgreSkeleton.h
+include/OGRE/OgreSkeletonFileFormat.h
+include/OGRE/OgreSkeletonInstance.h
+include/OGRE/OgreSkeletonManager.h
+include/OGRE/OgreSkeletonSerializer.h
+include/OGRE/OgreSphere.h
+include/OGRE/OgreSpotShadowFadePng.h
+include/OGRE/OgreStableHeaders.h
+include/OGRE/OgreStaticFaceGroup.h
+include/OGRE/OgreStaticGeometry.h
+include/OGRE/OgreStdHeaders.h
+include/OGRE/OgreString.h
+include/OGRE/OgreStringConverter.h
+include/OGRE/OgreStringInterface.h
+include/OGRE/OgreStringVector.h
+include/OGRE/OgreSubEntity.h
+include/OGRE/OgreSubMesh.h
+include/OGRE/OgreTagPoint.h
+include/OGRE/OgreTargetManager.h
+include/OGRE/OgreTechnique.h
+include/OGRE/OgreTextAreaOverlayElement.h
+include/OGRE/OgreTexture.h
+include/OGRE/OgreTextureManager.h
+include/OGRE/OgreTextureUnitState.h
+include/OGRE/OgreTimer.h
+include/OGRE/OgreUserDefinedObject.h
+include/OGRE/OgreVector2.h
+include/OGRE/OgreVector3.h
+include/OGRE/OgreVector4.h
+include/OGRE/OgreVertexBoneAssignment.h
+include/OGRE/OgreVertexIndexData.h
+include/OGRE/OgreViewport.h
+include/OGRE/OgreWireBoundingBox.h
+include/OGRE/OgreZip.h
+include/OGRE/asm_math.h
+lib/OGRE/Plugin_BSPSceneManager.a
+lib/OGRE/Plugin_BSPSceneManager.la
+lib/OGRE/Plugin_OctreeSceneManager.a
+lib/OGRE/Plugin_OctreeSceneManager.la
+lib/OGRE/Plugin_ParticleFX.a
+lib/OGRE/Plugin_ParticleFX.la
+lib/OGRE/RenderSystem_GL.a
+lib/OGRE/RenderSystem_GL.la
+lib/libCEGUIOgreRenderer.a
+lib/libCEGUIOgreRenderer.la
+lib/libCEGUIOgreRenderer.so
+lib/libCEGUIOgreRenderer.so.0
+lib/libOgreMain.a
+lib/libOgreMain.la
+lib/libOgreMain.so
+lib/libOgreMain.so.9
+lib/libOgrePlatform.a
+lib/libOgrePlatform.la
+libdata/pkgconfig/CEGUI-OGRE.pc
+libdata/pkgconfig/OGRE.pc
+share/OGRE/ogre-config.glade
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+@dirrm include/OGRE
+@dirrm lib/OGRE
+@dirrm share/OGRE
+%%PORTDOCS%%@dirrm %%DOCSDIR%%