aboutsummaryrefslogtreecommitdiff
path: root/graphics/ogre3d
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-10-05 18:21:06 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-10-05 18:21:06 +0000
commit6549f0d5c1cf00193d6ff208af06fa7124be1bcb (patch)
tree2997d494c988fd2057d6ac2e1c81b70b0b994434 /graphics/ogre3d
parent4ba65cef22a2c17390795ccf032a2f8c61a51864 (diff)
downloadports-6549f0d5c1cf00193d6ff208af06fa7124be1bcb.tar.gz
ports-6549f0d5c1cf00193d6ff208af06fa7124be1bcb.zip
fix an error so the plugin libs are generated as shared libs and not as
static ones bump PORTREVISION
Notes
Notes: svn path=/head/; revision=144332
Diffstat (limited to 'graphics/ogre3d')
-rw-r--r--graphics/ogre3d/Makefile8
-rw-r--r--graphics/ogre3d/pkg-plist10
2 files changed, 13 insertions, 5 deletions
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index f13a20c0e746..01143c28705e 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ogre3d
PORTVERSION= 1.0.5
+PORTREVISION= 1
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=ogre
@@ -44,6 +45,13 @@ post-patch:
s|\$$(INSTALL_PROGRAM) .libs/|\$$(INSTALL_PROGRAM) |' \
${WRKSRC}/Samples/*/src/Makefile.in \
${WRKSRC}/Tools/*/src/Makefile.in
+ @${REINPLACE_CMD} -e '\
+ s|\(-L$$(top_builddir)/OgreMain/src\)\([$$ ]*\)|\1/.libs\2|' \
+ ${WRKSRC}/PlugIns/BSPSceneManager/src/Makefile.in \
+ ${WRKSRC}/PlugIns/CgProgramManager/src/Makefile.in \
+ ${WRKSRC}/PlugIns/EXRCodec/src/Makefile.in \
+ ${WRKSRC}/PlugIns/OctreeSceneManager/src/Makefile.in \
+ ${WRKSRC}/PlugIns/ParticleFX/src/Makefile.in
@${REINPLACE_CMD} -e 's|-L$$(top_builddir)/Samples/Common/CEGUIRenderer/src|&/.libs|' \
${WRKSRC}/Samples/Gui/src/Makefile.in
@${REINPLACE_CMD} -e 's|<CEGUI/|<|g' \
diff --git a/graphics/ogre3d/pkg-plist b/graphics/ogre3d/pkg-plist
index e197ca188eb4..2509405fa622 100644
--- a/graphics/ogre3d/pkg-plist
+++ b/graphics/ogre3d/pkg-plist
@@ -196,14 +196,14 @@ include/OGRE/OgreViewport.h
include/OGRE/OgreWireBoundingBox.h
include/OGRE/OgreZip.h
include/OGRE/asm_math.h
-lib/OGRE/Plugin_BSPSceneManager.a
lib/OGRE/Plugin_BSPSceneManager.la
-lib/OGRE/Plugin_OctreeSceneManager.a
+lib/OGRE/Plugin_BSPSceneManager.so
lib/OGRE/Plugin_OctreeSceneManager.la
-lib/OGRE/Plugin_ParticleFX.a
+lib/OGRE/Plugin_OctreeSceneManager.so
lib/OGRE/Plugin_ParticleFX.la
-lib/OGRE/RenderSystem_GL.a
+lib/OGRE/Plugin_ParticleFX.so
lib/OGRE/RenderSystem_GL.la
+lib/OGRE/RenderSystem_GL.so
lib/libCEGUIOgreRenderer.a
lib/libCEGUIOgreRenderer.la
lib/libCEGUIOgreRenderer.so
@@ -212,8 +212,8 @@ lib/libOgreMain.a
lib/libOgreMain.la
lib/libOgreMain.so
lib/libOgreMain.so.9
-lib/libOgrePlatform.a
lib/libOgrePlatform.la
+lib/libOgrePlatform.so
libdata/pkgconfig/CEGUI-OGRE.pc
libdata/pkgconfig/OGRE.pc
share/OGRE/ogre-config.glade