aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencv
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-08-18 10:51:01 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-08-18 10:51:01 +0000
commit23ee2a7d628e74980199fb95b27ce242a5f718a6 (patch)
treece0de1d0b7bda5eb762e64fe58300177d350898c /graphics/opencv
parentb95ee05497bd32b93280aec9b333ab635f3d381e (diff)
downloadports-23ee2a7d628e74980199fb95b27ce242a5f718a6.tar.gz
ports-23ee2a7d628e74980199fb95b27ce242a5f718a6.zip
Uses/cmake.mk: Replace CMAKE_ENV with CONFIGURE_ENV.
Instead of defining a variable that is almost always based on CONFIGURE_ENV, just use CONFIGURE_ENV directly. This also matches the behavior of other ports that do not use autotools (so most ports can just worry about CONFIGURE_ENV). Additionally, the fact that we do not use ?= means we do not have problems if another file in Uses/ needs to set CONFIGURE_ENV (with CMAKE_ENV, the order of the arguments to USES would matter). Ports which set CMAKE_ENV have been adjusted accordingly. In most cases, CMAKE_ENV was just replaced with CONFIGURE_ENV, the exceptions being: * databases/sqliteman: CMAKE_ENV line removed; setting QMAKESPEC there has no effect on the build system. * devel/freeocl: CMAKE_ENV line removed; FREEOCL_CXX_COMPILER is already retrieved from the CMAKE_CXX_COMPILER variable in the build system. * graphics/openimageio: CMAKE_ENV line removed; setting Qt variables there has no effect on the build system. Reviewed by: makc Differential Revision: https://reviews.freebsd.org/D3403
Notes
Notes: svn path=/head/; revision=394572
Diffstat (limited to 'graphics/opencv')
-rw-r--r--graphics/opencv/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index f12498fd389d..acc1e3699580 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -243,7 +243,7 @@ CMAKE_ARGS+= -DBUILD_opencv_java:BOOL=On
. for module in apps python stitching superres videostab
CMAKE_ARGS+= -DBUILD_opencv_${module}:BOOL=Off
. endfor
-CMAKE_ENV+= JAVA_HOME="${JAVA_HOME}"
+CONFIGURE_ENV+= JAVA_HOME="${JAVA_HOME}"
INSTALL_WRKSRC= ${WRKSRC}/modules/java
.else
LIB_DEPENDS+= libopencv_core.so:${PORTSDIR}/graphics/opencv-core