aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencv
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-08-10 20:35:10 +0000
committerJohn Marino <marino@FreeBSD.org>2013-08-10 20:35:10 +0000
commitb6386755cdd40a4fab25bf47d779493b3aa2c1e6 (patch)
treea5de7981b3b9b97c429c53a71fe15119d73cc8e0 /graphics/opencv
parent8964260749eb7e48a38193bef53ced8c0f54f947 (diff)
downloadports-b6386755cdd40a4fab25bf47d779493b3aa2c1e6.tar.gz
ports-b6386755cdd40a4fab25bf47d779493b3aa2c1e6.zip
graphics/opencv: continue recent binutils fix
This cleans up the previous commit, and combines the LDFLAGS. It's more logical this way, right after opencv_core is specified in LIB_DEPENDS. Approved by: bapt/culot (mentors, implicit)
Notes
Notes: svn path=/head/; revision=324558
Diffstat (limited to 'graphics/opencv')
-rw-r--r--graphics/opencv/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 051234049272..c3ff7de9efc9 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -32,7 +32,7 @@ PLIST_SUB+= VERSION=${DISTVERSION}
.if !defined(_BUILDING_OPENCV_CORE) && !defined(_BUILDING_OPENCV_PYTHON)
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-opencv
LIB_DEPENDS+= opencv_core.2:${PORTSDIR}/graphics/opencv-core
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -lopencv_core
PORTDOCS= *
@@ -43,8 +43,6 @@ GTK_DESC= GTK+ support
OPENEXR_DESC= OpenEXR support
TBB_DESC= TBB support
-LDFLAGS+= -lopencv_core
-
OPTIONS_DEFAULT= EIGEN2 JASPER JPEG PNG TIFF V4L
.include <bsd.port.options.mk>