aboutsummaryrefslogtreecommitdiff
path: root/graphics/opendx/Makefile
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2013-08-16 23:43:28 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2013-08-16 23:43:28 +0000
commitf7070a06b6780eb29481082f5482d184ad71dab5 (patch)
tree491b0ce1ddbd3d7f3a81b64d29a50e459dad4569 /graphics/opendx/Makefile
parentae3413e2cb46bfc826cf49218e338ab771981dd6 (diff)
downloadports-f7070a06b6780eb29481082f5482d184ad71dab5.tar.gz
ports-f7070a06b6780eb29481082f5482d184ad71dab5.zip
- Change dependency science/netcdf to science/netcdf4.
- Fix some portlint errors.
Notes
Notes: svn path=/head/; revision=324824
Diffstat (limited to 'graphics/opendx/Makefile')
-rw-r--r--graphics/opendx/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index ebacb3489b8b..cdeb1efa2872 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opendx
PORTVERSION= 4.4.4
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics math
MASTER_SITES= http://www.sfr-fresh.com/unix/misc/
DISTNAME= dx-${PORTVERSION}
@@ -12,10 +12,10 @@ MAINTAINER= stephen@FreeBSD.org
COMMENT= IBM's Open Visualization Data Explorer
LIB_DEPENDS= MagickWand:${PORTSDIR}/graphics/ImageMagick \
- tiff.4:${PORTSDIR}/graphics/tiff \
- cdf.0:${PORTSDIR}/science/cdf
+ tiff:${PORTSDIR}/graphics/tiff \
+ cdf:${PORTSDIR}/science/cdf
-USE_XORG= xinerama xext xpm xmu sm ice
+USE_XORG= xinerama xext xpm xmu sm ice
USES= bison motif gmake
USE_GCC= any
USE_GL= yes
@@ -33,13 +33,13 @@ IGNORE= HDF and NETCDF are conflicting
.endif
.if defined(WITH_HDF)
-LIB_DEPENDS+= mfhdf.3:${PORTSDIR}/science/hdf
+LIB_DEPENDS+= mfhdf:${PORTSDIR}/science/hdf
.else
CONFIGURE_ARGS+= --without-hdf
.endif
.if !defined(WITHOUT_NETCDF)
-LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
+LIB_DEPENDS+= netcdf:${PORTSDIR}/science/netcdf4
.else
CONFIGURE_ARGS+= --without-netcdf
.endif