aboutsummaryrefslogtreecommitdiff
path: root/graphics/osg-devel
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-01 02:49:31 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-01 02:49:31 +0000
commitd8b469805f55d02945510c32a1190aed04eef3cf (patch)
treec4d15a3d87074450510f4d1fc488603c39f008cc /graphics/osg-devel
parent583e279a73200fbf64a89bcd97a0c07b3b24461a (diff)
downloadports-d8b469805f55d02945510c32a1190aed04eef3cf.tar.gz
ports-d8b469805f55d02945510c32a1190aed04eef3cf.zip
- Update to 2.9.2
- Add CONFLICTS with osg - Mark MAKE_JOBS_SAFE
Notes
Notes: svn path=/head/; revision=231424
Diffstat (limited to 'graphics/osg-devel')
-rw-r--r--graphics/osg-devel/Makefile33
-rw-r--r--graphics/osg-devel/distinfo6
-rw-r--r--graphics/osg-devel/files/patch-src-osgViewer-CMakeLists.txt11
-rw-r--r--graphics/osg-devel/pkg-plist7
4 files changed, 33 insertions, 24 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index 3470c5b095d5..592be64f9716 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= osg
-PORTVERSION= 2.7.9
-PORTREVISION= 1
+PORTVERSION= 2.9.2
CATEGORIES= graphics
MASTER_SITES= http://www.openscenegraph.org/downloads/developer_releases/ \
http://mirror.amdmi3.ru/
-DISTNAME= OpenSceneGraph-${PORTVERSION}
PKGNAMESUFFIX= -devel
+DISTNAME= OpenSceneGraph-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= C++ OpenGL scene graph library for real-time rendering
@@ -21,16 +20,19 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
+CONFLICTS= osg-[0-9]*
+
USE_ZIP= yes
USE_CMAKE= yes
USE_GL= gl glu
USE_GNOME= pkgconfig
USE_XORG= x11
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
PLIST_SUB= OSG_VERSION=${PORTVERSION} \
- OSG_SHLIBVER=54 \
- OPENTHREADS_VERSION=2.3.1 \
+ OSG_SHLIBVER=57 \
+ OPENTHREADS_VERSION=2.4.0 \
OPENTHREADS_SHLIBVER=11
PORTSCOUT= limitw:1,odd
@@ -45,20 +47,21 @@ OPTIONS= CURL "Support for cURL" off \
ITK "Support for InsightToolkit" off \
VNC "Support for LibVNCServer" off \
OPENEXR "Support for OpenEXR" off \
+ FFMPEG "Support for FFmpeg" off \
SVG "Support for SVG through librsvg2" off \
PDF "Support for PDF through poppler" off \
XRANDR "Use Xrandr" on
-# broken
+# broken (openvrml from ports is too old)
# OPENVRML "Support for OpenVRML" off
.include <bsd.port.pre.mk>
# GUI toolkits are only needed for building examples, which are not even installed
-FORCE_IGNORE= FLTK GLUT SDL FOX Qt3 Qt4 wxWidgets # only needed for examples
-FORCE_IGNORE+= COLLADA Performer OurDCMTK XUL # not in ports (yet?)
-FORCE_REQUIRE= Threads OpenGL X11 JPEG PNG TIFF ZLIB # common and lightweight
-FORCE_PC_IGNORE= GTK GTKGL # only needed for examples
+FORCE_IGNORE= FLTK GLUT SDL FOX Qt3 Qt4 wxWidgets OpenAL # only for examples
+FORCE_IGNORE+= COLLADA Performer OurDCMTK XUL # not in ports
+FORCE_REQUIRE= Threads OpenGL X11 JPEG PNG TIFF ZLIB # common & lightweight
+FORCE_PC_IGNORE= GTK GTKGL # only for examples
FORCE_PC_REQUIRE=
# options that affect FIND_PACKAGE
@@ -140,6 +143,7 @@ FORCE_REQUIRE+= ITK
BUILD_DEPENDS+= ${LOCALBASE}/lib/InsightToolkit/UseITK.cmake:${PORTSDIR}/science/InsightToolkit
RUN_DEPENDS+= ${LOCALBASE}/lib/InsightToolkit/UseITK.cmake:${PORTSDIR}/science/InsightToolkit
PLIST_SUB+= ITK=""
+CXXFLAGS+= -DVCL_CAN_STATIC_CONST_INIT_FLOAT=0
.else
FORCE_IGNORE+= ITK
PLIST_SUB+= ITK="@comment "
@@ -163,6 +167,15 @@ FORCE_IGNORE+= OpenEXR
PLIST_SUB+= OPENEXR="@comment "
.endif
+.if defined(WITH_FFMPEG)
+FORCE_REQUIRE+= FFmpeg
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+PLIST_SUB+= FFMPEG=""
+.else
+FORCE_IGNORE+= FFmpeg
+PLIST_SUB+= FFMPEG="@comment "
+.endif
+
# options that affect PKG_CHECK_MODULES
.if defined(WITH_SVG)
FORCE_PC_REQUIRE+=RSVG
diff --git a/graphics/osg-devel/distinfo b/graphics/osg-devel/distinfo
index acdf818b2f8b..52c67ec8e875 100644
--- a/graphics/osg-devel/distinfo
+++ b/graphics/osg-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (OpenSceneGraph-2.7.9.zip) = 14629ae17c6a5207630713608d7f3c56
-SHA256 (OpenSceneGraph-2.7.9.zip) = bb2248b65ea6ff1a7f865f28e8b421951ac3d1623dc0ab10ebf30665e10992fb
-SIZE (OpenSceneGraph-2.7.9.zip) = 6702867
+MD5 (OpenSceneGraph-2.9.2.zip) = b15e0864fefbd37b071c545dd1760e90
+SHA256 (OpenSceneGraph-2.9.2.zip) = afa9323808dd4da08fa53f50d7cd257d05cd0a6436ac2c6238791fca03ca4d02
+SIZE (OpenSceneGraph-2.9.2.zip) = 6813410
diff --git a/graphics/osg-devel/files/patch-src-osgViewer-CMakeLists.txt b/graphics/osg-devel/files/patch-src-osgViewer-CMakeLists.txt
deleted file mode 100644
index 6d00269d1bcc..000000000000
--- a/graphics/osg-devel/files/patch-src-osgViewer-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/osgViewer/CMakeLists.txt.orig 2009-01-26 16:48:50.000000000 +0300
-+++ src/osgViewer/CMakeLists.txt 2009-02-04 19:00:45.000000000 +0300
-@@ -117,7 +117,7 @@
- IF(OSGVIEWER_USE_XRANDR)
- ADD_DEFINITIONS(-DOSGVIEWER_USE_XRANDR)
- SET(LIB_PRIVATE_HEADERS ${LIB_PRIVATE_HEADERS} ${XRANDR_INCLUDE_DIRS} )
-- LINK_LIBRARIES(Xrandr)
-+ LINK_LIBRARIES(${XRANDR_LDFLAGS})
- ENDIF(OSGVIEWER_USE_XRANDR)
-
- # X11 on Apple requires X11 library plus OpenGL linking hack on Leopard
diff --git a/graphics/osg-devel/pkg-plist b/graphics/osg-devel/pkg-plist
index 00d42c704370..08c896cee138 100644
--- a/graphics/osg-devel/pkg-plist
+++ b/graphics/osg-devel/pkg-plist
@@ -20,6 +20,7 @@ include/osg/AnimationPath
include/osg/ApplicationUsage
include/osg/ArgumentParser
include/osg/Array
+include/osg/AudioStream
include/osg/AutoTransform
include/osg/Billboard
include/osg/BlendColor
@@ -190,6 +191,8 @@ include/osgAnimation/Export
include/osgAnimation/Interpolator
include/osgAnimation/Keyframe
include/osgAnimation/LinkVisitor
+include/osgAnimation/MorphGeometry
+include/osgAnimation/RigGeometry
include/osgAnimation/Sampler
include/osgAnimation/Skeleton
include/osgAnimation/Skinning
@@ -391,6 +394,7 @@ include/osgUtil/Export
include/osgUtil/GLObjectsVisitor
include/osgUtil/HalfWayMapGenerator
include/osgUtil/HighlightMapGenerator
+include/osgUtil/IncrementalCompileOperation
include/osgUtil/IntersectVisitor
include/osgUtil/IntersectionVisitor
include/osgUtil/LineSegmentIntersector
@@ -399,6 +403,7 @@ include/osgUtil/Optimizer
include/osgUtil/PlaneIntersector
include/osgUtil/PolytopeIntersector
include/osgUtil/PositionalStateContainer
+include/osgUtil/PrintVisitor
include/osgUtil/ReflectionMapGenerator
include/osgUtil/RenderBin
include/osgUtil/RenderLeaf
@@ -406,6 +411,7 @@ include/osgUtil/RenderStage
include/osgUtil/ReversePrimitiveFunctor
include/osgUtil/SceneGraphBuilder
include/osgUtil/SceneView
+include/osgUtil/ShaderGen
include/osgUtil/Simplifier
include/osgUtil/SmoothingVisitor
include/osgUtil/StateGraph
@@ -527,6 +533,7 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_dot.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dw.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dxf.so
%%OPENEXR%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_exr.so
+%%FFMPEG%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_ffmpeg.so
%%FREETYPE%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_freetype.so
%%GDAL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_gdal.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_geo.so