aboutsummaryrefslogtreecommitdiff
path: root/graphics/osg-devel
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-05-08 02:19:16 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-05-08 02:19:16 +0000
commit25f4de6f2e84eff64897d46dc2c76646d17e0d76 (patch)
tree56dd0172d8cc544a9af0ec028319cba1f1e9d38e /graphics/osg-devel
parent96da2a068ac6cbccfd5c1cdc300308e3ec4b4f31 (diff)
downloadports-25f4de6f2e84eff64897d46dc2c76646d17e0d76.tar.gz
ports-25f4de6f2e84eff64897d46dc2c76646d17e0d76.zip
Add back png and jpeg LIB_DEPENDS. Respect CXX and C
Noticed by: bento
Notes
Notes: svn path=/head/; revision=58686
Diffstat (limited to 'graphics/osg-devel')
-rw-r--r--graphics/osg-devel/Makefile4
-rw-r--r--graphics/osg-devel/files/patch-aa21
2 files changed, 20 insertions, 5 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index ed79f0b383a5..01bfa90748c9 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -12,7 +12,9 @@ MASTER_SITES= http://www.openscenegraph.org/download/snapshots/
MAINTAINER= aa8vb@nc.rr.com
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ freetype.9:${PORTSDIR}/print/freetype2
USE_X_PREFIX= yes
USE_MESA= yes
diff --git a/graphics/osg-devel/files/patch-aa b/graphics/osg-devel/files/patch-aa
index 819bf0517f91..d23aa1eadbe5 100644
--- a/graphics/osg-devel/files/patch-aa
+++ b/graphics/osg-devel/files/patch-aa
@@ -1,6 +1,19 @@
---- ./Make/ORIG/makedefs.freebsd Wed Jan 16 07:08:27 2002
-+++ ./Make/makedefs.freebsd Thu Mar 14 18:32:27 2002
-@@ -17,9 +17,9 @@
+--- Make/makedefs.freebsd.orig Wed Jan 16 04:08:27 2002
++++ Make/makedefs.freebsd Tue May 7 18:34:36 2002
+@@ -6,20 +6,20 @@
+ DEPFILES = $(OBJS:.o=.d)
+
+
+-C++ = g++
++C++ = ${CXX}
+ YFLAGS = -d
+ LCINCS += -I/usr/local/include -I/usr/X11R6/include
+ LC++INCS += ${LCINCS}
+-CFLAGS = -O2 -W -Wall $(LCINCS)
++CFLAGS += -W -Wall $(LCINCS)
+ C++FLAGS = ${CFLAGS}
+ CPPFLAGS = ${CFLAGS}
+
SO_EXT = so
DL_EXT = so
@@ -8,7 +21,7 @@
+FREEBSD_LOCALLIBS = -L/usr/local/lib -rpath /usr/local/lib -L/usr/X11R6/lib -rpath /usr/X11R6/lib
-LDFLAGS = -O2 -W -Wall -pthread -L/usr/local/lib -L/usr/X11R6/lib
-+LDFLAGS = -O2 -W -Wall -pthread $(FREEBSD_LOCALLIBS)
++LDFLAGS = -W -Wall -pthread $(FREEBSD_LOCALLIBS)
DYNAMICLIBRARYLIB =
PFLIBS =