aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Geo-Proj4
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-02-11 02:34:36 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-02-11 02:34:36 +0000
commitdd0812beb6b04b4be03f1b0967f82e3f1c4bbc9f (patch)
tree8faece26346acf3424ddbe8b5568d6aae502c1d9 /graphics/p5-Geo-Proj4
parente7a152f6122264906849b830c8b08e9d0ea1cd4d (diff)
downloadports-dd0812beb6b04b4be03f1b0967f82e3f1c4bbc9f.tar.gz
ports-dd0812beb6b04b4be03f1b0967f82e3f1c4bbc9f.zip
Add p5-Geo-Proj4, a Perl wrapper for the proj library.
PR: ports/92693 Submitted by: Eric Stith <estith.freebsd.ports@thelunarempire.net>
Notes
Notes: svn path=/head/; revision=155690
Diffstat (limited to 'graphics/p5-Geo-Proj4')
-rw-r--r--graphics/p5-Geo-Proj4/Makefile30
-rw-r--r--graphics/p5-Geo-Proj4/distinfo3
-rw-r--r--graphics/p5-Geo-Proj4/pkg-descr6
-rw-r--r--graphics/p5-Geo-Proj4/pkg-plist8
4 files changed, 47 insertions, 0 deletions
diff --git a/graphics/p5-Geo-Proj4/Makefile b/graphics/p5-Geo-Proj4/Makefile
new file mode 100644
index 000000000000..efd0ce284d72
--- /dev/null
+++ b/graphics/p5-Geo-Proj4/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Geo-Proj4
+# Date created: 27 January 2006
+# Whom: Eric Stith
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Proj4
+PORTVERSION= 0.96
+CATEGORIES= graphics devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Geo
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= estith.freebsd.ports@thelunarempire.net
+COMMENT= Perl cartographic projections wrapper for Proj library
+
+LIB_DEPENDS= proj:${PORTSDIR}/graphics/proj
+
+MAN3= Geo::Proj4.3
+CFLAGS+= -I ${PREFIX}/include # XXX - This seems ugly
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-Geo-Proj4/distinfo b/graphics/p5-Geo-Proj4/distinfo
new file mode 100644
index 000000000000..99d1b2359ca0
--- /dev/null
+++ b/graphics/p5-Geo-Proj4/distinfo
@@ -0,0 +1,3 @@
+MD5 (Geo-Proj4-0.96.tar.gz) = ad97612158c95562cee43485910fbf40
+SHA256 (Geo-Proj4-0.96.tar.gz) = f010153d3b1d3c017759b7fb7f2cfc61a9dce4662073cf6228872bff7b606e00
+SIZE (Geo-Proj4-0.96.tar.gz) = 18698
diff --git a/graphics/p5-Geo-Proj4/pkg-descr b/graphics/p5-Geo-Proj4/pkg-descr
new file mode 100644
index 000000000000..72e0816d712b
--- /dev/null
+++ b/graphics/p5-Geo-Proj4/pkg-descr
@@ -0,0 +1,6 @@
+The Open Source PROJ.4 library converts between geographic coordinate systems.
+It is able to convert between geodetic latitude and longitude (LL, most commonly
+the WGS84 projection), into an enormous variety of other cartographic
+projections (XY, usually UTM).
+
+WWW: http://search.cpan.org/dist/Geo-Proj4/
diff --git a/graphics/p5-Geo-Proj4/pkg-plist b/graphics/p5-Geo-Proj4/pkg-plist
new file mode 100644
index 000000000000..ca14165bdf73
--- /dev/null
+++ b/graphics/p5-Geo-Proj4/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/mach/Geo/Proj4.pm
+%%SITE_PERL%%/mach/Geo/Proj4.pod
+%%SITE_PERL%%/mach/auto/Geo/Proj4/.packlist
+%%SITE_PERL%%/mach/auto/Geo/Proj4/Proj4.bs
+%%SITE_PERL%%/mach/auto/Geo/Proj4/Proj4.so
+@dirrm %%SITE_PERL%%/mach/auto/Geo/Proj4
+@dirrmtry %%SITE_PERL%%/mach/auto/Geo
+@dirrmtry %%SITE_PERL%%/mach/Geo