aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-ming/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-08-08 00:56:34 +0000
committerSteve Wills <swills@FreeBSD.org>2011-08-08 00:56:34 +0000
commite9ee2a64038022e34ab4bf64f8b3eef6ac235766 (patch)
treeef4c01133a1d22c21468e35b1e450ece06e0d950 /graphics/p5-ming/Makefile
parent3b8a4becc66e5c6dae63ec9d04ec9031c49802bc (diff)
downloadports-e9ee2a64038022e34ab4bf64f8b3eef6ac235766.tar.gz
ports-e9ee2a64038022e34ab4bf64f8b3eef6ac235766.zip
- Fix fetch
- Update to 0.4.3 - Convert to slave of graphics/ming
Notes
Notes: svn path=/head/; revision=279166
Diffstat (limited to 'graphics/p5-ming/Makefile')
-rw-r--r--graphics/p5-ming/Makefile84
1 files changed, 46 insertions, 38 deletions
diff --git a/graphics/p5-ming/Makefile b/graphics/p5-ming/Makefile
index 2621b9245000..d6a8633f7c0d 100644
--- a/graphics/p5-ming/Makefile
+++ b/graphics/p5-ming/Makefile
@@ -6,47 +6,55 @@
#
PORTNAME= ming
-PORTVERSION= 0.3.0
-PORTREVISION= 2
+PORTREVISION= 0
CATEGORIES= graphics perl5
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-perl-${PORTVERSION}
+PKGNAMESUFFIX=
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl5 module for Ming which allows you to create Flash 4/5 movies
-BROKEN= does not fetch
-
-LIB_DEPENDS= ming.4:${PORTSDIR}/graphics/ming
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/perl_ext
-
-PERL_CONFIGURE= yes
-CONFIGURE_ENV= LOCALBASE="${LOCALBASE}"
-
-MAN3= SWF.3 \
- SWF::Action.3 \
- SWF::Bitmap.3 \
- SWF::Button.3 \
- SWF::Constants.3 \
- SWF::DisplayItem.3 \
- SWF::Morph.3 \
- SWF::Movie.3 \
- SWF::Shape.3 \
- SWF::Sound.3 \
- SWF::Sprite.3 \
- SWF::TextField.3 \
- SWF::VideoStream.3
-
-post-patch:
- @${ECHO_CMD} -n > ${WRKSRC}/../configure.in
- @${LN} -sf ${LOCALBASE}/include/ming ${WRKSRC}/../src
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/*.* ${EXAMPLESDIR}
-.endif
-
-.include <bsd.port.mk>
+SLAVE_PORT= p5
+MASTERDIR= ${.CURDIR}/../../graphics/ming
+PLIST= ${.CURDIR}/pkg-plist
+CONFIGURE_ARGS+= --enable-perl
+INSTALL_WRKSRC= ${WRKSRC}/perl_ext
+PATCHDIR= ${.CURDIR}/files
+USE_PERL5= yes
+
+MAN3= SWF.3 \
+ SWF::Action.3 \
+ SWF::BinaryData.3 \
+ SWF::Bitmap.3 \
+ SWF::Blur.3 \
+ SWF::BrowserFont.3 \
+ SWF::Button.3 \
+ SWF::ButtonRecord.3 \
+ SWF::CXform.3 \
+ SWF::Character.3 \
+ SWF::Constants.3 \
+ SWF::DisplayItem.3 \
+ SWF::Fill.3 \
+ SWF::Filter.3 \
+ SWF::FilterMatrix.3 \
+ SWF::Font.3 \
+ SWF::FontCharacter.3 \
+ SWF::FontCollection.3 \
+ SWF::Gradient.3 \
+ SWF::InitAction.3 \
+ SWF::Matrix.3 \
+ SWF::Morph.3 \
+ SWF::Movie.3 \
+ SWF::MovieClip.3 \
+ SWF::PrebuiltClip.3 \
+ SWF::Shadow.3 \
+ SWF::Shape.3 \
+ SWF::Sound.3 \
+ SWF::SoundInstance.3 \
+ SWF::SoundStream.3 \
+ SWF::Sprite.3 \
+ SWF::Text.3 \
+ SWF::TextField.3 \
+ SWF::VideoStream.3
+
+.include "${MASTERDIR}/Makefile"