aboutsummaryrefslogtreecommitdiff
path: root/graphics/pear-Image_Graph
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-15 05:18:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-05-15 05:18:25 +0000
commit91cd24b578281221e4c38a41d9b310263dd7819c (patch)
tree8f1dd22ae82b222befddf75a3cc63cb42f2eeba6 /graphics/pear-Image_Graph
parenta3f940658f445a1b51eb172a8c2c56e7704169d4 (diff)
downloadports-91cd24b578281221e4c38a41d9b310263dd7819c.tar.gz
ports-91cd24b578281221e4c38a41d9b310263dd7819c.zip
- Fix php53 issus
- Take over maintainership PR: 146555 Submitted by: olli hauer <ohauer@gmx.de> Approved by: Nick Hilliard <nick@foobar.org> (prev. maintainer)
Notes
Notes: svn path=/head/; revision=254339
Diffstat (limited to 'graphics/pear-Image_Graph')
-rw-r--r--graphics/pear-Image_Graph/Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/graphics/pear-Image_Graph/Makefile b/graphics/pear-Image_Graph/Makefile
index 238a92c027b8..d5a172df712b 100644
--- a/graphics/pear-Image_Graph/Makefile
+++ b/graphics/pear-Image_Graph/Makefile
@@ -10,13 +10,16 @@ PORTVERSION= 0.7.2
PORTREVISION= 2
CATEGORIES= graphics www pear
-MAINTAINER= nick@foobar.org
+MAINTAINER= miwi@FreeBSD.org
COMMENT= An OO PEAR graph rendering package
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log \
${PEARDIR}/Image/Canvas.php:${PORTSDIR}/graphics/pear-Image_Canvas
+USE_PHP= yes
+USE_DOS2UNIX= yes
+
CATEGORY= Image
FILES= Graph.php Graph/Axis.php Graph/Common.php Graph/Config.php \
Graph/Constants.php Graph/DataPreprocessor.php \
@@ -163,12 +166,23 @@ DOCS= ChangeLog colors.txt LICENSE README examples/antialias.php \
LATEST_LINK= pear-Image_Graph
+.include <bsd.port.pre.mk>
post-patch:
+# don't modify images
.for file in ${FILES}
- @${REINPLACE_CMD} -e "s|@package_version@|${DISTVERSION}|" ${WRKSRC}/${file}
+ @if ${ECHO_CMD} ${file} | ${GREP} -q -e "php$$" ; then \
+ ${REINPLACE_CMD} -e "s|@package_version@|${DISTVERSION}|" ${WRKSRC}/${file}; \
+ fi
.endfor
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+# fix for php5.3, see http://pear.php.net/bugs/bug.php?id=16529
+.if ${PHP_VER} != 4
+.for file in ${FILES}
+ @if ${ECHO_CMD} ${file} | ${GREP} -q -e "php$$" ; then \
+ ${REINPLACE_CMD} -e 's|parent::Image[^(]*|parent::__construct|' ${WRKSRC}/${file}; \
+ fi
+.endfor
+.endif
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>