aboutsummaryrefslogtreecommitdiff
path: root/graphics/pecomato
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-25 15:46:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-25 15:46:07 +0000
commit5055e5aee5e0b3c8a3654b5318a2575d9fc53be0 (patch)
tree3fb4721073b3e0ac19a65e6063cbf3747c36805d /graphics/pecomato
parent09bc6e62037d0a457a54dee9279858846b4b2171 (diff)
downloadports-5055e5aee5e0b3c8a3654b5318a2575d9fc53be0.tar.gz
ports-5055e5aee5e0b3c8a3654b5318a2575d9fc53be0.zip
- Fix build after addition of getdelim() and strndup()
PR: 133053 Submitted by: David Schultz <das@freebsd.org>
Notes
Notes: svn path=/head/; revision=230984
Diffstat (limited to 'graphics/pecomato')
-rw-r--r--graphics/pecomato/files/patch-Makefile.unix15
-rw-r--r--graphics/pecomato/files/patch-util.h24
2 files changed, 33 insertions, 6 deletions
diff --git a/graphics/pecomato/files/patch-Makefile.unix b/graphics/pecomato/files/patch-Makefile.unix
new file mode 100644
index 000000000000..2bc36b1146bf
--- /dev/null
+++ b/graphics/pecomato/files/patch-Makefile.unix
@@ -0,0 +1,15 @@
+--- Makefile.unix.orig 2009-03-25 03:04:17.000000000 -0400
++++ Makefile.unix 2009-03-25 03:15:45.000000000 -0400
+@@ -27,7 +27,11 @@
+ SRC_PREFIX = $(shell pwd)/dist-src
+
+ TARGET = $(PRODUCT)
+-OBJECTS = main.o gnu-strndup.o gnu-getline.o util.o exif.o iptc.o jfif.o adobe.o tiff.o
++OBJECTS = main.o util.o exif.o iptc.o jfif.o adobe.o tiff.o
++NEEDEXT = $(shell expr $(OSVERSION) \< 800067)
++ifeq ($(NEEDEXT),1)
++OBJECTS += gnu-strndup.o gnu-getline.o
++endif
+ DOC_DEFS = doc/Makefile.defs
+
+
diff --git a/graphics/pecomato/files/patch-util.h b/graphics/pecomato/files/patch-util.h
index cc78007ca30b..864049fd075a 100644
--- a/graphics/pecomato/files/patch-util.h
+++ b/graphics/pecomato/files/patch-util.h
@@ -1,10 +1,22 @@
---- util.h.orig Mon Dec 18 20:22:56 2006
-+++ util.h Mon Dec 18 20:23:03 2006
-@@ -8,6 +8,7 @@
-
- #ifndef _util_h_
+--- util.h.orig 2007-09-28 12:04:57.000000000 -0400
++++ util.h 2009-03-25 03:18:26.000000000 -0400
+@@ -10,6 +10,7 @@
#define _util_h_
-+#define _SSIZE_T_DECLARED
++#include <sys/param.h>
#include <stdio.h>
+ #include <stdarg.h>
+
+@@ -67,9 +68,11 @@
+ #define _SSIZE_T_DECLARED
+ #endif
+ #endif
++#if __FreeBSD_version < 800067
+ #include "gnu-getline.h"
+ #include "gnu-strndup.h"
+ #endif
++#endif
+
+ /* Microsoft Windows specific defines */
+ #ifdef OS_WIN32