aboutsummaryrefslogtreecommitdiff
path: root/graphics/pgplot/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-10-05 03:06:04 +0000
committerSteve Price <steve@FreeBSD.org>1998-10-05 03:06:04 +0000
commit802ef209411e50dc00c963a289649adcab3fa50e (patch)
tree4a734eabbc448ce164a8e88250ffbfcf9b2f0ffe /graphics/pgplot/Makefile
parent9db5d22a99cc8629a1eabc0aa0593f263a0b77d4 (diff)
downloadports-802ef209411e50dc00c963a289649adcab3fa50e.tar.gz
ports-802ef209411e50dc00c963a289649adcab3fa50e.zip
Convert to ELF.
Notes
Notes: svn path=/head/; revision=13649
Diffstat (limited to 'graphics/pgplot/Makefile')
-rw-r--r--graphics/pgplot/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/graphics/pgplot/Makefile b/graphics/pgplot/Makefile
index 81660913e855..0aedceae0523 100644
--- a/graphics/pgplot/Makefile
+++ b/graphics/pgplot/Makefile
@@ -3,7 +3,7 @@
# Date created: 21 December 1996
# Whom: jmz
#
-# $Id: Makefile,v 1.3 1997/07/17 15:12:44 max Exp $
+# $Id: Makefile,v 1.4 1997/08/15 13:36:01 jmz Exp $
#
DISTNAME= pgplot5.2
@@ -16,6 +16,15 @@ MAINTAINER= jmz@FreeBSD.org
WRKSRC= ${WRKDIR}/pgplot
post-install:
- ${LDCONFIG} -m ${PREFIX}/lib
+.for f in libcpgplot.so libpgplot.so
+ ${LN} -sf $f.${VERSION} ${PREFIX}/lib/$f
+.endfor
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+VERSION= 5
+.else
+VERSION= 5.2
+.endif