aboutsummaryrefslogtreecommitdiff
path: root/graphics/pgplot
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-10-05 03:06:04 +0000
committerSteve Price <steve@FreeBSD.org>1998-10-05 03:06:04 +0000
commit802ef209411e50dc00c963a289649adcab3fa50e (patch)
tree4a734eabbc448ce164a8e88250ffbfcf9b2f0ffe /graphics/pgplot
parent9db5d22a99cc8629a1eabc0aa0593f263a0b77d4 (diff)
downloadports-802ef209411e50dc00c963a289649adcab3fa50e.tar.gz
ports-802ef209411e50dc00c963a289649adcab3fa50e.zip
Convert to ELF.
Notes
Notes: svn path=/head/; revision=13649
Diffstat (limited to 'graphics/pgplot')
-rw-r--r--graphics/pgplot/Makefile13
-rw-r--r--graphics/pgplot/files/Makefile2
-rw-r--r--graphics/pgplot/files/xf774
-rw-r--r--graphics/pgplot/pkg-plist9
4 files changed, 20 insertions, 8 deletions
diff --git a/graphics/pgplot/Makefile b/graphics/pgplot/Makefile
index 81660913e855..0aedceae0523 100644
--- a/graphics/pgplot/Makefile
+++ b/graphics/pgplot/Makefile
@@ -3,7 +3,7 @@
# Date created: 21 December 1996
# Whom: jmz
#
-# $Id: Makefile,v 1.3 1997/07/17 15:12:44 max Exp $
+# $Id: Makefile,v 1.4 1997/08/15 13:36:01 jmz Exp $
#
DISTNAME= pgplot5.2
@@ -16,6 +16,15 @@ MAINTAINER= jmz@FreeBSD.org
WRKSRC= ${WRKDIR}/pgplot
post-install:
- ${LDCONFIG} -m ${PREFIX}/lib
+.for f in libcpgplot.so libpgplot.so
+ ${LN} -sf $f.${VERSION} ${PREFIX}/lib/$f
+.endfor
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+VERSION= 5
+.else
+VERSION= 5.2
+.endif
diff --git a/graphics/pgplot/files/Makefile b/graphics/pgplot/files/Makefile
index 6060abb8c395..d2d5a3776722 100644
--- a/graphics/pgplot/files/Makefile
+++ b/graphics/pgplot/files/Makefile
@@ -6,7 +6,7 @@ all:
make -f Makefile.doc
install:
- install -c *.a *.so.5.2 ${PREFIX}/lib
+ install -c *.a *.so.5* ${PREFIX}/lib
mkdir -p ${PREFIX}/share/pgplot
install -c grfont.dat rgb.txt pgplot.doc pgplot.html pgplot-routines.tex cpg/cpgplot.doc ${PREFIX}/share/pgplot
install -c cpgplot.h ${PREFIX}/include
diff --git a/graphics/pgplot/files/xf77 b/graphics/pgplot/files/xf77
index cd8a80e475c9..554d36ecd08f 100644
--- a/graphics/pgplot/files/xf77
+++ b/graphics/pgplot/files/xf77
@@ -8,10 +8,10 @@ $myname = $0;
$count = 0;
while ($ARGV[0] =~ /^-/) {
- $opt . = " $ARGV[0]";
+ $opt .= " $ARGV[0]";
if ($ARGV[0] eq "-o") {
shift;
- $opt . = " $ARGV[0]";
+ $opt .= " $ARGV[0]";
}
shift;
}
diff --git a/graphics/pgplot/pkg-plist b/graphics/pgplot/pkg-plist
index 79efc5db7e28..c4ac9e295e47 100644
--- a/graphics/pgplot/pkg-plist
+++ b/graphics/pgplot/pkg-plist
@@ -2,11 +2,13 @@ bin/pgxwin_server
bin/pgdisp
include/cpgplot.h
lib/libcpgplot.a
+lib/libcpgplot.so
lib/libcpgplot.so.5.2
lib/libpgplot.a
-lib/libpgplot.so.5.2
-@exec /sbin/ldconfig -m %D/lib
-@unexec /sbin/ldconfig -R
+lib/libpgplot.so
+lib/libpgplot.so.5.2
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %D/lib
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
share/pgplot/Makefile.demo
share/pgplot/cpgdemo.c
share/pgplot/cpgplot.doc
@@ -33,3 +35,4 @@ share/pgplot/pgdemo14.f
share/pgplot/pgdemo15.f
share/pgplot/pgdemo16.f
share/pgplot/pgdemo17.f
+@dirrm share/pgplot