aboutsummaryrefslogtreecommitdiff
path: root/graphics/picviz
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-11-11 12:18:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-11-11 12:18:38 +0000
commitc6084df9746a4134299f5a3054646416afb33a34 (patch)
tree63566a5f4f315b152d3a4897424aea0efd3af81c /graphics/picviz
parent6fa559831981b846ed55fef7529e8d1a8eec784d (diff)
downloadports-c6084df9746a4134299f5a3054646416afb33a34.tar.gz
ports-c6084df9746a4134299f5a3054646416afb33a34.zip
Picviz is a parallel coordinates plotter which enables easy scripting from
various input (tcpdump, syslog, iptables logs, apache logs, etc..) to visualize your data and discover interesting results quickly. Picviz helps you to create, automate and understand parallel coordinates plots. Its primary goal is to graph data in order to be able to quickly analyze problems and find correlations among variables. With security analysis in mind, the program has been designed to be very flexible, able to graph millions of events. The language is designed to be close to the graphviz graph description language. WWW: http://www.wallinfire.net/picviz PR: 128705 Submitted by: Tim Hemel <ports at timit dot nl>
Notes
Notes: svn path=/head/; revision=222732
Diffstat (limited to 'graphics/picviz')
-rw-r--r--graphics/picviz/Makefile26
-rw-r--r--graphics/picviz/distinfo3
-rw-r--r--graphics/picviz/files/patch-doc-CMakeLists.txt8
-rw-r--r--graphics/picviz/files/patch-src-libpicviz-CMakeLists.txt27
-rw-r--r--graphics/picviz/files/patch-src-libpicviz-parser-lexer.l51
-rw-r--r--graphics/picviz/files/patch-src-libpicviz-values-mapping.c10
-rw-r--r--graphics/picviz/pkg-descr15
-rw-r--r--graphics/picviz/pkg-plist33
8 files changed, 173 insertions, 0 deletions
diff --git a/graphics/picviz/Makefile b/graphics/picviz/Makefile
new file mode 100644
index 000000000000..bfee1a4063b5
--- /dev/null
+++ b/graphics/picviz/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: picviz
+# Date created: 08 Nov 2008
+# Whom: Tim Hemel
+#
+# $FreeBSD$
+#
+
+PORTNAME= picviz
+PORTVERSION= 0.4
+CATEGORIES= graphics security
+MASTER_SITES= http://www.wallinfire.net/picviz/attachment/wiki/ReleasesDownload/
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}?format=raw
+
+MAINTAINER= ports@timit.nl
+COMMENT= Parallel coordinates plotter
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
+ cairo.2:${PORTSDIR}/graphics/cairo
+
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+USE_BISON= build
+
+MAN1= pcv.1
+
+.include <bsd.port.mk>
diff --git a/graphics/picviz/distinfo b/graphics/picviz/distinfo
new file mode 100644
index 000000000000..aa172703f8fb
--- /dev/null
+++ b/graphics/picviz/distinfo
@@ -0,0 +1,3 @@
+MD5 (picviz-0.4.tar.gz?format=raw) = 92aecf1465a278095611d01fb4e86d28
+SHA256 (picviz-0.4.tar.gz?format=raw) = 57a65bf942350904c72c6710cebdebe20c9dea315b865c5ba6128503b70624f2
+SIZE (picviz-0.4.tar.gz?format=raw) = 1587160
diff --git a/graphics/picviz/files/patch-doc-CMakeLists.txt b/graphics/picviz/files/patch-doc-CMakeLists.txt
new file mode 100644
index 000000000000..3e8c91e25cdd
--- /dev/null
+++ b/graphics/picviz/files/patch-doc-CMakeLists.txt
@@ -0,0 +1,8 @@
+--- doc/CMakeLists.txt.orig 2008-10-27 14:39:31.000000000 +0300
++++ doc/CMakeLists.txt 2008-11-10 01:56:33.000000000 +0300
+@@ -1,4 +1,4 @@
+ set(manpages pcv.1)
+
+-install(FILES ${manpages} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/${MAN_DIR}/man1)
++install(FILES ${manpages} DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1)
+
diff --git a/graphics/picviz/files/patch-src-libpicviz-CMakeLists.txt b/graphics/picviz/files/patch-src-libpicviz-CMakeLists.txt
new file mode 100644
index 000000000000..3c2ccd8c1287
--- /dev/null
+++ b/graphics/picviz/files/patch-src-libpicviz-CMakeLists.txt
@@ -0,0 +1,27 @@
+--- src/libpicviz/CMakeLists.txt.orig 2008-10-27 14:39:31.000000000 +0300
++++ src/libpicviz/CMakeLists.txt 2008-11-10 02:00:01.000000000 +0300
+@@ -1,7 +1,7 @@
+ add_subdirectory(plugins)
+ #add_subdirectory(bindings)
+
+-include_directories(${picviz_SOURCE_DIR}/src/libpicviz/include ${picviz_SOURCE_DIR}/src/libpicviz/parser ${picviz_SOURCE_DIR}/src/libpicviz/props)
++include_directories(${picviz_SOURCE_DIR}/src/libpicviz/include ${picviz_SOURCE_DIR}/src/libpicviz/parser ${picviz_SOURCE_DIR}/src/libpicviz/props ${PCRE_INCLUDE_DIR})
+
+ #set(CMAKE_SHARED_LINKER_FLAGS "-lm -lfl -ly")
+ configure_file(
+@@ -26,7 +26,7 @@
+
+ set_target_properties(picviz PROPERTIES SOVERSION 1)
+
+-target_link_libraries(picviz "-lm -ldl")
++target_link_libraries(picviz "-lm")
+
+ install(TARGETS picviz LIBRARY DESTINATION ${LIB_INSTALL_DIR})
+ INSTALL(FILES
+@@ -55,5 +55,5 @@
+ PERMISSIONS OWNER_READ GROUP_READ WORLD_READ)
+
+ INSTALL(FILES ${picviz_BINARY_DIR}/src/libpicviz/picviz.pc
+- DESTINATION ${LIB_INSTALL_DIR}/pkgconfig/ )
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig/ )
+
diff --git a/graphics/picviz/files/patch-src-libpicviz-parser-lexer.l b/graphics/picviz/files/patch-src-libpicviz-parser-lexer.l
new file mode 100644
index 000000000000..0a185ad0af63
--- /dev/null
+++ b/graphics/picviz/files/patch-src-libpicviz-parser-lexer.l
@@ -0,0 +1,51 @@
+--- src/libpicviz/parser/lexer.l.orig 2008-10-27 12:39:31.000000000 +0100
++++ src/libpicviz/parser/lexer.l 2008-11-08 17:11:55.000000000 +0100
+@@ -19,7 +19,27 @@
+ static char *realfile;
+
+ void yyerror (char *s);
++
++#ifdef __FreeBSD__
++char* strndup(const char* string, size_t n)
++{
++ char* copy_string = 0;
++
++ if(0 == string || 0 == n)
++ return 0;
++
++ copy_string = (char*) malloc(n + 1);
++ if(0 == copy_string)
++ return 0;
++
++ memcpy(copy_string, string, n);
++ *(copy_string + n) = '\0';
++
++ return copy_string;
++}
++#else
+ char * strndup (const char *s, size_t n);
++#endif
+
+ #define MAX_INCLUDE_DEPTH 10
+ YY_BUFFER_STATE includes[MAX_INCLUDE_DEPTH];
+@@ -48,7 +68,20 @@
+ return str;
+ }
+
++void yyset_lineno(int line_number) {
++ yylineno = line_number;
++}
++
++int yyget_lineno() {
++ return yylineno;
++}
++
++char * yyget_text() {
++ return yytext;
++}
++
+ %}
++%option yylineno
+ %option noyywrap
+
+ SECTION (header|engine|axes|data)
diff --git a/graphics/picviz/files/patch-src-libpicviz-values-mapping.c b/graphics/picviz/files/patch-src-libpicviz-values-mapping.c
new file mode 100644
index 000000000000..0968015c9a12
--- /dev/null
+++ b/graphics/picviz/files/patch-src-libpicviz-values-mapping.c
@@ -0,0 +1,10 @@
+--- src/libpicviz/values-mapping.c.orig 2008-11-08 16:07:44.000000000 +0100
++++ src/libpicviz/values-mapping.c 2008-11-08 16:08:33.000000000 +0100
+@@ -24,6 +24,7 @@
+ #include <sys/socket.h>
+ #include <netdb.h>
+ #include <ctype.h>
++#include <netinet/in.h>
+
+
+ #if defined(__linux__) && ! defined(__USE_XOPEN)
diff --git a/graphics/picviz/pkg-descr b/graphics/picviz/pkg-descr
new file mode 100644
index 000000000000..7b4eebbcb3b8
--- /dev/null
+++ b/graphics/picviz/pkg-descr
@@ -0,0 +1,15 @@
+Picviz is a parallel coordinates plotter which enables easy scripting from
+various input (tcpdump, syslog, iptables logs, apache logs, etc..) to visualize
+your data and discover interesting results quickly.
+
+Picviz helps you to create, automate and understand parallel coordinates plots.
+
+Its primary goal is to graph data in order to be able to quickly analyze
+problems and find correlations among variables. With security analysis in mind,
+the program has been designed to be very flexible, able to graph millions of
+events.
+
+The language is designed to be close to the graphviz graph description
+language.
+
+WWW: http://www.wallinfire.net/picviz
diff --git a/graphics/picviz/pkg-plist b/graphics/picviz/pkg-plist
new file mode 100644
index 000000000000..f9ab1346005a
--- /dev/null
+++ b/graphics/picviz/pkg-plist
@@ -0,0 +1,33 @@
+bin/pcv
+include/picviz/axis.h
+include/picviz/common.h
+include/picviz/correlation.h
+include/picviz/debug.h
+include/picviz/defaults.h
+include/picviz/draw.h
+include/picviz/engine.h
+include/picviz/filter.h
+include/picviz/image.h
+include/picviz/learn.h
+include/picviz/line.h
+include/picviz/linuxlist.h
+include/picviz/pcimage.h
+include/picviz/picviz-pcre.h
+include/picviz/picviz.h
+include/picviz/plugins.h
+include/picviz/properties.h
+include/picviz/render.h
+include/picviz/types.h
+include/picviz/values-mapping.h
+include/picviz/variable.h
+lib/libpicviz.so
+lib/libpicviz.so.1
+lib/picviz/libpicvizoutcsv.so
+lib/picviz/libpicvizoutdebug.so
+lib/picviz/libpicvizoutpngcairo.so
+lib/picviz/libpicvizoutsvg.so
+lib/picviz/libpicvizrendebug.so
+lib/picviz/libpicvizrenheatline.so
+libdata/pkgconfig/picviz.pc
+@dirrm lib/picviz
+@dirrm include/picviz